mirror of
https://github.com/Lienol/openwrt
synced 2025-01-07 03:06:49 +08:00
r8125: update to version 9.010.01-2
This commit is contained in:
parent
4d33175879
commit
9508988f0e
@ -7,12 +7,12 @@ include $(TOPDIR)/rules.mk
|
||||
include $(INCLUDE_DIR)/kernel.mk
|
||||
|
||||
PKG_NAME:=r8125
|
||||
PKG_VERSION:=9.009.02-1
|
||||
PKG_VERSION:=9.010.01-2
|
||||
PKG_RELEASE:=$(AUTORELEASE)
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://codeload.github.com/awesometic/realtek-r8125-dkms/tar.gz/$(PKG_VERSION)?
|
||||
PKG_HASH:=e3f0a0a02a4ba847cb962ea7e12c89e3f4ab732944f04ebeb76d4d9711fa8ca6
|
||||
PKG_HASH:=b3e1b36578ba92a775049535e7434a9fc46710a721846c3706aca3d265db8cb9
|
||||
PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/realtek-$(PKG_NAME)-dkms-$(PKG_VERSION)
|
||||
|
||||
PKG_LICENSE:=GPL-2.0-only
|
||||
|
18
package/kernel/r8125/patches/020-5.19-support.patch
Normal file
18
package/kernel/r8125/patches/020-5.19-support.patch
Normal file
@ -0,0 +1,18 @@
|
||||
--- a/src/r8125_n.c
|
||||
+++ b/src/r8125_n.c
|
||||
@@ -116,6 +116,15 @@
|
||||
#define FIRMWARE_8168FP_3 "rtl_nic/rtl8168fp-3.fw"
|
||||
#define FIRMWARE_8168FP_4 "rtl_nic/rtl8168fp-4.fw"
|
||||
|
||||
+#if LINUX_VERSION_CODE >= KERNEL_VERSION(5, 19, 0)
|
||||
+static inline void netif_set_gso_max_size(struct net_device *dev,
|
||||
+ unsigned int size)
|
||||
+{
|
||||
+ /* dev->gso_max_size is read locklessly from sk_setup_caps() */
|
||||
+ WRITE_ONCE(dev->gso_max_size, size);
|
||||
+}
|
||||
+#endif
|
||||
+
|
||||
/* Maximum number of multicast addresses to filter (vs. Rx-all-multicast).
|
||||
The RTL chips use a 64 element hash table based on the Ethernet CRC. */
|
||||
static const int multicast_filter_limit = 32;
|
@ -8,7 +8,7 @@
|
||||
#include <linux/if_vlan.h>
|
||||
#include <linux/crc32.h>
|
||||
#include <linux/interrupt.h>
|
||||
@@ -10407,6 +10408,23 @@ rtl8125_setup_mqs_reg(struct rtl8125_private *tp)
|
||||
@@ -10425,6 +10426,23 @@ rtl8125_setup_mqs_reg(struct rtl8125_private *tp)
|
||||
}
|
||||
}
|
||||
|
||||
@ -32,7 +32,7 @@
|
||||
static void
|
||||
rtl8125_init_software_variable(struct net_device *dev)
|
||||
{
|
||||
@@ -10838,6 +10856,8 @@ rtl8125_init_software_variable(struct net_device *dev)
|
||||
@@ -10856,6 +10874,8 @@ rtl8125_init_software_variable(struct net_device *dev)
|
||||
if (tp->InitRxDescType == RX_DESC_RING_TYPE_3)
|
||||
tp->rtl8125_rx_config |= EnableRxDescV3;
|
||||
|
Loading…
Reference in New Issue
Block a user