Merge pull request #624 from 1582130940/lede-origin

packages: Sync with upstream
This commit is contained in:
coolsnowwolf 2022-12-16 11:42:04 +08:00 committed by GitHub
commit 12674bdfbd
No known key found for this signature in database
GPG Key ID: 4AEE18F83AFDEB23
5 changed files with 10 additions and 28 deletions

View File

@ -3,7 +3,7 @@ menu "Configuration"
config PERL_THREADS
bool "Enable threading support"
default y if (mips || mipsel || i386 || i686 || x86_64 || armeb || arm)
default y if (mips || mipsel || i386 || i686 || x86_64 || armeb || arm || aarch64)
default n
config PERL_TESTS

View File

@ -2,11 +2,11 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=python-pycares
PKG_VERSION:=4.2.2
PKG_RELEASE:=$(AUTORELEASE)
PKG_VERSION:=4.3.0
PKG_RELEASE:=1
PYPI_NAME:=pycares
PKG_HASH:=e1f57a8004370080694bd6fb969a1ffc9171a59c6824d54f791c1b2e4d298385
PKG_HASH:=c542696f6dac978e9d99192384745a65f80a7d9450501151e4a7563e06010d45
PKG_LICENSE:=MIT
PKG_LICENSE_FILES:=LICENSE

View File

@ -1,11 +1,11 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=yt-dlp
PKG_VERSION:=2022.9.1
PKG_VERSION:=2022.11.11
PKG_RELEASE:=1
PYPI_NAME:=yt-dlp
PKG_HASH:=bc74ee255790043e458197aaf25c6c104fefc9fcda4458f652619447ab4ae0d7
PKG_HASH:=f6b962023c17a77151476f0f6ed71be87d017629ba5d9994528bc548521191b6
PKG_MAINTAINER:=Michal Vasilek <michal.vasilek@nic.cz>
PKG_LICENSE:=Unlicense

View File

@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=nano
PKG_VERSION:=7.0
PKG_RELEASE:=$(AUTORELEASE)
PKG_VERSION:=7.1
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@GNU/nano
PKG_HASH:=8dd6eac38b2b8786d82681f0e1afd84f6b75210d17391b6443c437e451552149
PKG_HASH:=57ba751e9b7519f0f6ddee505202e387c75dde440c1f7aa1b9310cc381406836
PKG_LICENSE:=GPL-3.0-or-later
PKG_LICENSE_FILES:=COPYING
@ -90,7 +90,6 @@ else ifeq ($(BUILD_VARIANT),plus)
# plus variant with some features included
CONFIGURE_ARGS += \
--enable-help \
--enable-justify \
--enable-linenumbers \
--enable-multibuffer \
--enable-nanorc \
@ -100,6 +99,7 @@ else ifeq ($(BUILD_VARIANT),plus)
--disable-comment \
--disable-extra \
--disable-histories \
--disable-justify \
--disable-libmagic \
--disable-mouse \
--disable-operatingdir \

View File

@ -1,18 +0,0 @@
--- a/src/nano.c
+++ b/src/nano.c
@@ -1395,11 +1395,14 @@ bool changes_something(const void *f)
#ifndef NANO_TINY
f == chop_previous_word || f == chop_next_word ||
f == zap_text || f == cut_till_eof || f == do_execute ||
- f == do_indent || f == do_unindent || f == do_comment ||
+ f == do_indent || f == do_unindent ||
#endif
#ifdef ENABLE_JUSTIFY
f == do_justify || f == do_full_justify ||
#endif
+#ifdef ENABLE_COMMENT
+ f == do_comment ||
+#endif
#ifdef ENABLE_SPELLER
f == do_spell ||
#endif