mirror of
https://github.com/coolsnowwolf/packages
synced 2025-01-07 07:07:02 +08:00
hiredis: update to version 1.1.0
See project release page[1] for more details. Switch build to use CMake instead of autotools, allows removal of local patch. [1]: https://github.com/redis/hiredis/releases Signed-off-by: Daniel Golle <daniel@makrotopia.org>
This commit is contained in:
parent
05852dbc15
commit
16bb930e26
@ -8,21 +8,22 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=hiredis
|
||||
PKG_VERSION:=1.0.2
|
||||
PKG_VERSION:=1.1.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://codeload.github.com/redis/hiredis/tar.gz/v$(PKG_VERSION)?
|
||||
PKG_HASH:=e0ab696e2f07deb4252dda45b703d09854e53b9703c7d52182ce5a22616c3819
|
||||
PKG_HASH:=fe6d21741ec7f3fc9df409d921f47dfc73a4d8ff64f4ac6f1d95f951bf7f53d6
|
||||
|
||||
PKG_LICENSE:=BSD-3-Clause
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
|
||||
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
PKG_INSTALL:=1
|
||||
CMAKE_INSTALL:=1
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
include $(INCLUDE_DIR)/cmake.mk
|
||||
|
||||
define Package/libhiredis
|
||||
SECTION:=libs
|
||||
@ -35,17 +36,6 @@ define Package/libhiredis/description
|
||||
Hiredis is a minimalistic C client library for the Redis database.
|
||||
endef
|
||||
|
||||
MAKE_FLAGS += ARCH="" DEBUG="" PREFIX="/usr" uname_S="Linux"
|
||||
|
||||
define Build/InstallDev
|
||||
$(INSTALL_DIR) $(1)/usr/include/hiredis/adapters
|
||||
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/include/hiredis/adapters/* $(1)/usr/include/hiredis/adapters
|
||||
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/include/hiredis/*.h $(1)/usr/include/hiredis/
|
||||
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libhiredis.{so*,a} $(1)/usr/lib/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/hiredis.pc $(1)/usr/lib/pkgconfig
|
||||
endef
|
||||
|
||||
define Package/libhiredis/install
|
||||
$(INSTALL_DIR) $(1)/usr/lib/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libhiredis.so* $(1)/usr/lib/
|
||||
|
@ -1,32 +0,0 @@
|
||||
commit f96d9f9d2e3ba39352035e6ac26463243484d404
|
||||
Author: Sebastian Kemper <sebastian_ml@gmx.net>
|
||||
Date: Sun Jan 13 19:25:52 2019 +0100
|
||||
|
||||
Setup .pc file to allow use for cross-compiling
|
||||
|
||||
The Makefile is currently creating the pkg-config file using static lib
|
||||
and include dir statements. Change that so that projects that
|
||||
cross-compile hiredis can use pkg-config to setup other programs
|
||||
depending on it.
|
||||
|
||||
Note: these projects (like OpenWrt) call pkg-config with arguments to
|
||||
overwrite some variables in the .pc file, namely:
|
||||
|
||||
--define-variable=prefix=<...>
|
||||
--define-variable=exec_prefix=<...>
|
||||
|
||||
Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
|
||||
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -234,8 +234,8 @@ $(PKGCONFNAME): hiredis.h
|
||||
@echo "Generating $@ for pkgconfig..."
|
||||
@echo prefix=$(PREFIX) > $@
|
||||
@echo exec_prefix=\$${prefix} >> $@
|
||||
- @echo libdir=$(PREFIX)/$(LIBRARY_PATH) >> $@
|
||||
- @echo includedir=$(PREFIX)/$(INCLUDE_PATH) >> $@
|
||||
+ @echo libdir=\$${exec_prefix}/$(LIBRARY_PATH) >> $@
|
||||
+ @echo includedir=\$${prefix}/$(INCLUDE_PATH) >> $@
|
||||
@echo >> $@
|
||||
@echo Name: hiredis >> $@
|
||||
@echo Description: Minimalistic C client library for Redis. >> $@
|
Loading…
Reference in New Issue
Block a user