mirror of
https://github.com/coolsnowwolf/packages
synced 2025-01-07 07:07:02 +08:00
libv4l: update to 1.22.1
Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
4bc31916b4
commit
26c94e2454
@ -6,17 +6,16 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=v4l-utils
|
||||
PKG_VERSION:=1.20.0
|
||||
PKG_RELEASE:=5
|
||||
PKG_VERSION:=1.22.1
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=https://www.linuxtv.org/downloads/v4l-utils
|
||||
PKG_HASH:=956118713f7ccb405c55c7088a6a2490c32d54300dd9a30d8d5008c28d3726f7
|
||||
PKG_HASH:=65c6fbe830a44ca105c443b027182c1b2c9053a91d1e72ad849dfab388b94e31
|
||||
|
||||
PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
|
||||
|
||||
PKG_USE_MIPS16:=0
|
||||
PKG_FIXUP:=autoreconf
|
||||
PKG_INSTALL:=1
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
|
||||
@ -75,7 +74,6 @@ define Package/v4l-utils/description
|
||||
endef
|
||||
|
||||
TARGET_CFLAGS += -flto
|
||||
TARGET_CXXFLAGS += -std=c++11
|
||||
TARGET_LDFLAGS += \
|
||||
$(if $(CONFIG_USE_GLIBC),,-largp) \
|
||||
-Wl,--gc-sections,--as-needed
|
||||
|
@ -1,10 +0,0 @@
|
||||
--- a/utils/libcecutil/cec-info.cpp
|
||||
+++ b/utils/libcecutil/cec-info.cpp
|
||||
@@ -5,6 +5,7 @@
|
||||
* Copyright 2017 Cisco Systems, Inc. and/or its affiliates. All rights reserved.
|
||||
*/
|
||||
|
||||
+#include <cctype>
|
||||
#include <stdio.h>
|
||||
#include <string>
|
||||
#include <unistd.h>
|
@ -1,28 +0,0 @@
|
||||
--- a/utils/v4l2-ctl/v4l2-ctl-common.cpp
|
||||
+++ b/utils/v4l2-ctl/v4l2-ctl-common.cpp
|
||||
@@ -785,15 +785,17 @@ static bool parse_subset(char *optarg)
|
||||
|
||||
static bool parse_next_subopt(char **subs, char **value)
|
||||
{
|
||||
- static char *const subopts[] = {
|
||||
- NULL
|
||||
- };
|
||||
- int opt = getsubopt(subs, subopts, value);
|
||||
+ char *p = *subs;
|
||||
+ *value = *subs;
|
||||
|
||||
- if (opt < 0 || *value)
|
||||
- return false;
|
||||
- fprintf(stderr, "Missing suboption value\n");
|
||||
- return true;
|
||||
+ while (*p && *p != ',')
|
||||
+ p++;
|
||||
+
|
||||
+ if (*p)
|
||||
+ *p++ = '\0';
|
||||
+
|
||||
+ *subs = p;
|
||||
+ return false;
|
||||
}
|
||||
|
||||
void common_cmd(const std::string &media_bus_info, int ch, char *optarg)
|
Loading…
Reference in New Issue
Block a user