mirror of
https://github.com/coolsnowwolf/packages
synced 2025-01-07 07:07:02 +08:00
minidlna: fix build with new autotools
Backport a patch that fixes build with new versions of Autoconf and Automake. Signed-off-by: Michael Pratt <mcpratt@pm.me>
This commit is contained in:
parent
af2580b0bd
commit
3858f3a59c
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=minidlna
|
||||
PKG_VERSION:=1.3.0
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=@SF/minidlna
|
||||
|
@ -0,0 +1,34 @@
|
||||
From 8d8d04785bdc8d743d8a1fcfadd1285d86670b1e
|
||||
From: Justin Maggard <jmaggard@arlo.com>
|
||||
Date: Wed, 9 Feb 2022 18:32:19 -0800
|
||||
Subject: [PATCH] build: Fix configure error on some platforms
|
||||
|
||||
Fixes libid3tag and libavformat detection errors.
|
||||
---
|
||||
configure.ac | 8 ++++++--
|
||||
1 file changed, 6 insertions(+), 2 deletions(-)
|
||||
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -414,7 +414,10 @@ for dir in "" /usr/local $SEARCH_DIR; do
|
||||
AC_CHECK_LIB([id3tag -lz], [id3_file_open], [LIBID3TAG_LIBS="-lid3tag -lz"], [unset ac_cv_lib_id3tag_id3_file_open; LDFLAGS="$LDFLAGS_SAVE"; continue])
|
||||
break
|
||||
done
|
||||
-test x"$ac_cv_lib_id3tag__lz___id3_file_open" = x"yes" || AC_MSG_ERROR([Could not find libid3tag])
|
||||
+if test x"$ac_cv_lib_id3tag__lz___id3_file_open" != x"yes" &&
|
||||
+ test x"$ac_cv_lib_id3tag__lz_id3_file_open" != x"yes"; then
|
||||
+ AC_MSG_ERROR([Could not find libid3tag])
|
||||
+fi
|
||||
AC_SUBST(LIBID3TAG_LIBS)
|
||||
|
||||
LDFLAGS_SAVE="$LDFLAGS"
|
||||
@@ -441,7 +444,8 @@ for dir in "" /usr/local $SEARCH_DIR; do
|
||||
break
|
||||
done
|
||||
if test x"$ac_cv_lib_avformat__lavcodec__lavutil__lz___av_open_input_file" != x"yes" &&
|
||||
- test x"$ac_cv_lib_avformat__lavcodec__lavutil__lz___avformat_open_input" != x"yes"; then
|
||||
+ test x"$ac_cv_lib_avformat__lavcodec__lavutil__lz___avformat_open_input" != x"yes" &&
|
||||
+ test x"$ac_cv_lib_avformat__lavcodec__lavutil__lz_avformat_open_input" != x"yes"; then
|
||||
AC_MSG_ERROR([Could not find libavformat - part of ffmpeg])
|
||||
fi
|
||||
AC_SUBST(LIBAVFORMAT_LIBS)
|
@ -11,7 +11,7 @@
|
||||
check_PROGRAMS = testupnpdescgen
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -658,6 +658,5 @@ case "$target_os" in
|
||||
@@ -662,6 +662,5 @@ case "$target_os" in
|
||||
esac
|
||||
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user