mirror of
https://github.com/coolsnowwolf/packages
synced 2025-01-07 07:07:02 +08:00
sbc: update to version 2.0
Fixes issue with use of x86-specific compiler primitives on non-x86 systems which we had previously patched downstream, remove this patch. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
This commit is contained in:
parent
52c4bc8d0e
commit
3e2265dbd1
@ -8,12 +8,12 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=sbc
|
||||
PKG_VERSION:=1.5
|
||||
PKG_VERSION:=2.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=@KERNEL/linux/bluetooth/
|
||||
PKG_HASH:=0cbad69823a99e8421fe0700e8cf9eeb8fa0c1ad28e8dbc2182b3353507931d2
|
||||
PKG_HASH:=8f12368e1dbbf55e14536520473cfb338c84b392939cc9b64298360fd4a07992
|
||||
|
||||
PKG_LICENSE:=LGPL-2.1-or-later
|
||||
PKG_LICENSE_FILES:=COPYING.LIB
|
||||
|
@ -1,12 +0,0 @@
|
||||
--- a/sbc/sbc_primitives.c
|
||||
+++ b/sbc/sbc_primitives.c
|
||||
@@ -593,7 +593,9 @@ static int sbc_calc_scalefactors_j(
|
||||
|
||||
static void sbc_init_primitives_x86(struct sbc_encoder_state *state)
|
||||
{
|
||||
+#ifdef __x86__
|
||||
__builtin_cpu_init();
|
||||
+#endif
|
||||
|
||||
#ifdef SBC_BUILD_WITH_MMX_SUPPORT
|
||||
if (__builtin_cpu_supports("mmx"))
|
Loading…
Reference in New Issue
Block a user