mirror of
https://github.com/coolsnowwolf/packages
synced 2025-01-08 13:27:39 +08:00
knxd: bump to upstream version 0.14.56
Signed-off-by: Othmar Truniger <github@truniger.ch>
This commit is contained in:
parent
d3aa303cba
commit
53e97f319b
@ -11,12 +11,12 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=knxd
|
||||
PKG_VERSION:=0.14.54
|
||||
PKG_VERSION:=0.14.56
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://codeload.github.com/knxd/knxd/tar.gz/$(PKG_VERSION)?
|
||||
PKG_HASH:=54041c32eaa24474f3346f39871ab01ffe50d99bfbae723bf4e84140dabaa329
|
||||
PKG_HASH:=ae447870d0aba55062cbca8acdaa7a40578ad3ef6e6fb3a91dc982f5d81d5da9
|
||||
|
||||
PKG_MAINTAINER:=Othmar Truniger <github@truniger.ch>
|
||||
PKG_LICENSE:=GPL-2.0-or-later
|
||||
|
@ -7,4 +7,4 @@
|
||||
-test -d .git || exit
|
||||
-# git describe --tags
|
||||
-git log --format=format:%D | perl -ne 'next unless s#.*tag: ##; s#,.*##; next if m#/#; print; exit;'
|
||||
+echo -n "0.14.53"
|
||||
+echo -n "0.14.56"
|
||||
|
@ -1,41 +0,0 @@
|
||||
From: https://github.com/knxd/knxd/pull/531/commits/cb8a564d2c6250f712528e929892a5e7ddb74778
|
||||
|
||||
From cb8a564d2c6250f712528e929892a5e7ddb74778 Mon Sep 17 00:00:00 2001
|
||||
From: "Sergey V. Lobanov" <sergey@lobanov.in>
|
||||
Date: Mon, 31 Jan 2022 01:34:20 +0300
|
||||
Subject: [PATCH] Add clang suport as build cc
|
||||
|
||||
ccforbuild.m4 comes from gmp project (very old version).
|
||||
Current version does not support clang due to using GCC exit()
|
||||
builtin function. clang does not have exit() builtin function.
|
||||
|
||||
GMP project fixed this issue by the commit https://gmplib.org/repo/gmp/rev/beda46a3c10d
|
||||
|
||||
This patch backports "upstream" change (`exit(0)` relaced by
|
||||
`return 0` in conftest.c)
|
||||
|
||||
Signed-off-by: Sergey V. Lobanov <sergey@lobanov.in>
|
||||
---
|
||||
m4/ccforbuild.m4 | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
--- a/m4/ccforbuild.m4
|
||||
+++ b/m4/ccforbuild.m4
|
||||
@@ -69,7 +69,7 @@ cat >conftest.c <<EOF
|
||||
int
|
||||
main ()
|
||||
{
|
||||
- exit(0);
|
||||
+ return 0;
|
||||
}
|
||||
EOF
|
||||
gmp_compile="$1 conftest.c"
|
||||
@@ -143,7 +143,7 @@ AC_CACHE_CHECK([for build system executa
|
||||
int
|
||||
main ()
|
||||
{
|
||||
- exit (0);
|
||||
+ return 0;
|
||||
}
|
||||
EOF
|
||||
for i in .exe ,ff8 ""; do
|
Loading…
Reference in New Issue
Block a user