mirror of
https://github.com/coolsnowwolf/packages
synced 2025-01-08 13:27:39 +08:00
ptunnel-ng: fix compilation with kernel 5.15
Some header change requires to include musl's headers first. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
e19581475a
commit
586cc0c04a
@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=ptunnel-ng
|
||||
PKG_VERSION:=1.42
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://codeload.github.com/lnslbrty/ptunnel-ng/tar.gz/v$(PKG_VERSION)?
|
||||
|
22
net/ptunnel-ng/patches/010-musl.patch
Normal file
22
net/ptunnel-ng/patches/010-musl.patch
Normal file
@ -0,0 +1,22 @@
|
||||
--- a/src/ptunnel.h
|
||||
+++ b/src/ptunnel.h
|
||||
@@ -45,9 +45,6 @@
|
||||
#define PING_TUNNEL_H 1
|
||||
|
||||
#ifndef WIN32
|
||||
-#ifdef HAVE_ICMPFILTER
|
||||
-#include <linux/icmp.h>
|
||||
-#endif
|
||||
#ifdef HAVE_SYS_UNISTD_H
|
||||
#include <sys/unistd.h>
|
||||
#endif
|
||||
@@ -56,6 +53,9 @@
|
||||
#include <netinet/in.h>
|
||||
#include <arpa/inet.h>
|
||||
#include <netdb.h>
|
||||
+#ifdef HAVE_ICMPFILTER
|
||||
+#include <linux/icmp.h>
|
||||
+#endif
|
||||
#include <pthread.h>
|
||||
#include <errno.h>
|
||||
#include <net/ethernet.h>
|
Loading…
Reference in New Issue
Block a user