mirror of
https://github.com/coolsnowwolf/packages
synced 2025-01-08 11:17:36 +08:00
zmq: update to 4.3.5
This commit is contained in:
parent
33b43c290a
commit
5c4514c600
@ -10,12 +10,12 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=zeromq
|
PKG_NAME:=zeromq
|
||||||
PKG_VERSION:=4.3.4
|
PKG_VERSION:=4.3.5
|
||||||
PKG_RELEASE:=3
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=https://github.com/zeromq/libzmq/releases/download/v$(PKG_VERSION)
|
PKG_SOURCE_URL:=https://github.com/zeromq/libzmq/releases/download/v$(PKG_VERSION)
|
||||||
PKG_HASH:=c593001a89f5a85dd2ddf564805deb860e02471171b3f204944857336295c3e5
|
PKG_HASH:=6653ef5910f17954861fe72332e68b03ca6e4d9c7160eb3a8de5a5a913bfab43
|
||||||
|
|
||||||
PKG_MAINTAINER:=Dirk Chang <dirk@kooiot.com>
|
PKG_MAINTAINER:=Dirk Chang <dirk@kooiot.com>
|
||||||
PKG_LICENSE:=GPL-3.0-or-later
|
PKG_LICENSE:=GPL-3.0-or-later
|
||||||
|
@ -9,7 +9,7 @@ Subject: [PATCH] fix-openpgm-linking-for-zeromq
|
|||||||
|
|
||||||
--- a/CMakeLists.txt
|
--- a/CMakeLists.txt
|
||||||
+++ b/CMakeLists.txt
|
+++ b/CMakeLists.txt
|
||||||
@@ -793,7 +793,7 @@ else()
|
@@ -809,7 +809,7 @@ else()
|
||||||
# message(FATAL_ERROR "WITH_OPENPGM not implemented")
|
# message(FATAL_ERROR "WITH_OPENPGM not implemented")
|
||||||
|
|
||||||
if(NOT OPENPGM_PKGCONFIG_NAME)
|
if(NOT OPENPGM_PKGCONFIG_NAME)
|
||||||
@ -18,7 +18,7 @@ Subject: [PATCH] fix-openpgm-linking-for-zeromq
|
|||||||
endif()
|
endif()
|
||||||
|
|
||||||
set(OPENPGM_PKGCONFIG_NAME
|
set(OPENPGM_PKGCONFIG_NAME
|
||||||
@@ -804,6 +804,8 @@ else()
|
@@ -820,6 +820,8 @@ else()
|
||||||
|
|
||||||
if(OPENPGM_FOUND)
|
if(OPENPGM_FOUND)
|
||||||
message(STATUS ${OPENPGM_PKGCONFIG_NAME}" found")
|
message(STATUS ${OPENPGM_PKGCONFIG_NAME}" found")
|
||||||
@ -27,7 +27,7 @@ Subject: [PATCH] fix-openpgm-linking-for-zeromq
|
|||||||
set(pkg_config_names_private "${pkg_config_names_private} ${OPENPGM_PKGCONFIG_NAME}")
|
set(pkg_config_names_private "${pkg_config_names_private} ${OPENPGM_PKGCONFIG_NAME}")
|
||||||
else()
|
else()
|
||||||
message(
|
message(
|
||||||
@@ -1447,6 +1449,10 @@ if(BUILD_SHARED)
|
@@ -1494,6 +1496,10 @@ if(BUILD_SHARED)
|
||||||
endif()
|
endif()
|
||||||
endif()
|
endif()
|
||||||
|
|
@ -7,38 +7,13 @@ libbsd is only used once and as part of a larger, incorrect function.
|
|||||||
I rewrote the code that used it without the need for it.
|
I rewrote the code that used it without the need for it.
|
||||||
---
|
---
|
||||||
CMakeLists.txt | 41 ++++++-----------------------
|
CMakeLists.txt | 41 ++++++-----------------------
|
||||||
Makefile.am | 12 ++++-----
|
|
||||||
builds/cmake/platform.hpp.in | 2 --
|
builds/cmake/platform.hpp.in | 2 --
|
||||||
configure.ac | 39 +--------------------------
|
|
||||||
packaging/debian/control | 2 --
|
|
||||||
packaging/debian/zeromq.dsc | 2 +-
|
|
||||||
packaging/redhat/zeromq.spec | 2 +-
|
|
||||||
src/compat.hpp | 51 +++++++++++++++++++++++-------------
|
src/compat.hpp | 51 +++++++++++++++++++++++-------------
|
||||||
8 files changed, 50 insertions(+), 101 deletions(-)
|
8 files changed, 50 insertions(+), 101 deletions(-)
|
||||||
|
|
||||||
--- a/CMakeLists.txt
|
--- a/CMakeLists.txt
|
||||||
+++ b/CMakeLists.txt
|
+++ b/CMakeLists.txt
|
||||||
@@ -240,19 +240,6 @@ if(NOT ZMQ_USE_GNUTLS)
|
@@ -1484,10 +1484,6 @@ if(BUILD_SHARED)
|
||||||
endif()
|
|
||||||
endif()
|
|
||||||
|
|
||||||
-if(NOT MSVC)
|
|
||||||
- option(WITH_LIBBSD "Use libbsd instead of builtin strlcpy" ON)
|
|
||||||
- if(WITH_LIBBSD)
|
|
||||||
- pkg_check_modules(LIBBSD "libbsd")
|
|
||||||
- if(LIBBSD_FOUND)
|
|
||||||
- message(STATUS "Using libbsd")
|
|
||||||
- set(pkg_config_names_private "${pkg_config_names_private} libbsd")
|
|
||||||
- set(ZMQ_HAVE_LIBBSD 1)
|
|
||||||
- endif()
|
|
||||||
- endif()
|
|
||||||
- check_cxx_symbol_exists(strlcpy string.h ZMQ_HAVE_STRLCPY)
|
|
||||||
-endif()
|
|
||||||
-
|
|
||||||
# Select curve encryption library, defaults to tweetnacl To use libsodium instead, use --with-libsodium(must be
|
|
||||||
# installed) To disable curve, use --disable-curve
|
|
||||||
|
|
||||||
@@ -1437,10 +1424,6 @@ if(BUILD_SHARED)
|
|
||||||
target_link_libraries(libzmq ${NSS3_LIBRARIES})
|
target_link_libraries(libzmq ${NSS3_LIBRARIES})
|
||||||
endif()
|
endif()
|
||||||
|
|
||||||
@ -49,8 +24,8 @@ I rewrote the code that used it without the need for it.
|
|||||||
if(SODIUM_FOUND)
|
if(SODIUM_FOUND)
|
||||||
target_link_libraries(libzmq ${SODIUM_LIBRARIES})
|
target_link_libraries(libzmq ${SODIUM_LIBRARIES})
|
||||||
# On Solaris, libsodium depends on libssp
|
# On Solaris, libsodium depends on libssp
|
||||||
@@ -1482,10 +1465,6 @@ if(BUILD_STATIC)
|
@@ -1534,10 +1530,6 @@ if(BUILD_STATIC)
|
||||||
target_link_libraries(libzmq-static ${GNUTLS_LIBRARIES})
|
target_include_directories(libzmq-static PRIVATE "${GNUTLS_INCLUDE_DIR}")
|
||||||
endif()
|
endif()
|
||||||
|
|
||||||
- if(LIBBSD_FOUND)
|
- if(LIBBSD_FOUND)
|
||||||
@ -60,8 +35,8 @@ I rewrote the code that used it without the need for it.
|
|||||||
if(NSS3_FOUND)
|
if(NSS3_FOUND)
|
||||||
target_link_libraries(libzmq-static ${NSS3_LIBRARIES})
|
target_link_libraries(libzmq-static ${NSS3_LIBRARIES})
|
||||||
endif()
|
endif()
|
||||||
@@ -1550,10 +1529,6 @@ if(BUILD_SHARED)
|
@@ -1607,10 +1599,6 @@ if(BUILD_SHARED)
|
||||||
target_link_libraries(${perf-tool} ${GNUTLS_LIBRARIES})
|
target_include_directories(${perf-tool} PRIVATE "${GNUTLS_INCLUDE_DIR}")
|
||||||
endif()
|
endif()
|
||||||
|
|
||||||
- if(LIBBSD_FOUND)
|
- if(LIBBSD_FOUND)
|
||||||
@ -71,40 +46,9 @@ I rewrote the code that used it without the need for it.
|
|||||||
if(NSS3_FOUND)
|
if(NSS3_FOUND)
|
||||||
target_link_libraries(${perf-tool} ${NSS3_LIBRARIES})
|
target_link_libraries(${perf-tool} ${NSS3_LIBRARIES})
|
||||||
endif()
|
endif()
|
||||||
--- a/Makefile.am
|
|
||||||
+++ b/Makefile.am
|
|
||||||
@@ -351,11 +351,11 @@ if HAVE_VSCRIPT_COMPLEX
|
|
||||||
src_libzmq_la_LDFLAGS += $(VSCRIPT_LDFLAGS),$(srcdir)/src/libzmq.vers
|
|
||||||
endif
|
|
||||||
|
|
||||||
-src_libzmq_la_CPPFLAGS = $(CODE_COVERAGE_CPPFLAGS) $(LIBUNWIND_CFLAGS) $(LIBBSD_CFLAGS)
|
|
||||||
-src_libzmq_la_CFLAGS = $(CODE_COVERAGE_CFLAGS) $(LIBUNWIND_CFLAGS) $(LIBBSD_CFLAGS)
|
|
||||||
+src_libzmq_la_CPPFLAGS = $(CODE_COVERAGE_CPPFLAGS) $(LIBUNWIND_CFLAGS)
|
|
||||||
+src_libzmq_la_CFLAGS = $(CODE_COVERAGE_CFLAGS) $(LIBUNWIND_CFLAGS)
|
|
||||||
src_libzmq_la_CXXFLAGS = @LIBZMQ_EXTRA_CXXFLAGS@ $(CODE_COVERAGE_CXXFLAGS) \
|
|
||||||
- $(LIBUNWIND_CFLAGS) $(LIBBSD_CFLAGS)
|
|
||||||
-src_libzmq_la_LIBADD = $(CODE_COVERAGE_LDFLAGS) $(LIBUNWIND_LIBS) $(LIBBSD_LIBS)
|
|
||||||
+ $(LIBUNWIND_CFLAGS)
|
|
||||||
+src_libzmq_la_LIBADD = $(CODE_COVERAGE_LDFLAGS) $(LIBUNWIND_LIBS)
|
|
||||||
|
|
||||||
if USE_NSS
|
|
||||||
src_libzmq_la_CPPFLAGS += ${NSS3_CFLAGS}
|
|
||||||
@@ -849,10 +849,10 @@ tests_test_security_curve_SOURCES += \
|
|
||||||
endif
|
|
||||||
|
|
||||||
tests_test_security_curve_LDADD = \
|
|
||||||
- ${TESTUTIL_LIBS} src/libzmq.la $(LIBUNWIND_LIBS) $(LIBBSD_LIBS)
|
|
||||||
+ ${TESTUTIL_LIBS} src/libzmq.la $(LIBUNWIND_LIBS)
|
|
||||||
tests_test_security_curve_CPPFLAGS = \
|
|
||||||
${TESTUTIL_CPPFLAGS} \
|
|
||||||
- ${LIBUNWIND_CFLAGS} ${LIBBSD_CFLAGS}
|
|
||||||
+ ${LIBUNWIND_CFLAGS}
|
|
||||||
|
|
||||||
if USE_LIBSODIUM
|
|
||||||
tests_test_security_curve_CPPFLAGS += \
|
|
||||||
--- a/builds/cmake/platform.hpp.in
|
--- a/builds/cmake/platform.hpp.in
|
||||||
+++ b/builds/cmake/platform.hpp.in
|
+++ b/builds/cmake/platform.hpp.in
|
||||||
@@ -52,8 +52,6 @@
|
@@ -56,8 +56,6 @@
|
||||||
#cmakedefine ZMQ_HAVE_PTHREAD_SET_AFFINITY
|
#cmakedefine ZMQ_HAVE_PTHREAD_SET_AFFINITY
|
||||||
#cmakedefine HAVE_ACCEPT4
|
#cmakedefine HAVE_ACCEPT4
|
||||||
#cmakedefine HAVE_STRNLEN
|
#cmakedefine HAVE_STRNLEN
|
||||||
@ -112,65 +56,10 @@ I rewrote the code that used it without the need for it.
|
|||||||
-#cmakedefine ZMQ_HAVE_LIBBSD
|
-#cmakedefine ZMQ_HAVE_LIBBSD
|
||||||
|
|
||||||
#cmakedefine ZMQ_HAVE_IPC
|
#cmakedefine ZMQ_HAVE_IPC
|
||||||
|
#cmakedefine ZMQ_HAVE_STRUCT_SOCKADDR_UN
|
||||||
--- a/configure.ac
|
|
||||||
+++ b/configure.ac
|
|
||||||
@@ -12,7 +12,7 @@ AC_CONFIG_AUX_DIR(config)
|
|
||||||
AC_CONFIG_MACRO_DIR(config)
|
|
||||||
AC_CONFIG_HEADERS([src/platform.hpp])
|
|
||||||
AM_INIT_AUTOMAKE(foreign subdir-objects tar-ustar dist-zip)
|
|
||||||
-# Allow "configure --disable-maintainer-mode" to disable timestamp checking
|
|
||||||
+# Allow "configure --disable-maintainer-mode" to disable timestamp checking
|
|
||||||
AM_MAINTAINER_MODE([enable])
|
|
||||||
|
|
||||||
m4_pattern_allow([AC_PROG_CC_C99])
|
|
||||||
@@ -806,43 +806,6 @@ AC_COMPILE_IFELSE(
|
|
||||||
],[
|
|
||||||
AC_MSG_RESULT([no])
|
|
||||||
])
|
|
||||||
-
|
|
||||||
-AC_ARG_ENABLE([libbsd],
|
|
||||||
- [AS_HELP_STRING([--enable-libbsd],
|
|
||||||
- [enable libbsd [default=auto]])],
|
|
||||||
- [enable_libbsd=$enableval],
|
|
||||||
- [enable_libbsd="auto"])
|
|
||||||
-
|
|
||||||
-if test "x$enable_libbsd" != "xno"; then
|
|
||||||
- PKG_CHECK_MODULES(LIBBSD, [libbsd],
|
|
||||||
- [
|
|
||||||
- AC_DEFINE(ZMQ_HAVE_LIBBSD, 1, [The libbsd library is to be used])
|
|
||||||
- AC_SUBST([LIBBSD_CFLAGS])
|
|
||||||
- AC_SUBST([LIBBSD_LIBS])
|
|
||||||
- PKGCFG_NAMES_PRIVATE="$PKGCFG_NAMES_PRIVATE libbsd"
|
|
||||||
- found_libbsd="yes"
|
|
||||||
- ],
|
|
||||||
- [
|
|
||||||
- found_libbsd="no"
|
|
||||||
- if test "x$enable_libbsd" = "xyes"; then
|
|
||||||
- AC_MSG_ERROR([Cannot find libbsd])
|
|
||||||
- else
|
|
||||||
- AC_MSG_WARN([Cannot find libbsd])
|
|
||||||
- fi
|
|
||||||
- ])
|
|
||||||
-fi
|
|
||||||
-AC_MSG_CHECKING([whether strlcpy is available])
|
|
||||||
-AC_COMPILE_IFELSE(
|
|
||||||
- [AC_LANG_PROGRAM(
|
|
||||||
- [[#include <string.h>]],
|
|
||||||
- [[char buf [100]; size_t bar = strlcpy (buf, "foo", 100); (void)bar; return 0;]])
|
|
||||||
- ],[
|
|
||||||
- AC_MSG_RESULT([yes])
|
|
||||||
- AC_DEFINE(ZMQ_HAVE_STRLCPY, [1],
|
|
||||||
- [strlcpy is available])
|
|
||||||
- ],[
|
|
||||||
- AC_MSG_RESULT([no])
|
|
||||||
-])
|
|
||||||
|
|
||||||
# pthread_setname is non-posix, and there are at least 4 different implementations
|
|
||||||
AC_MSG_CHECKING([whether signature of pthread_setname_np() has 1 argument])
|
|
||||||
--- a/src/compat.hpp
|
--- a/src/compat.hpp
|
||||||
+++ b/src/compat.hpp
|
+++ b/src/compat.hpp
|
||||||
@@ -37,26 +37,41 @@
|
@@ -10,26 +10,41 @@
|
||||||
#define strcasecmp _stricmp
|
#define strcasecmp _stricmp
|
||||||
#define strtok_r strtok_s
|
#define strtok_r strtok_s
|
||||||
#else
|
#else
|
||||||
|
Loading…
Reference in New Issue
Block a user