mirror of
https://github.com/coolsnowwolf/packages
synced 2025-01-08 11:17:36 +08:00
qemu: update to 9.0.0 (#808)
This commit is contained in:
parent
86639d1993
commit
5d21961d4b
@ -9,10 +9,10 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=qemu
|
||||
PKG_VERSION:=8.1.2
|
||||
PKG_VERSION:=9.0.0
|
||||
PKG_RELEASE:=1
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_HASH:=541526a764576eb494d2ff5ec46aeb253e62ea29035d1c23c0a8af4e6cd4f087
|
||||
PKG_HASH:=32708ac66c30d8c892633ea968c771c1c76d597d70ddead21a0d22ccf386da69
|
||||
PKG_SOURCE_URL:=http://download.qemu.org/
|
||||
PKG_LICENSE:=GPL-2.0-only
|
||||
PKG_LICENSE_FILES:=LICENSE tcg/LICENSE
|
||||
|
@ -11,7 +11,7 @@ OpenWrt base build system decide flavor of fortify_source to use
|
||||
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -823,6 +823,8 @@ for opt do
|
||||
@@ -758,6 +758,8 @@ for opt do
|
||||
;;
|
||||
--gdb=*) gdb_bin="$optarg"
|
||||
;;
|
||||
|
@ -13,7 +13,7 @@ https://gitlab.alpinelinux.org/alpine/aports/commit/76b81b486480fd9c3294cd420bcf
|
||||
|
||||
--- a/qga/commands-posix.c
|
||||
+++ b/qga/commands-posix.c
|
||||
@@ -76,6 +76,7 @@ static void ga_wait_child(pid_t pid, int
|
||||
@@ -79,6 +79,7 @@ static void ga_wait_child(pid_t pid, int
|
||||
void qmp_guest_shutdown(const char *mode, Error **errp)
|
||||
{
|
||||
const char *shutdown_flag;
|
||||
@ -21,7 +21,7 @@ https://gitlab.alpinelinux.org/alpine/aports/commit/76b81b486480fd9c3294cd420bcf
|
||||
Error *local_err = NULL;
|
||||
pid_t pid;
|
||||
int status;
|
||||
@@ -97,10 +98,13 @@ void qmp_guest_shutdown(const char *mode
|
||||
@@ -100,10 +101,13 @@ void qmp_guest_shutdown(const char *mode
|
||||
slog("guest-shutdown called, mode: %s", mode);
|
||||
if (!mode || strcmp(mode, "powerdown") == 0) {
|
||||
shutdown_flag = powerdown_flag;
|
||||
@ -35,7 +35,7 @@ https://gitlab.alpinelinux.org/alpine/aports/commit/76b81b486480fd9c3294cd420bcf
|
||||
} else {
|
||||
error_setg(errp,
|
||||
"mode is invalid (valid values are: halt|powerdown|reboot");
|
||||
@@ -125,6 +129,7 @@ void qmp_guest_shutdown(const char *mode
|
||||
@@ -128,6 +132,7 @@ void qmp_guest_shutdown(const char *mode
|
||||
execl("/sbin/shutdown", "shutdown", "-h", shutdown_flag, "+0",
|
||||
"hypervisor initiated shutdown", (char *)NULL);
|
||||
#endif
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -3451,10 +3451,6 @@ subdir('common-user')
|
||||
@@ -3576,10 +3576,6 @@ subdir('common-user')
|
||||
subdir('bsd-user')
|
||||
subdir('linux-user')
|
||||
|
||||
@ -11,7 +11,7 @@
|
||||
# accel modules
|
||||
tcg_real_module_ss = ss.source_set()
|
||||
tcg_real_module_ss.add_all(when: 'CONFIG_TCG_MODULAR', if_true: tcg_module_ss)
|
||||
@@ -3945,10 +3941,6 @@ subdir('scripts')
|
||||
@@ -4094,10 +4090,6 @@ subdir('scripts')
|
||||
subdir('tools')
|
||||
subdir('pc-bios')
|
||||
subdir('docs')
|
||||
|
Loading…
Reference in New Issue
Block a user