qemu: update to 8.1.2

This commit is contained in:
coolsnowwolf 2024-01-15 17:48:49 +08:00
parent c0ce43a885
commit 6654fe655c
5 changed files with 31 additions and 25 deletions

View File

@ -9,10 +9,10 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=qemu
PKG_VERSION:=7.2.1
PKG_VERSION:=8.1.2
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_HASH:=8c85699acf9d7a43a5fe29a64cdd56370b0c2d1ad074baf7098a824d17aad73b
PKG_HASH:=541526a764576eb494d2ff5ec46aeb253e62ea29035d1c23c0a8af4e6cd4f087
PKG_SOURCE_URL:=http://download.qemu.org/
PKG_LICENSE:=GPL-2.0-only
PKG_LICENSE_FILES:=LICENSE tcg/LICENSE
@ -21,16 +21,15 @@ PKG_CPE_ID:=cpe:/a:qemu:qemu
PKG_BUILD_PARALLEL:=1
PKG_INSTALL:=1
PKG_USE_MIPS16:=0
PKG_FLAGS:=nonshared
PKG_BUILD_FLAGS:=no-mips16
PKG_BUILD_DEPENDS+=spice-protocol
include $(INCLUDE_DIR)/nls.mk
include $(INCLUDE_DIR)/package.mk
QEMU_DEPS_IN_GUEST := @(TARGET_x86_64||TARGET_armvirt||TARGET_malta)
QEMU_DEPS_IN_HOST := @(TARGET_x86_64||TARGET_sunxi)
QEMU_DEPS_IN_GUEST := @(TARGET_x86_64||TARGET_armsr||TARGET_malta)
QEMU_DEPS_IN_HOST := @(TARGET_x86_64||TARGET_armsr_armv8||TARGET_sunxi)
QEMU_DEPS_IN_HOST += +libstdcpp
QEMU_DEPS_IN_HOST += $(ICONV_DEPENDS)
@ -67,7 +66,6 @@ define Package/qemu-ga/install
endef
PKG_CONFIG_DEPENDS += CONFIG_PACKAGE_qemu-ga
PKG_CONFIG_DEPENDS += CONFIG_PACKAGE_libaio
define Package/qemu-bridge-helper
@ -93,7 +91,7 @@ define Package/qemu-img
SUBMENU:=Virtualization
TITLE:=QEMU Image utility
URL:=http://www.qemu.org
DEPENDS:=+glib2 +libaio +KERNEL_IO_URING:liburing $(QEMU_DEPS_IN_HOST)
DEPENDS:=+glib2 +QEMU_ZSTD:libzstd $(QEMU_DEPS_IN_HOST)
endef
define Package/qemu-img/install
@ -108,7 +106,7 @@ define Package/qemu-nbd
SUBMENU:=Virtualization
TITLE:=QEMU Network Block Device Utility
URL:=http://www.qemu.org
DEPENDS:=+glib2 +libaio +KERNEL_IO_URING:liburing $(QEMU_DEPS_IN_HOST) +kmod-nbd
DEPENDS:=+glib2 +QEMU_ZSTD:libzstd $(QEMU_DEPS_IN_HOST) +kmod-nbd
endef
define Package/qemu-nbd/install
@ -192,7 +190,7 @@ define qemu-target
SUBMENU:=Virtualization
TITLE:=QEMU target $(1)
URL:=http://www.qemu.org
DEPENDS:= +glib2 +libpthread +zlib +libbpf +libaio +KERNEL_IO_URING:liburing $(QEMU_DEPS_IN_HOST) $(qemu-target-$(1)-deps) \
DEPENDS:= +glib2 +libpthread +zlib +libbpf $(QEMU_DEPS_IN_HOST) $(qemu-target-$(1)-deps) \
+QEMU_UI_VNC:qemu-keymaps \
+QEMU_UI_VNC:libpng \
+QEMU_UI_VNC_JPEG:libjpeg \
@ -200,6 +198,7 @@ define qemu-target
+QEMU_UI_SPICE:libspice-server \
+QEMU_DEV_USB:libusb-1.0 \
+QEMU_SECCOMP:libseccomp \
+QEMU_ZSTD:libzstd \
$(if $(filter %-softmmu,$(1)),+libncurses +libfdt +libslirp +libudev +pixman +qemu-firmware-efi $(ICONV_DEPENDS))
endef
@ -221,6 +220,7 @@ endef
qemu-target-list := \
x86_64-softmmu \
arm-softmmu \
aarch64-softmmu \
qemu-target-x86_64-softmmu-deps:= \
+qemu-firmware-pxe \
@ -267,6 +267,10 @@ config QEMU_SECCOMP
Build QEMU with support for seccomp filters.
Select libseccomp which also pulls-in the needed kernel features.
config QEMU_ZSTD
bool "QEMU ZSTD compression support"
default n
endif
endef
@ -277,6 +281,7 @@ PKG_CONFIG_DEPENDS += \
CONFIG_QEMU_UI_SPICE \
CONFIG_QEMU_DEV_USB \
CONFIG_QEMU_SECCOMP \
CONFIG_QEMU_ZSTD \
# QEMU configure script does not recognize these options
@ -387,7 +392,7 @@ CONFIGURE_ARGS += \
--disable-docs \
--disable-fuse \
--disable-gcrypt \
--with-git-submodules=ignore \
--disable-download \
--disable-glusterfs \
--disable-gnutls \
--disable-guest-agent-msi \
@ -396,8 +401,8 @@ CONFIGURE_ARGS += \
--disable-libpmem \
--disable-libssh \
--$(if $(CONFIG_QEMU_DEV_USB),enable,disable)-libusb \
--$(if $(CONFIG_KERNEL_AIO),enable,disable)-linux-aio \
--$(if $(CONFIG_KERNEL_IO_URING),enable,disable)-linux-io-uring \
--disable-linux-aio \
--disable-linux-io-uring \
--disable-lzfse \
--disable-lzo \
--disable-modules \
@ -426,12 +431,13 @@ CONFIGURE_ARGS += \
--disable-werror \
--disable-xen-pci-passthrough \
--disable-xkbcommon \
--disable-zstd \
--$(if $(CONFIG_QEMU_ZSTD),enable,disable)-zstd \
--disable-selinux \
--disable-oss \
--disable-alsa \
--disable-pa \
--disable-vduse-blk-export \
--disable-libdw \
CONFIGURE_ARGS += --target-list='$(foreach target,$(qemu-target-list),$(if $(CONFIG_PACKAGE_qemu-$(target)),$(target)))'
CONFIGURE_ARGS += $(if $(CONFIG_PACKAGE_qemu-ga),--enable-guest-agent)

View File

@ -11,9 +11,9 @@ OpenWrt base build system decide flavor of fortify_source to use
--- a/configure
+++ b/configure
@@ -896,6 +896,8 @@ for opt do
@@ -823,6 +823,8 @@ for opt do
;;
--enable-jemalloc) meson_option_parse --enable-malloc=jemalloc jemalloc
--gdb=*) gdb_bin="$optarg"
;;
+ --disable-fortify-source) fortify_source="no"
+ ;;

View File

@ -32,9 +32,9 @@ Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
#endif /* CONFIG_LINUX */
#include "qemu/osdep.h"
@@ -29,6 +26,13 @@
#include <sys/vfs.h>
@@ -57,6 +54,13 @@ QemuFsType qemu_fd_getfs(int fd)
#endif
}
+#ifndef MAP_SYNC
+#define MAP_SYNC 0x0

View File

@ -13,17 +13,17 @@ https://gitlab.alpinelinux.org/alpine/aports/commit/76b81b486480fd9c3294cd420bcf
--- a/qga/commands-posix.c
+++ b/qga/commands-posix.c
@@ -74,6 +74,7 @@ static void ga_wait_child(pid_t pid, int
void qmp_guest_shutdown(bool has_mode, const char *mode, Error **errp)
@@ -76,6 +76,7 @@ static void ga_wait_child(pid_t pid, int
void qmp_guest_shutdown(const char *mode, Error **errp)
{
const char *shutdown_flag;
+ const char *fallback_cmd = NULL;
Error *local_err = NULL;
pid_t pid;
int status;
@@ -95,10 +96,13 @@ void qmp_guest_shutdown(bool has_mode, c
@@ -97,10 +98,13 @@ void qmp_guest_shutdown(const char *mode
slog("guest-shutdown called, mode: %s", mode);
if (!has_mode || strcmp(mode, "powerdown") == 0) {
if (!mode || strcmp(mode, "powerdown") == 0) {
shutdown_flag = powerdown_flag;
+ fallback_cmd = "/sbin/poweroff";
} else if (strcmp(mode, "halt") == 0) {
@ -35,7 +35,7 @@ https://gitlab.alpinelinux.org/alpine/aports/commit/76b81b486480fd9c3294cd420bcf
} else {
error_setg(errp,
"mode is invalid (valid values are: halt|powerdown|reboot");
@@ -123,6 +127,7 @@ void qmp_guest_shutdown(bool has_mode, c
@@ -125,6 +129,7 @@ void qmp_guest_shutdown(const char *mode
execl("/sbin/shutdown", "shutdown", "-h", shutdown_flag, "+0",
"hypervisor initiated shutdown", (char *)NULL);
#endif

View File

@ -1,6 +1,6 @@
--- a/meson.build
+++ b/meson.build
@@ -3142,10 +3142,6 @@ subdir('common-user')
@@ -3451,10 +3451,6 @@ subdir('common-user')
subdir('bsd-user')
subdir('linux-user')
@ -11,7 +11,7 @@
# accel modules
tcg_real_module_ss = ss.source_set()
tcg_real_module_ss.add_all(when: 'CONFIG_TCG_MODULAR', if_true: tcg_module_ss)
@@ -3633,10 +3629,6 @@ subdir('scripts')
@@ -3945,10 +3941,6 @@ subdir('scripts')
subdir('tools')
subdir('pc-bios')
subdir('docs')