mirror of
https://github.com/coolsnowwolf/packages
synced 2025-01-09 04:37:41 +08:00
libmodbus: update to 3.1.7
Signed-off-by: Michael Heimpold <mhei@heimpold.de>
This commit is contained in:
parent
87ed7b7d15
commit
791a2e0416
@ -8,12 +8,12 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=libmodbus
|
||||
PKG_VERSION:=3.1.6
|
||||
PKG_VERSION:=3.1.7
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://libmodbus.org/releases
|
||||
PKG_HASH:=d7d9fa94a16edb094e5fdf5d87ae17a0dc3f3e3d687fead81835d9572cf87c16
|
||||
PKG_HASH:=7dfe958431d0570b271e1a5b329b76a658e89c614cf119eb5aadb725c87f8fbd
|
||||
|
||||
PKG_MAINTAINER:=Michael Heimpold <mhei@heimpold.de>
|
||||
|
||||
|
@ -1,30 +0,0 @@
|
||||
From f1eb4bc7ccb09cd8d19ab641ee37637f8c34d16d Mon Sep 17 00:00:00 2001
|
||||
From: i-ky <gl.ivanovsky@gmail.com>
|
||||
Date: Tue, 10 Jul 2018 15:58:45 +0300
|
||||
Subject: [PATCH] Fixed MODBUS_GET_* macros in case of negative values
|
||||
|
||||
In case resulting value should be negative it is incorrect to use '+' operator to construct it from pieces, because highest bytes will result in negative number after bitwise shift while others will stay positive. Replacing addition with '|' should solve the issue.
|
||||
---
|
||||
src/modbus.h | 10 +++++-----
|
||||
1 file changed, 5 insertions(+), 5 deletions(-)
|
||||
|
||||
--- a/src/modbus.h
|
||||
+++ b/src/modbus.h
|
||||
@@ -245,12 +245,12 @@ MODBUS_API int modbus_reply_exception(mo
|
||||
#define MODBUS_GET_HIGH_BYTE(data) (((data) >> 8) & 0xFF)
|
||||
#define MODBUS_GET_LOW_BYTE(data) ((data) & 0xFF)
|
||||
#define MODBUS_GET_INT64_FROM_INT16(tab_int16, index) \
|
||||
- (((int64_t)tab_int16[(index) ] << 48) + \
|
||||
- ((int64_t)tab_int16[(index) + 1] << 32) + \
|
||||
- ((int64_t)tab_int16[(index) + 2] << 16) + \
|
||||
+ (((int64_t)tab_int16[(index) ] << 48) | \
|
||||
+ ((int64_t)tab_int16[(index) + 1] << 32) | \
|
||||
+ ((int64_t)tab_int16[(index) + 2] << 16) | \
|
||||
(int64_t)tab_int16[(index) + 3])
|
||||
-#define MODBUS_GET_INT32_FROM_INT16(tab_int16, index) ((tab_int16[(index)] << 16) + tab_int16[(index) + 1])
|
||||
-#define MODBUS_GET_INT16_FROM_INT8(tab_int8, index) ((tab_int8[(index)] << 8) + tab_int8[(index) + 1])
|
||||
+#define MODBUS_GET_INT32_FROM_INT16(tab_int16, index) ((tab_int16[(index)] << 16) | tab_int16[(index) + 1])
|
||||
+#define MODBUS_GET_INT16_FROM_INT8(tab_int8, index) ((tab_int8[(index)] << 8) | tab_int8[(index) + 1])
|
||||
#define MODBUS_SET_INT16_TO_INT8(tab_int8, index, value) \
|
||||
do { \
|
||||
tab_int8[(index)] = (value) >> 8; \
|
Loading…
Reference in New Issue
Block a user