softethervpn5: update version to 5.02.5181 (#825)

This commit is contained in:
HHJLKK 2024-06-09 19:18:24 +08:00 committed by GitHub
parent 7d89c09430
commit 797fcdd4f7
No known key found for this signature in database
GPG Key ID: B5690EEEBB952194
3 changed files with 19 additions and 9 deletions

View File

@ -3,7 +3,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=softethervpn5
PKG_VERSION:=5.01.9674
PKG_VERSION:=5.02.5181
PKG_RELEASE:=1
PKG_LICENSE:=GPL-2.0
@ -11,7 +11,7 @@ PKG_LICENSE_FILES:=COPYING
PKG_SOURCE_URL:=https://github.com/SoftEtherVPN/SoftEtherVPN/releases/download/$(PKG_VERSION)/
PKG_SOURCE:=softether-vpn-src-$(PKG_VERSION).tar.gz
PKG_HASH:=c4dc53f4912605a25c18357b0a0bf6dc059286ca901cb981abdf1a22d1649ddc
PKG_HASH:=2222ef48b3f9102265ef7d27e496ad40a1bd1eaba8093bc5e696b48402c52441
HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/SoftEtherVPN-$(PKG_VERSION)
PKG_BUILD_DIR:=$(BUILD_DIR)/SoftEtherVPN-$(PKG_VERSION)

View File

@ -0,0 +1,11 @@
--- a/src/Mayaqua/CMakeLists.txt
+++ b/src/Mayaqua/CMakeLists.txt
@@ -80,7 +80,7 @@ if(UNIX)
find_package(Threads REQUIRED)
# In some cases libiconv is not included in libc
- find_library(LIB_ICONV iconv)
+ find_library(LIB_ICONV iconv HINTS "${ICONV_LIB_PATH}")
find_library(LIB_M m)
find_library(LIB_RT rt)

View File

@ -1,15 +1,14 @@
--- a/src/Cedar/Server.c
+++ b/src/Cedar/Server.c
@@ -4,7 +4,7 @@
@@ -5,6 +5,7 @@
// Server.c
// VPN Server module
-
+#include <syslog.h>
#include "CedarPch.h"
static SERVER *server = NULL;
@@ -6492,6 +6492,10 @@ UINT SiWriteConfigurationFile(SERVER *s)
+#include <syslog.h>
#include "Server.h"
#include "Admin.h"
@@ -6593,6 +6594,10 @@ UINT SiWriteConfigurationFile(SERVER *s)
{
return 0;
}