mirror of
https://github.com/coolsnowwolf/packages
synced 2025-01-08 11:17:36 +08:00
xr_usb_serial_common: bump to 2023-03-31
Fix 6.1 and 6.6 kernel compile Fixes: https://github.com/coolsnowwolf/lede/issues/12362 Signed-off-by: John Thomson <git@johnthomson.fastmail.com.au>
This commit is contained in:
parent
df7f208c40
commit
7a3de3c5c1
@ -2,13 +2,13 @@ include $(TOPDIR)/rules.mk
|
||||
include $(INCLUDE_DIR)/kernel.mk
|
||||
|
||||
PKG_NAME:=usb-serial-xr_usb_serial_common
|
||||
PKG_SOURCE_DATE:=2022-03-30
|
||||
PKG_SOURCE_VERSION:=ecc6ebe0141b97942d774e6c6be37a330cc11a74
|
||||
PKG_RELEASE:=$(AUTORELEASE)
|
||||
PKG_SOURCE_DATE:=2023-03-21
|
||||
PKG_SOURCE_VERSION:=90ad530166f096347a5a57b6f9eb21c422a40fd9
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE_PROTO:=git
|
||||
PKG_SOURCE_URL:=https://github.com/kasbert/epsolar-tracer
|
||||
PKG_MIRROR_HASH:=487c4259211411d3c435284016f90c6770539c0a6f904f3327f18381a33c23e3
|
||||
PKG_MIRROR_HASH:=f8572929a66d2eeadc80ef68fb26d5b7a824b87b7959352ff44ad4b3a29dfb78
|
||||
|
||||
PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
|
||||
PKG_LICENSE:=GPL-2.0-or-later
|
||||
|
@ -0,0 +1,52 @@
|
||||
From 5115918c11cc99e93586cef7f33d8d3907b7258a Mon Sep 17 00:00:00 2001
|
||||
From: Adam Duskett <adam.duskett@amarulasolutions.com>
|
||||
Date: Wed, 3 Apr 2024 12:45:41 -0600
|
||||
Subject: [PATCH] Support Linux >= 6.2.0
|
||||
|
||||
FROM: https://github.com/kasbert/epsolar-tracer/pull/61
|
||||
|
||||
Signed-off-by: Adam Duskett <adam.duskett@amarulasolutions.com>
|
||||
---
|
||||
xr_usb_serial_common-1a/xr_usb_serial_common.c | 13 +++++++++++++
|
||||
1 file changed, 13 insertions(+)
|
||||
|
||||
--- a/xr_usb_serial_common-1a/xr_usb_serial_common.c
|
||||
+++ b/xr_usb_serial_common-1a/xr_usb_serial_common.c
|
||||
@@ -643,8 +643,13 @@ static void xr_usb_serial_tty_close(stru
|
||||
tty_port_close(&xr_usb_serial->port, tty, filp);
|
||||
}
|
||||
|
||||
+#if LINUX_VERSION_CODE >= KERNEL_VERSION(6, 2, 0)
|
||||
+static ssize_t xr_usb_serial_tty_write(struct tty_struct *tty,
|
||||
+ const unsigned char *buf, size_t count)
|
||||
+#else
|
||||
static int xr_usb_serial_tty_write(struct tty_struct *tty,
|
||||
const unsigned char *buf, int count)
|
||||
+#endif
|
||||
{
|
||||
struct xr_usb_serial *xr_usb_serial = tty->driver_data;
|
||||
int stat;
|
||||
@@ -655,7 +660,11 @@ static int xr_usb_serial_tty_write(struc
|
||||
if (!count)
|
||||
return 0;
|
||||
|
||||
+#if LINUX_VERSION_CODE >= KERNEL_VERSION(6, 2, 0)
|
||||
+ dev_vdbg(&xr_usb_serial->data->dev, "%s - count %zd\n", __func__, count);
|
||||
+#else
|
||||
dev_vdbg(&xr_usb_serial->data->dev, "%s - count %d\n", __func__, count);
|
||||
+#endif
|
||||
|
||||
spin_lock_irqsave(&xr_usb_serial->write_lock, flags);
|
||||
wbn = xr_usb_serial_wb_alloc(xr_usb_serial);
|
||||
@@ -672,7 +681,11 @@ static int xr_usb_serial_tty_write(struc
|
||||
}
|
||||
|
||||
count = (count > xr_usb_serial->writesize) ? xr_usb_serial->writesize : count;
|
||||
+#if LINUX_VERSION_CODE >= KERNEL_VERSION(6, 2, 0)
|
||||
+ dev_vdbg(&xr_usb_serial->data->dev, "%s - write %zd\n", __func__, count);
|
||||
+#else
|
||||
dev_vdbg(&xr_usb_serial->data->dev, "%s - write %d\n", __func__, count);
|
||||
+#endif
|
||||
memcpy(wb->buf, buf, count);
|
||||
wb->len = count;
|
||||
|
Loading…
Reference in New Issue
Block a user