mirror of
https://github.com/coolsnowwolf/packages
synced 2025-01-07 07:07:02 +08:00
patch: do not patch automake Makefile template
We do not build the tests for this package, so we can avoid needing autoreconf when the host automake version doesn't match the version this package was bootstrapped with by not changing the .am file in this patch. Signed-off-by: Michael Pratt <mcpratt@pm.me>
This commit is contained in:
parent
904bc26fce
commit
7d544a00b9
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=patch
|
||||
PKG_VERSION:=2.7.6
|
||||
PKG_RELEASE:=6
|
||||
PKG_RELEASE:=7
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=@GNU/patch
|
||||
|
@ -8,10 +8,10 @@ Subject: [PATCH] Fix arbitrary command execution in ed-style patches
|
||||
of piping it to ed: this will cause ed to abort on invalid commands
|
||||
instead of rejecting them and carrying on.
|
||||
* tests/ed-style: New test case.
|
||||
* tests/Makefile.am (TESTS): Add test case.
|
||||
* tests/Makefile.am (TESTS): Add test case. (OPENWRT REMOVED)
|
||||
---
|
||||
src/pch.c | 89 +++++++++++++++++++++++++++++++++++------------
|
||||
tests/Makefile.am | 1 +
|
||||
tests/Makefile.am | 1 + (OPENWRT REMOVED)
|
||||
tests/ed-style | 41 ++++++++++++++++++++++
|
||||
3 files changed, 108 insertions(+), 23 deletions(-)
|
||||
create mode 100644 tests/ed-style
|
||||
@ -143,16 +143,6 @@ instead of rejecting them and carrying on.
|
||||
|
||||
if (ofp)
|
||||
{
|
||||
--- a/tests/Makefile.am
|
||||
+++ b/tests/Makefile.am
|
||||
@@ -32,6 +32,7 @@ TESTS = \
|
||||
crlf-handling \
|
||||
dash-o-append \
|
||||
deep-directories \
|
||||
+ ed-style \
|
||||
empty-files \
|
||||
false-match \
|
||||
fifo \
|
||||
--- /dev/null
|
||||
+++ b/tests/ed-style
|
||||
@@ -0,0 +1,41 @@
|
||||
|
Loading…
Reference in New Issue
Block a user