mirror of
https://github.com/coolsnowwolf/packages
synced 2025-01-08 11:17:36 +08:00
shairport-sync: bump to v3.3.6
This commit is contained in:
parent
192b99ccd8
commit
8580bd51aa
@ -7,20 +7,16 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=shairport-sync
|
||||
PKG_VERSION:=3.1.6
|
||||
PKG_VERSION:=3.3.6
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE_PROTO:=git
|
||||
PKG_SOURCE_URL:=git://github.com/mikebrady/shairport-sync.git
|
||||
PKG_SOURCE_VERSION:=$(PKG_VERSION)
|
||||
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_MIRROR_HASH:=8f440a6bca6a58d04f7c0f6c7ea711b31a0aa4abc7e4d8f4da7346a085dcd966
|
||||
PKG_SOURCE_URL:=https://github.com/mikebrady/shairport-sync.git
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_VERSION:=4c6628abe47cc3f1cb4ced4ba0112ca124df6be9
|
||||
|
||||
PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>, \
|
||||
Mike Brady <mikebrady@eircom.net>
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_SOURCE_SUBDIR)
|
||||
|
||||
PKG_LICENSE:=MIT
|
||||
PKG_LICENSE_FILES:=COPYING LICENSES shairport.c
|
||||
|
||||
@ -33,9 +29,9 @@ define Package/shairport-sync/default
|
||||
SECTION:=sound
|
||||
CATEGORY:=Sound
|
||||
TITLE:=AirPlay compatible audio player
|
||||
DEPENDS:=@AUDIO_SUPPORT +libpthread +libstdcpp +alsa-lib +libconfig +libdaemon +libpopt
|
||||
DEPENDS:=@AUDIO_SUPPORT +libpthread +alsa-lib +libconfig +libdaemon +libpopt
|
||||
PROVIDES:=shairport-sync
|
||||
URL:=http://github.com/mikebrady/shairport-sync
|
||||
URL:=https://github.com/mikebrady/shairport-sync
|
||||
endef
|
||||
|
||||
define Package/shairport-sync-openssl
|
||||
@ -113,7 +109,7 @@ define Package/shairport-sync/default/install
|
||||
$(INSTALL_DIR) $(1)/etc/init.d
|
||||
$(INSTALL_BIN) ./files/shairport-sync.init $(1)/etc/init.d/shairport-sync
|
||||
$(INSTALL_DIR) $(1)/etc/config
|
||||
$(INSTALL_DATA) ./files/shairport-sync.config $(1)/etc/config/shairport-sync
|
||||
$(INSTALL_CONF) ./files/shairport-sync.config $(1)/etc/config/shairport-sync
|
||||
endef
|
||||
|
||||
Package/shairport-sync-openssl/install = $(Package/shairport-sync/default/install)
|
||||
|
35
sound/shairport-sync/patches/010-no-cxx.patch
Normal file
35
sound/shairport-sync/patches/010-no-cxx.patch
Normal file
@ -0,0 +1,35 @@
|
||||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -23,10 +23,6 @@ else
|
||||
endif
|
||||
endif
|
||||
|
||||
-if USE_APPLE_ALAC
|
||||
- shairport_sync_SOURCES += apple_alac.cpp
|
||||
-endif
|
||||
-
|
||||
if USE_CUSTOMPIDDIR
|
||||
AM_CFLAGS+= \
|
||||
-DPIDDIR=\"$(CUSTOM_PID_DIR)\"
|
||||
@@ -80,11 +76,6 @@ if USE_PA
|
||||
shairport_sync_SOURCES += audio_pa.c
|
||||
endif
|
||||
|
||||
-if USE_CONVOLUTION
|
||||
-shairport_sync_SOURCES += FFTConvolver/AudioFFT.cpp FFTConvolver/FFTConvolver.cpp FFTConvolver/Utilities.cpp FFTConvolver/convolver.cpp
|
||||
-AM_CXXFLAGS += -std=c++11
|
||||
-endif
|
||||
-
|
||||
if USE_DNS_SD
|
||||
shairport_sync_SOURCES += mdns_dns_sd.c
|
||||
endif
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -19,7 +19,6 @@ with_os=`echo ${with_os} | tr '[[:upper:]]' '[[:lower:]]' `
|
||||
|
||||
# Checks for programs.
|
||||
AC_PROG_CC
|
||||
-AC_PROG_CXX
|
||||
AC_PROG_INSTALL
|
||||
|
||||
PKG_PROG_PKG_CONFIG([0.9.0])
|
Loading…
Reference in New Issue
Block a user