mirror of
https://github.com/coolsnowwolf/packages
synced 2025-01-05 11:36:49 +08:00
opendkim: use pkgconfig for libbsd
Allows using the overlay. Also remove the outdated uClibc patch. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
cfd42842a9
commit
8fd6c03978
@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=opendkim
|
||||
PKG_VERSION:=2.10.3
|
||||
PKG_RELEASE:=5
|
||||
PKG_RELEASE:=6
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=@SF/$(PKG_NAME)
|
||||
@ -61,14 +61,14 @@ define Package/opendkim-tools/description
|
||||
opendkim-genzone, opendkim-testkey and opendkim-testmsg tools.
|
||||
endef
|
||||
|
||||
TARGET_CFLAGS += $(FPIC)
|
||||
|
||||
CONFIGURE_ARGS += \
|
||||
--without-db \
|
||||
--without-gcov \
|
||||
--without-gprof \
|
||||
--without-lcov \
|
||||
--with-milter=$(STAGING_DIR)/usr
|
||||
$(if $(CONFIG_USE_GLIBC),,--without-libbsd) \
|
||||
--with-milter=$(STAGING_DIR)/usr \
|
||||
--with-pic
|
||||
|
||||
define Build/InstallDev
|
||||
$(INSTALL_DIR) $(1)/usr/lib $(1)/usr/sbin
|
||||
|
2143
mail/opendkim/patches/020-libbsd.patch
Normal file
2143
mail/opendkim/patches/020-libbsd.patch
Normal file
File diff suppressed because it is too large
Load Diff
@ -1,20 +0,0 @@
|
||||
--- a/libopendkim/dkim-dns.c
|
||||
+++ b/libopendkim/dkim-dns.c
|
||||
@@ -163,6 +163,9 @@ int
|
||||
dkim_res_query(void *srv, int type, unsigned char *query, unsigned char *buf,
|
||||
size_t buflen, void **qh)
|
||||
{
|
||||
+#ifdef __UCLIBC__
|
||||
+ return DKIM_DNS_ERROR;
|
||||
+#else
|
||||
int n;
|
||||
int ret;
|
||||
struct dkim_res_qh *rq;
|
||||
@@ -209,6 +212,7 @@ dkim_res_query(void *srv, int type, unsi
|
||||
*qh = (void *) rq;
|
||||
|
||||
return DKIM_DNS_SUCCESS;
|
||||
+#endif // __UCLIBC__
|
||||
}
|
||||
|
||||
/*
|
Loading…
Reference in New Issue
Block a user