mirror of
https://github.com/coolsnowwolf/packages
synced 2025-01-07 07:07:02 +08:00
libgphoto2: update to 2.5.30
Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
6aeeafce8c
commit
9c0591edf9
@ -9,13 +9,13 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=libgphoto2
|
||||
PKG_VERSION:=2.5.26
|
||||
PKG_RELEASE:=3
|
||||
PORT_VERSION:=0.12.0
|
||||
PKG_VERSION:=2.5.30
|
||||
PKG_RELEASE:=1
|
||||
PORT_VERSION:=0.12.1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=@SF/gphoto
|
||||
PKG_HASH:=7740fea3cbb78489071cdfec06c07fab528e69e27ac82734eae6a73eaeeabcd4
|
||||
PKG_HASH:=ee61a1dac6ad5cf711d114e06b90a6d431961a6e7ec59f4b757a7cd77b1c0fb4
|
||||
|
||||
PKG_MAINTAINER:=Leonardo Medici <leonardo_medici@me.com>
|
||||
PKG_LICENSE:=LGPL-2.1-or-later
|
||||
@ -436,7 +436,7 @@ CONFIGURE_ARGS += \
|
||||
--enable-shared \
|
||||
--enable-static \
|
||||
--disable-rpath \
|
||||
--with-camlibs="all,outdated" \
|
||||
--with-camlibs="standard,outdated" \
|
||||
--with-gdlib=no \
|
||||
--with-libexif=no \
|
||||
--with-libusb=no \
|
||||
@ -446,29 +446,9 @@ CONFIGURE_ARGS += \
|
||||
--without-jpeg \
|
||||
--without-libiconv-prefix \
|
||||
--without-libintl-prefix \
|
||||
--with-pic
|
||||
|
||||
CONFIGURE_VARS += \
|
||||
CPPFLAGS="$$$$CPPFLAGS $(ICONV_CFLAGS)" \
|
||||
LDFLAGS="$$$$LDFLAGS $(ICONV_LDFLAGS)" \
|
||||
LIBUSB_CFLAGS="$$$$CPPFLAGS" \
|
||||
LIBUSB_LIBS="$$$$LDFLAGS -lusb" \
|
||||
LIBS="-lltdl" \
|
||||
|
||||
# LIBEXIF_CFLAGS="$$$$CPPFLAGS" \
|
||||
# LIBEXIF_LIBS="$$$$LDFLAGS -lexif" \
|
||||
|
||||
# If OpenWrt is using the iconv stub, we disable iconv support
|
||||
# in libgphoto2 entirely since the stub lacks some essential
|
||||
# conversions like UCS-2 to UTF-8 which will let certain drivers
|
||||
# fail with "Failed to create iconv converter" .
|
||||
ifneq ($(ICONV_FULL),1)
|
||||
CONFIGURE_VARS += am_cv_func_iconv=no am_cv_lib_iconv=no
|
||||
endif
|
||||
|
||||
MAKE_FLAGS += \
|
||||
LIBLTDL="" \
|
||||
|
||||
TARGET_CFLAGS += $(FPIC)
|
||||
TARGET_LDFLAGS += $(if $(INTL_FULL),-lintl) -lltdl
|
||||
|
||||
define Build/InstallDev
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
|
@ -1,20 +0,0 @@
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -244,7 +244,6 @@ ALL_LINGUAS="cs da de es eu fr hu it ja
|
||||
GP_GETTEXT_HACK([${PACKAGE}-${LIBGPHOTO2_CURRENT_MIN}],[The gPhoto Team],[${MAIL_GPHOTO_TRANSLATION}])
|
||||
AM_GNU_GETTEXT_VERSION([0.14.1])
|
||||
AM_GNU_GETTEXT([external])
|
||||
-AM_PO_SUBDIRS()
|
||||
AM_ICONV()
|
||||
GP_GETTEXT_FLAGS()
|
||||
|
||||
--- a/libgphoto2_port/configure.ac
|
||||
+++ b/libgphoto2_port/configure.ac
|
||||
@@ -124,7 +124,6 @@ GP_GETTEXT_HACK([${PACKAGE}-${LIBGPHOTO2
|
||||
ALL_LINGUAS="cs da de es eu fi fr it ja nl pl pt_BR ru sk sr sv uk vi zh_CN zh_TW"
|
||||
AM_GNU_GETTEXT_VERSION([0.14.1])
|
||||
AM_GNU_GETTEXT([external])
|
||||
-AM_PO_SUBDIRS()
|
||||
AM_ICONV()
|
||||
GP_GETTEXT_FLAGS()
|
||||
|
@ -1,83 +0,0 @@
|
||||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -9,7 +9,7 @@ EXTRA_DIST = MAINTAINERS TESTERS install
|
||||
EXTRA_DIST += HACKING.md SECURITY.md
|
||||
|
||||
# Note: @subdirs@ lists all the directories from AC_CONFIG_SUBDIRS()
|
||||
-SUBDIRS = @subdirs@ libgphoto2 camlibs tests examples po packaging doc gphoto-m4
|
||||
+SUBDIRS = @subdirs@ libgphoto2 camlibs packaging gphoto-m4
|
||||
|
||||
EXTRA_DIST += libgphoto2.pc.in
|
||||
pkgconfig_DATA = libgphoto2.pc
|
||||
--- a/Makefile.in
|
||||
+++ b/Makefile.in
|
||||
@@ -503,7 +503,7 @@ EXTRA_DIST = MAINTAINERS TESTERS install
|
||||
README.packaging
|
||||
|
||||
# Note: @subdirs@ lists all the directories from AC_CONFIG_SUBDIRS()
|
||||
-SUBDIRS = @subdirs@ libgphoto2 camlibs tests examples po packaging doc gphoto-m4
|
||||
+SUBDIRS = @subdirs@ libgphoto2 camlibs packaging gphoto-m4
|
||||
pkgconfig_DATA = libgphoto2.pc
|
||||
noinst_DATA = libgphoto2-uninstalled.pc
|
||||
doc_DATA = AUTHORS COPYING NEWS ABOUT-NLS ChangeLog README.md \
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -706,20 +706,11 @@ gphoto-m4/Makefile
|
||||
libgphoto2/Makefile
|
||||
libgphoto2.pc
|
||||
libgphoto2-uninstalled.pc
|
||||
-examples/Makefile
|
||||
-tests/Makefile
|
||||
-tests/ddb/Makefile
|
||||
-tests/ddb/check-ddb.sh
|
||||
packaging/Makefile
|
||||
packaging/linux-hotplug/Makefile
|
||||
packaging/generic/Makefile
|
||||
packaging/rpm/Makefile
|
||||
packaging/rpm/package.spec
|
||||
-po/Makefile.in
|
||||
-doc/Makefile
|
||||
-doc/Doxyfile
|
||||
-doc/Doxyfile-internals
|
||||
-doc/api/Makefile
|
||||
],[
|
||||
dnl This relies on this code being called for each of the above files
|
||||
dnl with ac_file set to the filename.
|
||||
--- a/libgphoto2_port/Makefile.am
|
||||
+++ b/libgphoto2_port/Makefile.am
|
||||
@@ -25,7 +25,7 @@ udevscript_PROGRAMS =
|
||||
bin_SCRIPTS = gphoto2-port-config
|
||||
|
||||
# The . stands for the current dir, i.e. the iolibs to build.
|
||||
-SUBDIRS = po libgphoto2_port test . doc gphoto-m4
|
||||
+SUBDIRS = libgphoto2_port . gphoto-m4
|
||||
|
||||
|
||||
########################################################################
|
||||
--- a/libgphoto2_port/Makefile.in
|
||||
+++ b/libgphoto2_port/Makefile.in
|
||||
@@ -581,7 +581,7 @@ EXTRA_LTLIBRARIES = disk.la ptpip.la ser
|
||||
bin_SCRIPTS = gphoto2-port-config
|
||||
|
||||
# The . stands for the current dir, i.e. the iolibs to build.
|
||||
-SUBDIRS = po libgphoto2_port test . doc gphoto-m4
|
||||
+SUBDIRS = libgphoto2_port . gphoto-m4
|
||||
|
||||
########################################################################
|
||||
# All iolibs are defined as EXTRA_LTLIBRARIES. This requires that
|
||||
--- a/libgphoto2_port/configure.ac
|
||||
+++ b/libgphoto2_port/configure.ac
|
||||
@@ -536,13 +536,10 @@ AC_SUBST([AM_LDFLAGS])
|
||||
# ---------------------------------------------------------------------------
|
||||
AC_CONFIG_FILES([
|
||||
Makefile
|
||||
-po/Makefile.in
|
||||
libgphoto2_port/Makefile
|
||||
libgphoto2_port.pc
|
||||
libgphoto2_port-uninstalled.pc
|
||||
gphoto2-port-config
|
||||
-test/Makefile
|
||||
-doc/Makefile
|
||||
gphoto-m4/Makefile
|
||||
])
|
||||
AC_OUTPUT
|
Loading…
Reference in New Issue
Block a user