mirror of
https://github.com/coolsnowwolf/packages
synced 2025-01-09 04:37:41 +08:00
grep: update to 3.8
Manually refresh: - ppc-musl.patch Release Notes: https://lists.gnu.org/archive/html/info-gnu/2022-09/msg00001.html Signed-off-by: Nick Hainke <vincent@systemli.org>
This commit is contained in:
parent
af4f864262
commit
afcf2945e8
@ -8,12 +8,12 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=grep
|
PKG_NAME:=grep
|
||||||
PKG_VERSION:=3.7
|
PKG_VERSION:=3.8
|
||||||
PKG_RELEASE:=2
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||||
PKG_SOURCE_URL:=@GNU/grep
|
PKG_SOURCE_URL:=@GNU/grep
|
||||||
PKG_HASH:=5c10da312460aec721984d5d83246d24520ec438dd48d7ab5a05dbc0d6d6823c
|
PKG_HASH:=498d7cc1b4fb081904d87343febb73475cf771e424fb7e6141aff66013abc382
|
||||||
|
|
||||||
PKG_MAINTAINER:=Julen Landa Alustiza <julen@zokormazo.info>
|
PKG_MAINTAINER:=Julen Landa Alustiza <julen@zokormazo.info>
|
||||||
PKG_LICENSE:=GPL-3.0-or-later
|
PKG_LICENSE:=GPL-3.0-or-later
|
||||||
|
@ -1,15 +1,15 @@
|
|||||||
https://github.com/void-linux/void-packages/commit/0d9556b8593d6e67027fb1c83d176b7f899547e5
|
https://github.com/void-linux/void-packages/commit/0d9556b8593d6e67027fb1c83d176b7f899547e5
|
||||||
--- a/lib/sigsegv.c
|
--- a/lib/sigsegv.c
|
||||||
+++ b/lib/sigsegv.c
|
+++ b/lib/sigsegv.c
|
||||||
@@ -221,8 +221,10 @@ int libsigsegv_version = LIBSIGSEGV_VERS
|
@@ -246,8 +246,10 @@ int libsigsegv_version = LIBSIGSEGV_VERS
|
||||||
/* both should be equivalent */
|
/* Because of the union, both definitions should be equivalent. */
|
||||||
# if 0
|
# if 0
|
||||||
# define SIGSEGV_FAULT_STACKPOINTER ((ucontext_t *) ucp)->uc_mcontext.regs->gpr[1]
|
# define SIGSEGV_FAULT_STACKPOINTER ((ucontext_t *) ucp)->uc_mcontext.regs->gpr[1]
|
||||||
-# else
|
-# else
|
||||||
+# elif defined(__GLIBC__)
|
+# elif defined(__GLIBC__)
|
||||||
# define SIGSEGV_FAULT_STACKPOINTER ((ucontext_t *) ucp)->uc_mcontext.uc_regs->gregs[1]
|
# define SIGSEGV_FAULT_STACKPOINTER ((ucontext_t *) ucp)->uc_mcontext.uc_regs->gregs[1]
|
||||||
+# else
|
+# else
|
||||||
+# define SIGSEGV_FAULT_STACKPOINTER ((ucontext_t *) ucp)->uc_mcontext.gregs[1]
|
+# define SIGSEGV_FAULT_STACKPOINTER ((ucontext_t *) ucp)->uc_mcontext.gregs[1]
|
||||||
|
# endif
|
||||||
# endif
|
# endif
|
||||||
# endif
|
# endif
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user