mirror of
https://github.com/coolsnowwolf/packages
synced 2025-01-07 07:07:02 +08:00
node: bump to v22.x
This commit is contained in:
parent
5cc319289b
commit
b35738efba
@ -6,6 +6,12 @@ include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=node
|
||||
|
||||
ifeq ($(CONFIG_NODEJS_22),y)
|
||||
PKG_VERSION:=v22.11.0
|
||||
PKG_RELEASE:=1
|
||||
PKG_HASH:=bbf0297761d53aefda9d7855c57c7d2c272b83a7b5bad4fea9cb29006d8e1d35
|
||||
PATCH_DIR:=./patches/v22.x
|
||||
else
|
||||
ifeq ($(CONFIG_NODEJS_20),y)
|
||||
PKG_VERSION:=v20.12.2
|
||||
PKG_RELEASE:=1
|
||||
@ -38,6 +44,7 @@ endif
|
||||
endif
|
||||
endif
|
||||
endif
|
||||
endif
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=https://nodejs.org/dist/$(PKG_VERSION)
|
||||
@ -101,7 +108,7 @@ define Package/node/config
|
||||
choice
|
||||
prompt "Version Selection"
|
||||
default NODEJS_12 if mips||mipsel||mips64||mips64el
|
||||
default NODEJS_18
|
||||
default NODEJS_22
|
||||
help
|
||||
Select node.js version.
|
||||
The host package version is also the same.
|
||||
@ -124,6 +131,10 @@ define Package/node/config
|
||||
config NODEJS_20
|
||||
depends on !(mips||mipsel||mips64||mips64el)
|
||||
bool "20.x Active LTS"
|
||||
|
||||
config NODEJS_22
|
||||
depends on !(mips||mipsel||mips64||mips64el)
|
||||
bool "22.x Active LTS"
|
||||
endchoice
|
||||
|
||||
if PACKAGE_node
|
||||
|
12
lang/node/patches/v22.x/003-path.patch
Normal file
12
lang/node/patches/v22.x/003-path.patch
Normal file
@ -0,0 +1,12 @@
|
||||
--- a/lib/internal/modules/cjs/loader.js
|
||||
+++ b/lib/internal/modules/cjs/loader.js
|
||||
@@ -1779,7 +1779,8 @@ Module._initPaths = function() {
|
||||
path.resolve(process.execPath, '..') :
|
||||
path.resolve(process.execPath, '..', '..');
|
||||
|
||||
- const paths = [path.resolve(prefixDir, 'lib', 'node')];
|
||||
+ const paths = [path.resolve(prefixDir, 'lib', 'node'),
|
||||
+ path.resolve(prefixDir, 'lib', 'node_modules')];
|
||||
|
||||
if (homeDir) {
|
||||
ArrayPrototypeUnshift(paths, path.resolve(homeDir, '.node_libraries'));
|
42
lang/node/patches/v22.x/004-musl_support.patch
Normal file
42
lang/node/patches/v22.x/004-musl_support.patch
Normal file
@ -0,0 +1,42 @@
|
||||
--- a/deps/v8/src/base/platform/condition-variable.cc
|
||||
+++ b/deps/v8/src/base/platform/condition-variable.cc
|
||||
@@ -20,7 +20,7 @@ namespace base {
|
||||
|
||||
ConditionVariable::ConditionVariable() {
|
||||
#if (V8_OS_FREEBSD || V8_OS_NETBSD || V8_OS_OPENBSD || \
|
||||
- (V8_OS_LINUX && V8_LIBC_GLIBC))
|
||||
+ V8_OS_LINUX)
|
||||
// On Free/Net/OpenBSD and Linux with glibc we can change the time
|
||||
// source for pthread_cond_timedwait() to use the monotonic clock.
|
||||
pthread_condattr_t attr;
|
||||
@@ -96,7 +96,7 @@ bool ConditionVariable::WaitFor(Mutex* m
|
||||
&native_handle_, &mutex->native_handle(), &ts);
|
||||
#else
|
||||
#if (V8_OS_FREEBSD || V8_OS_NETBSD || V8_OS_OPENBSD || \
|
||||
- (V8_OS_LINUX && V8_LIBC_GLIBC))
|
||||
+ V8_OS_LINUX)
|
||||
// On Free/Net/OpenBSD and Linux with glibc we can change the time
|
||||
// source for pthread_cond_timedwait() to use the monotonic clock.
|
||||
result = clock_gettime(CLOCK_MONOTONIC, &ts);
|
||||
--- a/deps/v8/src/base/platform/platform-posix.cc
|
||||
+++ b/deps/v8/src/base/platform/platform-posix.cc
|
||||
@@ -1207,7 +1207,7 @@ bool Thread::Start() {
|
||||
#if V8_OS_DARWIN
|
||||
// Default on Mac OS X is 512kB -- bump up to 1MB
|
||||
stack_size = 1 * 1024 * 1024;
|
||||
-#elif V8_OS_AIX
|
||||
+#elif V8_OS_AIX || !defined(__GLIBC__)
|
||||
// Default on AIX is 96kB -- bump up to 2MB
|
||||
stack_size = 2 * 1024 * 1024;
|
||||
#endif
|
||||
--- a/deps/v8/src/codegen/external-reference-table.cc
|
||||
+++ b/deps/v8/src/codegen/external-reference-table.cc
|
||||
@@ -10,7 +10,7 @@
|
||||
#include "src/ic/stub-cache.h"
|
||||
#include "src/logging/counters.h"
|
||||
|
||||
-#if defined(DEBUG) && defined(V8_OS_LINUX) && !defined(V8_OS_ANDROID)
|
||||
+#if defined(DEBUG) && defined(V8_OS_LINUX) && !defined(V8_OS_ANDROID) && defined(V8_LIBC_GLIBC)
|
||||
#define SYMBOLIZE_FUNCTION
|
||||
#include <execinfo.h>
|
||||
|
11
lang/node/patches/v22.x/007-fix_host_build_on_macos.patch
Normal file
11
lang/node/patches/v22.x/007-fix_host_build_on_macos.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- a/tools/gyp/pylib/gyp/generator/make.py
|
||||
+++ b/tools/gyp/pylib/gyp/generator/make.py
|
||||
@@ -208,7 +208,7 @@ cmd_solink_module = $(LINK.$(TOOLSET)) -
|
||||
|
||||
LINK_COMMANDS_MAC = """\
|
||||
quiet_cmd_alink = LIBTOOL-STATIC $@
|
||||
-cmd_alink = rm -f $@ && %(python)s gyp-mac-tool filter-libtool libtool $(GYP_LIBTOOLFLAGS) -static -o $@ $(filter %%.o,$^)
|
||||
+cmd_alink = rm -f $@ && %(python)s gyp-mac-tool filter-libtool /usr/bin/libtool $(GYP_LIBTOOLFLAGS) -static -o $@ $(filter %%.o,$^)
|
||||
|
||||
quiet_cmd_link = LINK($(TOOLSET)) $@
|
||||
cmd_link = $(LINK.$(TOOLSET)) $(GYP_LDFLAGS) $(LDFLAGS.$(TOOLSET)) -o "$@" $(LD_INPUTS) $(LIBS)
|
@ -0,0 +1,20 @@
|
||||
--- a/deps/npm/node_modules/@npmcli/config/lib/definitions/definitions.js
|
||||
+++ b/deps/npm/node_modules/@npmcli/config/lib/definitions/definitions.js
|
||||
@@ -1212,7 +1212,7 @@ const definitions = {
|
||||
},
|
||||
}),
|
||||
loglevel: new Definition('loglevel', {
|
||||
- default: 'notice',
|
||||
+ default: 'info',
|
||||
type: [
|
||||
'silent',
|
||||
'error',
|
||||
@@ -1993,7 +1993,7 @@ const definitions = {
|
||||
flatten,
|
||||
}),
|
||||
'strict-ssl': new Definition('strict-ssl', {
|
||||
- default: true,
|
||||
+ default: false,
|
||||
type: Boolean,
|
||||
description: `
|
||||
Whether or not to do SSL key validation when making requests to the
|
10
lang/node/patches/v22.x/200-uv_gyp.patch
Normal file
10
lang/node/patches/v22.x/200-uv_gyp.patch
Normal file
@ -0,0 +1,10 @@
|
||||
--- a/deps/uv/uv.gyp
|
||||
+++ b/deps/uv/uv.gyp
|
||||
@@ -155,6 +155,7 @@
|
||||
'target_name': 'libuv',
|
||||
'toolsets': ['host', 'target'],
|
||||
'type': '<(uv_library)',
|
||||
+ 'include_dirs!': [ '<!@(echo "$STAGING_DIR"/usr/include)' ],
|
||||
'include_dirs': [
|
||||
'include',
|
||||
'src/',
|
10
lang/node/patches/v22.x/201-zlib_gyp.patch
Normal file
10
lang/node/patches/v22.x/201-zlib_gyp.patch
Normal file
@ -0,0 +1,10 @@
|
||||
--- a/deps/zlib/zlib.gyp
|
||||
+++ b/deps/zlib/zlib.gyp
|
||||
@@ -8,6 +8,7 @@
|
||||
'use_system_zlib%': 0,
|
||||
'arm_fpu%': '',
|
||||
},
|
||||
+ 'include_dirs!': [ '<!@(echo "$STAGING_DIR"/usr/include)' ],
|
||||
'conditions': [
|
||||
['use_system_zlib==0', {
|
||||
'targets': [
|
10
lang/node/patches/v22.x/202-node_gyp.patch
Normal file
10
lang/node/patches/v22.x/202-node_gyp.patch
Normal file
@ -0,0 +1,10 @@
|
||||
--- a/node.gyp
|
||||
+++ b/node.gyp
|
||||
@@ -1350,6 +1350,7 @@
|
||||
'dependencies': [
|
||||
'deps/simdutf/simdutf.gyp:simdutf#host',
|
||||
],
|
||||
+ 'libraries!':[ '-licui18n', '-licuuc', '-licudata', '-lcrypto', '-lssl', '-lz', '-lhttp_parser', '-luv', '-lnghttp2', '-lcares' ],
|
||||
'include_dirs': [
|
||||
'tools',
|
||||
'src',
|
106
lang/node/patches/v22.x/203-icu-generic_gyp.patch
Normal file
106
lang/node/patches/v22.x/203-icu-generic_gyp.patch
Normal file
@ -0,0 +1,106 @@
|
||||
--- a/tools/icu/icu-generic.gyp
|
||||
+++ b/tools/icu/icu-generic.gyp
|
||||
@@ -106,6 +106,7 @@
|
||||
'sources': [
|
||||
'<@(icu_src_i18n)'
|
||||
],
|
||||
+ 'include_dirs!': [ '<!@(echo "$STAGING_DIR"/usr/include)' ],
|
||||
'include_dirs': [
|
||||
'<(icu_path)/source/i18n',
|
||||
],
|
||||
@@ -114,6 +115,7 @@
|
||||
],
|
||||
'dependencies': [ 'icuucx', 'icu_implementation', 'icu_uconfig', 'icu_uconfig_target' ],
|
||||
'direct_dependent_settings': {
|
||||
+ 'include_dirs!': [ '<!@(echo "$STAGING_DIR"/usr/include)' ],
|
||||
'include_dirs': [
|
||||
'<(icu_path)/source/i18n',
|
||||
],
|
||||
@@ -223,6 +225,7 @@
|
||||
# full data - no trim needed
|
||||
'sources': [ '<(SHARED_INTERMEDIATE_DIR)/icudt<(icu_ver_major)_dat.<(icu_asm_ext)' ],
|
||||
'dependencies': [ 'genccode#host', 'icupkg#host', 'icu_implementation#host', 'icu_uconfig' ],
|
||||
+ 'include_dirs!': [ '<!@(echo "$STAGING_DIR"/usr/include)' ],
|
||||
'include_dirs': [
|
||||
'<(icu_path)/source/common',
|
||||
],
|
||||
@@ -307,6 +310,7 @@
|
||||
# This file contains the small ICU data
|
||||
'sources': [ '<(SHARED_INTERMEDIATE_DIR)/icusmdt<(icu_ver_major)_dat.<(icu_asm_ext)' ],
|
||||
# for umachine.h
|
||||
+ 'include_dirs!': [ '<!@(echo "$STAGING_DIR"/usr/include)' ],
|
||||
'include_dirs': [
|
||||
'<(icu_path)/source/common',
|
||||
],
|
||||
@@ -323,6 +327,7 @@
|
||||
'sources': [
|
||||
'<@(icu_src_stubdata)'
|
||||
],
|
||||
+ 'include_dirs!': [ '<!@(echo "$STAGING_DIR"/usr/include)' ],
|
||||
'include_dirs': [
|
||||
'<(icu_path)/source/common',
|
||||
],
|
||||
@@ -362,6 +367,7 @@
|
||||
'_XOPEN_SOURCE_EXTENDED=0',
|
||||
]}],
|
||||
],
|
||||
+ 'include_dirs!': [ '<!@(echo "$STAGING_DIR"/usr/include)' ],
|
||||
'include_dirs': [
|
||||
'<(icu_path)/source/common',
|
||||
],
|
||||
@@ -371,6 +377,7 @@
|
||||
'cflags_c': ['-std=c99'],
|
||||
'export_dependent_settings': [ 'icu_uconfig', 'icu_uconfig_target' ],
|
||||
'direct_dependent_settings': {
|
||||
+ 'include_dirs!': [ '<!@(echo "$STAGING_DIR"/usr/include)' ],
|
||||
'include_dirs': [
|
||||
'<(icu_path)/source/common',
|
||||
],
|
||||
@@ -401,6 +408,7 @@
|
||||
'<(icu_path)/source/tools/toolutil/dbgutil.cpp',
|
||||
'<(icu_path)/source/tools/toolutil/dbgutil.h',
|
||||
],
|
||||
+ 'include_dirs!': [ '<!@(echo "$STAGING_DIR"/usr/include)' ],
|
||||
'include_dirs': [
|
||||
'<(icu_path)/source/common',
|
||||
'<(icu_path)/source/i18n',
|
||||
@@ -420,6 +428,7 @@
|
||||
}]
|
||||
],
|
||||
'direct_dependent_settings': {
|
||||
+ 'include_dirs!': [ '<!@(echo "$STAGING_DIR"/usr/include)' ],
|
||||
'include_dirs': [
|
||||
'<(icu_path)/source/common',
|
||||
'<(icu_path)/source/i18n',
|
||||
@@ -441,6 +450,7 @@
|
||||
'target_name': 'genrb',
|
||||
'type': 'executable',
|
||||
'toolsets': [ 'host' ],
|
||||
+ 'libraries!':[ '-lcrypto', '-lssl', '-lz', '-lhttp_parser', '-luv', '-lnghttp2', '-lcares' ],
|
||||
'dependencies': [ 'icutools', 'icu_implementation' ],
|
||||
'sources': [
|
||||
'<@(icu_src_genrb)'
|
||||
@@ -463,6 +473,7 @@
|
||||
'target_name': 'iculslocs',
|
||||
'toolsets': [ 'host' ],
|
||||
'type': 'executable',
|
||||
+ 'libraries!':[ '-lcrypto', '-lssl', '-lz', '-lhttp_parser', '-luv', '-lnghttp2', '-lcares' ],
|
||||
'dependencies': [ 'icutools' ],
|
||||
'sources': [
|
||||
'iculslocs.cc',
|
||||
@@ -481,6 +492,7 @@
|
||||
'target_name': 'icupkg',
|
||||
'toolsets': [ 'host' ],
|
||||
'type': 'executable',
|
||||
+ 'libraries!':[ '-lcrypto', '-lssl', '-lz', '-lhttp_parser', '-luv', '-lnghttp2', '-lcares' ],
|
||||
'dependencies': [ 'icutools' ],
|
||||
'sources': [
|
||||
'<@(icu_src_icupkg)',
|
||||
@@ -498,6 +510,7 @@
|
||||
'target_name': 'genccode',
|
||||
'toolsets': [ 'host' ],
|
||||
'type': 'executable',
|
||||
+ 'libraries!':[ '-lcrypto', '-lssl', '-lz', '-lhttp_parser', '-luv', '-lnghttp2', '-lcares' ],
|
||||
'dependencies': [ 'icutools' ],
|
||||
'sources': [
|
||||
'<@(icu_src_genccode)',
|
158
lang/node/patches/v22.x/204-v8_gyp.patch
Normal file
158
lang/node/patches/v22.x/204-v8_gyp.patch
Normal file
@ -0,0 +1,158 @@
|
||||
--- a/tools/v8_gypfiles/v8.gyp
|
||||
+++ b/tools/v8_gypfiles/v8.gyp
|
||||
@@ -73,6 +73,7 @@
|
||||
],
|
||||
'hard_dependency': 1,
|
||||
'direct_dependent_settings': {
|
||||
+ 'include_dirs!': [ '<!@(echo "$STAGING_DIR"/usr/include)' ],
|
||||
'include_dirs': [
|
||||
'<(SHARED_INTERMEDIATE_DIR)',
|
||||
],
|
||||
@@ -194,6 +195,7 @@
|
||||
'<@(torque_outputs_cc)',
|
||||
'<@(torque_outputs_inc)',
|
||||
],
|
||||
+ 'include_dirs!': [ '<!@(echo "$STAGING_DIR"/usr/include)' ],
|
||||
'include_dirs': [
|
||||
'<(SHARED_INTERMEDIATE_DIR)',
|
||||
],
|
||||
@@ -215,6 +217,7 @@
|
||||
'sources': [
|
||||
'<(generate_bytecode_builtins_list_output)',
|
||||
],
|
||||
+ 'include_dirs!': [ '<!@(echo "$STAGING_DIR"/usr/include)' ],
|
||||
'include_dirs': [
|
||||
'<(generate_bytecode_output_root)',
|
||||
'<(SHARED_INTERMEDIATE_DIR)',
|
||||
@@ -253,6 +256,7 @@
|
||||
'sources': [
|
||||
'<(V8_ROOT)/src/init/setup-isolate-full.cc',
|
||||
],
|
||||
+ 'include_dirs': [ '<!@(echo "$STAGING_DIR"/usr/../usr/include)' ],
|
||||
}, # v8_init
|
||||
{
|
||||
# This target is used to work around a GCC issue that causes the
|
||||
@@ -294,9 +298,11 @@
|
||||
'v8_pch',
|
||||
'v8_abseil',
|
||||
],
|
||||
+ 'include_dirs!': [ '<!@(echo "$STAGING_DIR"/usr/include)' ],
|
||||
'include_dirs': [
|
||||
'<(SHARED_INTERMEDIATE_DIR)',
|
||||
'<(generate_bytecode_output_root)',
|
||||
+ '<!@(echo "$STAGING_DIR"/usr/../usr/include)',
|
||||
],
|
||||
'sources': [
|
||||
'<!@pymod_do_main(GN-scraper "<(V8_ROOT)/BUILD.gn" "\\"v8_initializers.*?sources = ")',
|
||||
@@ -820,6 +826,7 @@
|
||||
'toolsets': ['host', 'target'],
|
||||
'direct_dependent_settings': {
|
||||
'sources': ['<!@pymod_do_main(GN-scraper "<(V8_ROOT)/BUILD.gn" "v8_compiler_sources = ")'],
|
||||
+ 'include_dirs': [ '<!@(echo "$STAGING_DIR"/usr/../usr/include)' ],
|
||||
'conditions': [
|
||||
['v8_target_arch=="ia32"', {
|
||||
'sources': [
|
||||
@@ -929,6 +936,8 @@
|
||||
'target_name': 'v8_turboshaft',
|
||||
'type': 'static_library',
|
||||
'toolsets': ['host', 'target'],
|
||||
+ 'libraries!':[ '-lcrypto', '-lssl', '-lz', '-lhttp_parser', '-luv', '-lnghttp2', '-lcares' ],
|
||||
+ 'include_dirs': [ '<!@(echo "$STAGING_DIR"/usr/../usr/include)' ],
|
||||
'dependencies': [
|
||||
'generate_bytecode_builtins_list',
|
||||
'run_torque',
|
||||
@@ -968,6 +977,7 @@
|
||||
'run_torque',
|
||||
'v8_maybe_icu',
|
||||
],
|
||||
+ 'include_dirs': [ '<!@(echo "$STAGING_DIR"/usr/../usr/include)' ],
|
||||
'conditions': [
|
||||
['(is_component_build and not v8_optimized_debug and v8_enable_fast_mksnapshot) or v8_enable_turbofan==0', {
|
||||
'dependencies': [
|
||||
@@ -1010,6 +1020,7 @@
|
||||
],
|
||||
'includes': ['inspector.gypi'],
|
||||
'direct_dependent_settings': {
|
||||
+ 'include_dirs!': [ '<!@(echo "$STAGING_DIR"/usr/include)' ],
|
||||
'include_dirs': [
|
||||
'<(generate_bytecode_output_root)',
|
||||
'<(SHARED_INTERMEDIATE_DIR)',
|
||||
@@ -1647,6 +1658,7 @@
|
||||
}],
|
||||
],
|
||||
'direct_dependent_settings': {
|
||||
+ 'include_dirs!': [ '<!@(echo "$STAGING_DIR"/usr/include)' ],
|
||||
'include_dirs': [
|
||||
'<(V8_ROOT)/include',
|
||||
],
|
||||
@@ -1667,6 +1679,7 @@
|
||||
{
|
||||
'target_name': 'bytecode_builtins_list_generator',
|
||||
'type': 'executable',
|
||||
+ 'libraries!':[ '-licui18n', '-licuuc', '-licudata', '-lcrypto', '-lssl', '-lz', '-lhttp_parser', '-luv', '-lnghttp2', '-lcares' ],
|
||||
'conditions': [
|
||||
['want_separate_host_toolset', {
|
||||
'toolsets': ['host'],
|
||||
@@ -1695,6 +1708,9 @@
|
||||
{
|
||||
'target_name': 'mksnapshot',
|
||||
'type': 'executable',
|
||||
+ 'libraries!':[ '-lcrypto', '-lssl', '-lz', '-lhttp_parser', '-luv', '-lnghttp2', '-lcares' ],
|
||||
+ 'library_dirs':[ '../../../../staging_dir/hostpkg/share/icu/current/lib' ],
|
||||
+ 'include_dirs': [ '<!@(echo "$STAGING_DIR"/usr/../usr/include)' ],
|
||||
'dependencies': [
|
||||
'v8_base_without_compiler',
|
||||
'v8_compiler_for_mksnapshot',
|
||||
@@ -1723,6 +1739,7 @@
|
||||
{
|
||||
'target_name': 'torque',
|
||||
'type': 'executable',
|
||||
+ 'libraries!':[ '-licui18n', '-licuuc', '-licudata', '-lcrypto', '-lssl', '-lz', '-lhttp_parser', '-luv', '-lnghttp2', '-lcares' ],
|
||||
'dependencies': [
|
||||
'torque_base',
|
||||
# "build/win:default_exe_manifest",
|
||||
@@ -1765,6 +1782,7 @@
|
||||
{
|
||||
'target_name': 'torque-language-server',
|
||||
'type': 'executable',
|
||||
+ 'libraries!':[ '-licui18n', '-licuuc', '-licudata', '-lcrypto', '-lssl', '-lz', '-lhttp_parser', '-luv', '-lnghttp2', '-lcares' ],
|
||||
'conditions': [
|
||||
['want_separate_host_toolset', {
|
||||
'toolsets': ['host'],
|
||||
@@ -1796,6 +1814,8 @@
|
||||
{
|
||||
'target_name': 'gen-regexp-special-case',
|
||||
'type': 'executable',
|
||||
+ 'libraries!':[ '-lcrypto', '-lssl', '-lz', '-lhttp_parser', '-luv', '-lnghttp2', '-lcares' ],
|
||||
+ 'library_dirs':[ '../../../../staging_dir/hostpkg/share/icu/current/lib' ],
|
||||
'dependencies': [
|
||||
'v8_libbase',
|
||||
# "build/win:default_exe_manifest",
|
||||
@@ -2036,6 +2056,7 @@
|
||||
}],
|
||||
],
|
||||
'direct_dependent_settings': {
|
||||
+ 'include_dirs!': [ '<!@(echo "$STAGING_DIR"/usr/include)' ],
|
||||
'include_dirs': [
|
||||
'<(V8_ROOT)/include',
|
||||
],
|
||||
@@ -2175,15 +2196,19 @@
|
||||
}],
|
||||
],
|
||||
'direct_dependent_settings': {
|
||||
+ 'include_dirs!': [ '<!@(echo "$STAGING_DIR"/usr/include)' ],
|
||||
'include_dirs': [
|
||||
'<(V8_ROOT)/third_party/zlib',
|
||||
'<(V8_ROOT)/third_party/zlib/google',
|
||||
+ '<!@(echo "$STAGING_DIR"/usr/../usr/include)',
|
||||
],
|
||||
},
|
||||
'defines': [ 'ZLIB_IMPLEMENTATION' ],
|
||||
+ 'include_dirs!': [ '<!@(echo "$STAGING_DIR"/usr/include)' ],
|
||||
'include_dirs': [
|
||||
'<(V8_ROOT)/third_party/zlib',
|
||||
'<(V8_ROOT)/third_party/zlib/google',
|
||||
+ '<!@(echo "$STAGING_DIR"/usr/../usr/include)',
|
||||
],
|
||||
'sources': [
|
||||
'<(V8_ROOT)/third_party/zlib/adler32.c',
|
@ -0,0 +1,10 @@
|
||||
--- a/deps/v8/src/base/small-vector.h
|
||||
+++ b/deps/v8/src/base/small-vector.h
|
||||
@@ -22,7 +22,6 @@ template <typename T, size_t kSize, type
|
||||
class SmallVector {
|
||||
// Currently only support trivially copyable and trivially destructible data
|
||||
// types, as it uses memcpy to copy elements and never calls destructors.
|
||||
- ASSERT_TRIVIALLY_COPYABLE(T);
|
||||
static_assert(std::is_trivially_destructible<T>::value);
|
||||
|
||||
public:
|
@ -0,0 +1,25 @@
|
||||
From 54299ac3a3d4e4520b8604dce43c2584092ccde2 Mon Sep 17 00:00:00 2001
|
||||
From: Michael Cho <michael@michaelcho.dev>
|
||||
Date: Sun, 27 Oct 2024 10:08:07 -0400
|
||||
Subject: [PATCH] build: fix building with system icu 76
|
||||
|
||||
ICU 76 decided to reduce overlinking[^1] thus `icu-i18n` will no longer
|
||||
add `icu-uc` when linking to shared libraries. This results in undefined
|
||||
symbols/references when trying to build with system ICU 76.
|
||||
|
||||
[^1]: unicode-org/icu@199bc82
|
||||
---
|
||||
configure.py | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
--- a/configure.py
|
||||
+++ b/configure.py
|
||||
@@ -1876,7 +1876,7 @@ def configure_intl(o):
|
||||
elif with_intl == 'system-icu':
|
||||
# ICU from pkg-config.
|
||||
o['variables']['v8_enable_i18n_support'] = 1
|
||||
- pkgicu = pkg_config('icu-i18n')
|
||||
+ pkgicu = pkg_config(['icu-i18n', 'icu-uc'])
|
||||
if not pkgicu[0]:
|
||||
error('''Could not load pkg-config data for "icu-i18n".
|
||||
See above errors or the README.md.''')
|
38
lang/node/patches/v22.x/999-fix_compile_error_for_ia32.patch
Normal file
38
lang/node/patches/v22.x/999-fix_compile_error_for_ia32.patch
Normal file
@ -0,0 +1,38 @@
|
||||
--- a/deps/v8/src/compiler/backend/ia32/instruction-selector-ia32.cc
|
||||
+++ b/deps/v8/src/compiler/backend/ia32/instruction-selector-ia32.cc
|
||||
@@ -1161,7 +1161,7 @@ template <typename Adapter>
|
||||
void VisitAtomicExchange(InstructionSelectorT<Adapter>* selector,
|
||||
typename Adapter::node_t node, ArchOpcode opcode,
|
||||
MachineRepresentation rep) {
|
||||
- using node_t = Adapter::node_t;
|
||||
+ using node_t = typename Adapter::node_t;
|
||||
IA32OperandGeneratorT<Adapter> g(selector);
|
||||
node_t base = selector->input_at(node, 0);
|
||||
node_t index = selector->input_at(node, 1);
|
||||
@@ -1732,7 +1732,7 @@ template <typename Adapter>
|
||||
void VisitWord32PairShift(InstructionSelectorT<Adapter>* selector,
|
||||
InstructionCode opcode,
|
||||
typename Adapter::node_t node) {
|
||||
- using node_t = Adapter::node_t;
|
||||
+ using node_t = typename Adapter::node_t;
|
||||
IA32OperandGeneratorT<Adapter> g(selector);
|
||||
|
||||
node_t shift = selector->input_at(node, 2);
|
||||
@@ -2507,7 +2507,7 @@ template <typename Adapter>
|
||||
void VisitAtomicBinOp(InstructionSelectorT<Adapter>* selector,
|
||||
typename Adapter::node_t node, ArchOpcode opcode,
|
||||
MachineRepresentation rep) {
|
||||
- using node_t = Adapter::node_t;
|
||||
+ using node_t = typename Adapter::node_t;
|
||||
AddressingMode addressing_mode;
|
||||
IA32OperandGeneratorT<Adapter> g(selector);
|
||||
node_t base = selector->input_at(node, 0);
|
||||
@@ -2528,7 +2528,7 @@ void VisitAtomicBinOp(InstructionSelecto
|
||||
template <typename Adapter>
|
||||
void VisitPairAtomicBinOp(InstructionSelectorT<Adapter>* selector,
|
||||
typename Adapter::node_t node, ArchOpcode opcode) {
|
||||
- using node_t = Adapter::node_t;
|
||||
+ using node_t = typename Adapter::node_t;
|
||||
IA32OperandGeneratorT<Adapter> g(selector);
|
||||
node_t base = selector->input_at(node, 0);
|
||||
node_t index = selector->input_at(node, 1);
|
29
lang/node/patches/v22.x/999-localhost-no-addrconfig.patch
Normal file
29
lang/node/patches/v22.x/999-localhost-no-addrconfig.patch
Normal file
@ -0,0 +1,29 @@
|
||||
Description: do not use dns.ADDRCONFIG for localhost
|
||||
it fails on IPv6-only systems. Setting it with libc fails on linux.
|
||||
https://github.com/nodejs/node/issues/33279
|
||||
Author: Jérémy Lal <kapouer@melix.org>
|
||||
Last-Update: 2020-06-11
|
||||
Bug-Debian: https://bugs.debian.org/962318
|
||||
Forwarded: https://github.com/nodejs/node/issues/33816
|
||||
--- a/lib/net.js
|
||||
+++ b/lib/net.js
|
||||
@@ -1,4 +1,5 @@
|
||||
// Copyright Joyent, Inc. and other Node contributors.
|
||||
+
|
||||
//
|
||||
// Permission is hereby granted, free of charge, to any person obtaining a
|
||||
// copy of this software and associated documentation files (the
|
||||
@@ -1342,13 +1343,6 @@ function lookupAndConnect(self, options)
|
||||
hints: options.hints || 0,
|
||||
};
|
||||
|
||||
- if (!isWindows &&
|
||||
- dnsopts.family !== 4 &&
|
||||
- dnsopts.family !== 6 &&
|
||||
- dnsopts.hints === 0) {
|
||||
- dnsopts.hints = dns.ADDRCONFIG;
|
||||
- }
|
||||
-
|
||||
debug('connect: find host', host);
|
||||
debug('connect: dns options', dnsopts);
|
||||
self._host = host;
|
@ -0,0 +1,10 @@
|
||||
--- a/node.gyp
|
||||
+++ b/node.gyp
|
||||
@@ -1351,6 +1351,7 @@
|
||||
'deps/simdutf/simdutf.gyp:simdutf#host',
|
||||
],
|
||||
'libraries!':[ '-licui18n', '-licuuc', '-licudata', '-lcrypto', '-lssl', '-lz', '-lhttp_parser', '-luv', '-lnghttp2', '-lcares' ],
|
||||
+ 'cflags!': ['-mbranch-protection=standard'],
|
||||
'include_dirs': [
|
||||
'tools',
|
||||
'src',
|
@ -1,16 +1,17 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=nghttp2
|
||||
PKG_VERSION:=1.51.0
|
||||
PKG_VERSION:=1.63.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=https://github.com/nghttp2/nghttp2/releases/download/v$(PKG_VERSION)
|
||||
PKG_HASH:=66aa76d97c143f42295405a31413e5e7d157968dad9f957bb4b015b598882e6b
|
||||
PKG_HASH:=4879c75dd32a74421b9857924449460b8341796c0613ba114ab2188e4622354b
|
||||
|
||||
PKG_MAINTAINER:=Hans Dedecker <dedeckeh@gmail.com>
|
||||
PKG_LICENSE:=MIT
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
PKG_CPE_ID:=cpe:/a:nghttp2:nghttp2
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
include $(INCLUDE_DIR)/cmake.mk
|
||||
|
Loading…
Reference in New Issue
Block a user