mirror of
https://github.com/coolsnowwolf/packages
synced 2025-01-07 07:07:02 +08:00
libpng: update to 1.6.38
Remove upstream backports. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
bdce7df0b0
commit
b647d31b66
@ -8,12 +8,12 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=libpng
|
||||
PKG_VERSION:=1.6.37
|
||||
PKG_RELEASE:=11
|
||||
PKG_VERSION:=1.6.38
|
||||
PKG_RELEASE:=$(AUTORELEASE)
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=@SF/libpng
|
||||
PKG_HASH:=505e70834d35383537b6491e7ae8641f1a4bed1876dbfe361201fc80868d88ca
|
||||
PKG_HASH:=b3683e8b8111ebf6f1ac004ebb6b0c975cd310ec469d98364388e9cedbfa68be
|
||||
|
||||
PKG_MAINTAINER:=Jo-Philipp Wich <jo@mein.io>
|
||||
PKG_LICENSE:=Libpng GPL-2.0-or-later BSD-3-Clause
|
||||
|
@ -1,38 +0,0 @@
|
||||
From 28c0f8895e4ac270b56b5c7e8089dd2417bc4e3c Mon Sep 17 00:00:00 2001
|
||||
From: Alex Gaynor <alex.gaynor@gmail.com>
|
||||
Date: Sun, 20 May 2018 18:46:32 -0400
|
||||
Subject: [PATCH] cmake: Add an option to enable/disable building of
|
||||
executables
|
||||
|
||||
Add the CMake option PNG_EXECUTABLES (on by default) in order to
|
||||
allow or disallow the building of non-essential executable programs
|
||||
associated with libpng.
|
||||
|
||||
Contributed-by: Alex Gaynor <alex.gaynor@gmail.com>
|
||||
Contributed-by: Cosmin Truta <ctruta@gmail.com>
|
||||
Signed-off-by: Cosmin Truta <ctruta@gmail.com>
|
||||
---
|
||||
CMakeLists.txt | 6 ++++--
|
||||
1 file changed, 4 insertions(+), 2 deletions(-)
|
||||
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -53,7 +53,8 @@ endif()
|
||||
# COMMAND LINE OPTIONS
|
||||
option(PNG_SHARED "Build shared lib" ON)
|
||||
option(PNG_STATIC "Build static lib" ON)
|
||||
-option(PNG_TESTS "Build libpng tests" ON)
|
||||
+option(PNG_EXECUTABLES "Build libpng executables" ON)
|
||||
+option(PNG_TESTS "Build libpng tests" ON)
|
||||
|
||||
# Many more configuration options could be added here
|
||||
option(PNG_FRAMEWORK "Build OS X framework" OFF)
|
||||
@@ -747,7 +748,7 @@ if(PNG_TESTS AND PNG_SHARED)
|
||||
png_add_test(NAME pngimage-full COMMAND pngimage OPTIONS --exhaustive --list-combos --log FILES ${PNGSUITE_PNGS})
|
||||
endif()
|
||||
|
||||
-if(PNG_SHARED)
|
||||
+if(PNG_SHARED AND PNG_EXECUTABLES)
|
||||
add_executable(pngfix ${pngfix_sources})
|
||||
target_link_libraries(pngfix png)
|
||||
set(PNG_BIN_TARGETS pngfix)
|
@ -1,67 +0,0 @@
|
||||
From 9f734b13f4ea062af98652c4c7678f667d2d85c7 Mon Sep 17 00:00:00 2001
|
||||
From: David Callu <callu.david@gmail.com>
|
||||
Date: Thu, 4 Jul 2019 15:15:53 +0200
|
||||
Subject: [PATCH] cmake: Use the correct ZLIB_* variable names
|
||||
|
||||
ZLIB_LIBRARIES and ZLIB_INCLUDE_DIRS are the official cmake variable
|
||||
names.
|
||||
---
|
||||
CMakeLists.txt | 15 ++++++++-------
|
||||
1 file changed, 8 insertions(+), 7 deletions(-)
|
||||
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -40,7 +40,7 @@ option(PNG_BUILD_ZLIB "Custom zlib Locat
|
||||
|
||||
if(NOT PNG_BUILD_ZLIB)
|
||||
find_package(ZLIB REQUIRED)
|
||||
- include_directories(${ZLIB_INCLUDE_DIR})
|
||||
+ include_directories(${ZLIB_INCLUDE_DIRS})
|
||||
endif()
|
||||
|
||||
if(UNIX AND NOT APPLE AND NOT BEOS AND NOT HAIKU)
|
||||
@@ -523,7 +523,7 @@ if(PNG_DEBUG)
|
||||
endif()
|
||||
|
||||
# NOW BUILD OUR TARGET
|
||||
-include_directories(${CMAKE_CURRENT_SOURCE_DIR} ${ZLIB_INCLUDE_DIR})
|
||||
+include_directories(${CMAKE_CURRENT_SOURCE_DIR} ${ZLIB_INCLUDE_DIRS})
|
||||
|
||||
unset(PNG_LIB_TARGETS)
|
||||
|
||||
@@ -537,7 +537,7 @@ if(PNG_SHARED)
|
||||
set_target_properties(png PROPERTIES PREFIX "lib")
|
||||
set_target_properties(png PROPERTIES IMPORT_PREFIX "lib")
|
||||
endif()
|
||||
- target_link_libraries(png ${ZLIB_LIBRARY} ${M_LIBRARY})
|
||||
+ target_link_libraries(png ${ZLIB_LIBRARIES} ${M_LIBRARY})
|
||||
|
||||
if(UNIX AND AWK)
|
||||
if(HAVE_LD_VERSION_SCRIPT)
|
||||
@@ -572,7 +572,7 @@ if(PNG_STATIC)
|
||||
# msvc does not append 'lib' - do it here to have consistent name
|
||||
set_target_properties(png_static PROPERTIES PREFIX "lib")
|
||||
endif()
|
||||
- target_link_libraries(png_static ${ZLIB_LIBRARY} ${M_LIBRARY})
|
||||
+ target_link_libraries(png_static ${ZLIB_LIBRARIES} ${M_LIBRARY})
|
||||
endif()
|
||||
|
||||
if(PNG_FRAMEWORK)
|
||||
@@ -589,7 +589,7 @@ if(PNG_FRAMEWORK)
|
||||
XCODE_ATTRIBUTE_INSTALL_PATH "@rpath"
|
||||
PUBLIC_HEADER "${libpng_public_hdrs}"
|
||||
OUTPUT_NAME png)
|
||||
- target_link_libraries(png_framework ${ZLIB_LIBRARY} ${M_LIBRARY})
|
||||
+ target_link_libraries(png_framework ${ZLIB_LIBRARIES} ${M_LIBRARY})
|
||||
endif()
|
||||
|
||||
if(NOT PNG_LIB_TARGETS)
|
||||
@@ -754,7 +754,7 @@ if(PNG_SHARED AND PNG_EXECUTABLES)
|
||||
set(PNG_BIN_TARGETS pngfix)
|
||||
|
||||
add_executable(png-fix-itxt ${png_fix_itxt_sources})
|
||||
- target_link_libraries(png-fix-itxt ${ZLIB_LIBRARY} ${M_LIBRARY})
|
||||
+ target_link_libraries(png-fix-itxt ${ZLIB_LIBRARIES} ${M_LIBRARY})
|
||||
list(APPEND PNG_BIN_TARGETS png-fix-itxt)
|
||||
endif()
|
||||
|
@ -1,22 +0,0 @@
|
||||
From dbe3e0c43e549a1602286144d94b0666549b18e6 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Cristian=20Rodr=C3=ADguez?= <crrodriguez@opensuse.org>
|
||||
Date: Mon, 19 Mar 2018 12:41:47 -0300
|
||||
Subject: [PATCH] libpng.pc.in: zlib dependency is private
|
||||
|
||||
zlib should be injected only when pkgconfig is ran with the --static
|
||||
option.
|
||||
---
|
||||
libpng.pc.in | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
--- a/libpng.pc.in
|
||||
+++ b/libpng.pc.in
|
||||
@@ -6,7 +6,7 @@ includedir=@includedir@/libpng@PNGLIB_MA
|
||||
Name: libpng
|
||||
Description: Loads and saves PNG files
|
||||
Version: @PNGLIB_VERSION@
|
||||
-Requires: zlib
|
||||
+Requires.private: zlib
|
||||
Libs: -L${libdir} -lpng@PNGLIB_MAJOR@@PNGLIB_MINOR@
|
||||
Libs.private: @LIBS@
|
||||
Cflags: -I${includedir}
|
Loading…
Reference in New Issue
Block a user