mirror of
https://github.com/coolsnowwolf/packages
synced 2025-01-07 07:07:02 +08:00
squeezelite: bump to 1.9.9-1415
Signed-off-by: Robert Högberg <robert.hogberg@gmail.com>
This commit is contained in:
parent
0ac3d5ccae
commit
c0e6c7e980
@ -6,13 +6,13 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=squeezelite
|
||||
PKG_VERSION:=1.9.9-1403
|
||||
PKG_RELEASE:=$(AUTORELEASE)
|
||||
PKG_VERSION:=1.9.9-1415
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE_PROTO:=git
|
||||
PKG_SOURCE_URL:=https://github.com/ralph-irving/squeezelite
|
||||
PKG_SOURCE_VERSION:=bc72c0de3fff771540a2a45aaafafed539387b3c
|
||||
PKG_MIRROR_HASH:=25f6c320e52b53c0340a337429b91d59783c87f1af3454dc0434c24b90ed3b94
|
||||
PKG_SOURCE_VERSION:=5361789c8df37d87a22cc2253ff746557044931a
|
||||
PKG_MIRROR_HASH:=c6cabb4041c1197881d9f5e9ea8293ece2d409356ccf56d4a8948743b49b13ca
|
||||
|
||||
PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
|
||||
PKG_LICENSE:=GPL-3.0-or-later
|
||||
@ -116,6 +116,8 @@ define Package/squeezelite-mini/description
|
||||
This package will dynamically load installed codecs.
|
||||
endef
|
||||
|
||||
opts+= -DNO_MAD
|
||||
|
||||
ifeq ($(CONFIG_SQUEEZELITE_WMA),y)
|
||||
opts+= -DFFMPEG
|
||||
endif
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- a/main.c
|
||||
+++ b/main.c
|
||||
@@ -93,6 +93,7 @@ static void usage(const char *argv0) {
|
||||
@@ -99,6 +99,7 @@ static void usage(const char *argv0) {
|
||||
#if IR
|
||||
" -i [<filename>]\tEnable lirc remote control support (lirc config file ~/.lircrc used if filename not specified)\n"
|
||||
#endif
|
||||
@ -8,7 +8,7 @@
|
||||
" -m <mac addr>\t\tSet mac address, format: ab:cd:ef:12:34:56\n"
|
||||
" -M <modelname>\tSet the squeezelite player model name sent to the server (default: " MODEL_NAME_STRING ")\n"
|
||||
" -n <name>\t\tSet the player name\n"
|
||||
@@ -292,6 +293,8 @@ int main(int argc, char **argv) {
|
||||
@@ -304,6 +305,8 @@ int main(int argc, char **argv) {
|
||||
extern bool user_rates;
|
||||
char *logfile = NULL;
|
||||
u8_t mac[6];
|
||||
@ -17,7 +17,7 @@
|
||||
unsigned stream_buf_size = STREAMBUF_SIZE;
|
||||
unsigned output_buf_size = 0; // set later
|
||||
unsigned rates[MAX_SUPPORTED_SAMPLERATES] = { 0 };
|
||||
@@ -332,6 +335,7 @@ int main(int argc, char **argv) {
|
||||
@@ -344,6 +347,7 @@ int main(int argc, char **argv) {
|
||||
|
||||
int maxSampleRate = 0;
|
||||
|
||||
@ -25,7 +25,7 @@
|
||||
char *optarg = NULL;
|
||||
int optind = 1;
|
||||
int i;
|
||||
@@ -339,8 +343,6 @@ int main(int argc, char **argv) {
|
||||
@@ -351,8 +355,6 @@ int main(int argc, char **argv) {
|
||||
#define MAXCMDLINE 512
|
||||
char cmdline[MAXCMDLINE] = "";
|
||||
|
||||
@ -34,7 +34,7 @@
|
||||
for (i = 0; i < argc && (strlen(argv[i]) + strlen(cmdline) + 2 < MAXCMDLINE); i++) {
|
||||
strcat(cmdline, argv[i]);
|
||||
strcat(cmdline, " ");
|
||||
@@ -348,7 +350,7 @@ int main(int argc, char **argv) {
|
||||
@@ -360,7 +362,7 @@ int main(int argc, char **argv) {
|
||||
|
||||
while (optind < argc && strlen(argv[optind]) >= 2 && argv[optind][0] == '-') {
|
||||
char *opt = argv[optind] + 1;
|
||||
@ -43,7 +43,7 @@
|
||||
#if ALSA
|
||||
"UVO"
|
||||
#endif
|
||||
@@ -442,6 +444,9 @@ int main(int argc, char **argv) {
|
||||
@@ -454,6 +456,9 @@ int main(int argc, char **argv) {
|
||||
case 'f':
|
||||
logfile = optarg;
|
||||
break;
|
||||
@ -53,7 +53,7 @@
|
||||
case 'm':
|
||||
{
|
||||
int byte = 0;
|
||||
@@ -755,6 +760,11 @@ int main(int argc, char **argv) {
|
||||
@@ -767,6 +772,11 @@ int main(int argc, char **argv) {
|
||||
winsock_init();
|
||||
#endif
|
||||
|
||||
@ -65,7 +65,7 @@
|
||||
stream_init(log_stream, stream_buf_size);
|
||||
|
||||
if (!strcmp(output_device, "-")) {
|
||||
@@ -801,7 +811,7 @@ int main(int argc, char **argv) {
|
||||
@@ -813,7 +823,7 @@ int main(int argc, char **argv) {
|
||||
exit(1);
|
||||
}
|
||||
|
||||
@ -132,7 +132,7 @@
|
||||
} else {
|
||||
--- a/squeezelite.h
|
||||
+++ b/squeezelite.h
|
||||
@@ -456,7 +456,7 @@ char* strcasestr(const char *haystack, c
|
||||
@@ -458,7 +458,7 @@ char* strcasestr(const char *haystack, c
|
||||
|
||||
char *next_param(char *src, char c);
|
||||
u32_t gettime_ms(void);
|
||||
@ -141,7 +141,7 @@
|
||||
void set_nonblock(sockfd s);
|
||||
int connect_timeout(sockfd sock, const struct sockaddr *addr, socklen_t addrlen, int timeout);
|
||||
void server_addr(char *server, in_addr_t *ip_ptr, unsigned *port_ptr);
|
||||
@@ -513,7 +513,7 @@ void buf_init(struct buffer *buf, size_t
|
||||
@@ -515,7 +515,7 @@ void buf_init(struct buffer *buf, size_t
|
||||
void buf_destroy(struct buffer *buf);
|
||||
|
||||
// slimproto.c
|
||||
|
@ -1,80 +0,0 @@
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -24,7 +24,7 @@ OPT_PULSEAUDIO = -DPULSEAUDIO
|
||||
SOURCES = \
|
||||
main.c slimproto.c buffer.c stream.c utils.c \
|
||||
output.c output_alsa.c output_pa.c output_stdout.c output_pack.c output_pulse.c decode.c \
|
||||
- flac.c pcm.c mad.c vorbis.c mpg.c
|
||||
+ flac.c pcm.c vorbis.c mpg.c
|
||||
|
||||
SOURCES_DSD = dsd.c dop.c dsd2pcm/dsd2pcm.c
|
||||
SOURCES_FF = ffmpeg.c
|
||||
@@ -45,7 +45,7 @@ LINK_PULSEAUDIO = -lpulse
|
||||
LINK_SSL = -lssl -lcrypto
|
||||
LINK_ALAC = -lalac
|
||||
|
||||
-LINKALL = -lmad -lmpg123 -lFLAC -lvorbisfile -lvorbis -logg
|
||||
+LINKALL = -lmpg123 -lFLAC -lvorbisfile -lvorbis -logg
|
||||
LINKALL_FF = -lavformat -lavcodec -lavutil
|
||||
LINKALL_RESAMPLE = -lsoxr
|
||||
LINKALL_IR = -llirc_client
|
||||
--- a/decode.c
|
||||
+++ b/decode.c
|
||||
@@ -183,11 +183,7 @@ void decode_init(log_level level, const
|
||||
if (!strstr(exclude_codecs, "pcm") && (!include_codecs || (order_codecs = strstr(include_codecs, "pcm"))))
|
||||
sort_codecs((include_codecs ? order_codecs - include_codecs : i), register_pcm());
|
||||
|
||||
- // try mad then mpg for mp3 unless command line option passed
|
||||
- if (!(strstr(exclude_codecs, "mp3") || strstr(exclude_codecs, "mad")) &&
|
||||
- (!include_codecs || (order_codecs = strstr(include_codecs, "mp3")) || (order_codecs = strstr(include_codecs, "mad"))))
|
||||
- sort_codecs((include_codecs ? order_codecs - include_codecs : i), register_mad());
|
||||
- else if (!(strstr(exclude_codecs, "mp3") || strstr(exclude_codecs, "mpg")) &&
|
||||
+ if (!(strstr(exclude_codecs, "mp3") || strstr(exclude_codecs, "mpg")) &&
|
||||
(!include_codecs || (order_codecs = strstr(include_codecs, "mp3")) || (order_codecs = strstr(include_codecs, "mpg"))))
|
||||
sort_codecs((include_codecs ? order_codecs - include_codecs : i), register_mpg());
|
||||
|
||||
--- a/main.c
|
||||
+++ b/main.c
|
||||
@@ -51,7 +51,7 @@
|
||||
#else
|
||||
#define CODECS_DSD ""
|
||||
#endif
|
||||
-#define CODECS_MP3 " (mad,mpg for specific mp3 codec)"
|
||||
+#define CODECS_MP3 ""
|
||||
|
||||
#define CODECS CODECS_BASE CODECS_AAC CODECS_FF CODECS_OPUS CODECS_DSD CODECS_MP3
|
||||
|
||||
--- a/squeezelite.h
|
||||
+++ b/squeezelite.h
|
||||
@@ -191,7 +191,6 @@
|
||||
|
||||
#if LINUX
|
||||
#define LIBFLAC "libFLAC.so.8"
|
||||
-#define LIBMAD "libmad.so.0"
|
||||
#define LIBMPG "libmpg123.so.0"
|
||||
#define LIBVORBIS "libvorbisfile.so.3"
|
||||
#define LIBOPUS "libopusfile.so.0"
|
||||
@@ -206,7 +205,6 @@
|
||||
|
||||
#if OSX
|
||||
#define LIBFLAC "libFLAC.8.dylib"
|
||||
-#define LIBMAD "libmad.0.dylib"
|
||||
#define LIBMPG "libmpg123.0.dylib"
|
||||
#define LIBVORBIS "libvorbisfile.3.dylib"
|
||||
#define LIBTREMOR "libvorbisidec.1.dylib"
|
||||
@@ -220,7 +218,6 @@
|
||||
|
||||
#if WIN
|
||||
#define LIBFLAC "libFLAC.dll"
|
||||
-#define LIBMAD "libmad-0.dll"
|
||||
#define LIBMPG "libmpg123-0.dll"
|
||||
#define LIBVORBIS "libvorbisfile.dll"
|
||||
#define LIBOPUS "libopusfile-0.dll"
|
||||
@@ -234,7 +231,6 @@
|
||||
|
||||
#if FREEBSD
|
||||
#define LIBFLAC "libFLAC.so.8"
|
||||
-#define LIBMAD "libmad.so.0"
|
||||
#define LIBMPG "libmpg123.so.0"
|
||||
#define LIBVORBIS "libvorbisfile.so.3"
|
||||
#define LIBTREMOR "libvorbisidec.so.1"
|
Loading…
Reference in New Issue
Block a user