mirror of
https://github.com/coolsnowwolf/packages
synced 2025-01-08 13:27:39 +08:00
nano: update to 7.0
Update nano to version 7.0. Add a patch to fix the plus variant. Upstream discussion and patch in https://savannah.gnu.org/bugs/?63372 Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
This commit is contained in:
parent
87e6fd0b94
commit
c5c9267148
@ -8,12 +8,12 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=nano
|
||||
PKG_VERSION:=6.4
|
||||
PKG_VERSION:=7.0
|
||||
PKG_RELEASE:=$(AUTORELEASE)
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=@GNU/nano
|
||||
PKG_HASH:=4199ae8ca78a7796de56de1a41b821dc47912c0307e9816b56cc317df34661c0
|
||||
PKG_HASH:=8dd6eac38b2b8786d82681f0e1afd84f6b75210d17391b6443c437e451552149
|
||||
|
||||
PKG_LICENSE:=GPL-3.0-or-later
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
|
18
utils/nano/patches/100-post-7.0-fix-commenting.patch
Normal file
18
utils/nano/patches/100-post-7.0-fix-commenting.patch
Normal file
@ -0,0 +1,18 @@
|
||||
--- a/src/nano.c
|
||||
+++ b/src/nano.c
|
||||
@@ -1395,11 +1395,14 @@ bool changes_something(const void *f)
|
||||
#ifndef NANO_TINY
|
||||
f == chop_previous_word || f == chop_next_word ||
|
||||
f == zap_text || f == cut_till_eof || f == do_execute ||
|
||||
- f == do_indent || f == do_unindent || f == do_comment ||
|
||||
+ f == do_indent || f == do_unindent ||
|
||||
#endif
|
||||
#ifdef ENABLE_JUSTIFY
|
||||
f == do_justify || f == do_full_justify ||
|
||||
#endif
|
||||
+#ifdef ENABLE_COMMENT
|
||||
+ f == do_comment ||
|
||||
+#endif
|
||||
#ifdef ENABLE_SPELLER
|
||||
f == do_spell ||
|
||||
#endif
|
Loading…
Reference in New Issue
Block a user