xtables-addons: fix kernel 6.12 support

This commit is contained in:
coolsnowwolf 2024-11-22 16:13:51 +08:00
parent af8cff26f3
commit d822390763
3 changed files with 25 additions and 3 deletions

View File

@ -7,9 +7,9 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=xtables-addons
PKG_VERSION:=3.24
PKG_RELEASE:=2
PKG_HASH:=3e823f71720519ced31c4c7d2bfaf7120d9c01c59a0843dfcbe93c95c64d81c1
PKG_VERSION:=3.27
PKG_RELEASE:=1
PKG_HASH:=e47ea8febe73c12ecab09d2c93578c5dc72d76f17fdf673397758f519cce6828
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://inai.de/files/xtables-addons/

View File

@ -0,0 +1,11 @@
--- a/extensions/rtsp/nf_conntrack_rtsp.c
+++ b/extensions/rtsp/nf_conntrack_rtsp.c
@@ -735,7 +735,7 @@
}
#if LINUX_VERSION_CODE >= KERNEL_VERSION(3,6,0)
- strlcpy(hlpr->name, tmpname, sizeof(hlpr->name));
+ strscpy(hlpr->name, tmpname, sizeof(hlpr->name));
#else
hlpr->name = tmpname;
#endif

View File

@ -0,0 +1,11 @@
--- a/extensions/ACCOUNT/Makefile.am
+++ b/extensions/ACCOUNT/Makefile.am
@@ -3,7 +3,7 @@
AM_CPPFLAGS = ${regular_CPPFLAGS} -I${abs_top_srcdir}/extensions
AM_CFLAGS = ${regular_CFLAGS} ${libxtables_CFLAGS}
-include ${top_srcdir}/Makefile.extra
+include ../../Makefile.extra
sbin_PROGRAMS = iptaccount
iptaccount_LDADD = libxt_ACCOUNT_cl.la