mirror of
https://github.com/kiddin9/openwrt-packages.git
synced 2025-01-09 06:07:44 +08:00
🎨 Sync 2024-02-26 20:25:51
This commit is contained in:
parent
c06deee8c7
commit
3e16644eb7
@ -1,10 +1,10 @@
|
||||
# Copyright (C) 2020-2023 Hyy2001X <https://github.com/Hyy2001X>
|
||||
# Copyright (C) 2020-2024 Hyy2001X <https://github.com/Hyy2001X>
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=autoupdate
|
||||
PKG_VERSION:=1
|
||||
PKG_RELEASE:=2
|
||||
PKG_RELEASE:=3
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
@ -16,7 +16,7 @@ define Package/$(PKG_NAME)
|
||||
endef
|
||||
|
||||
define Package/$(PKG_NAME)/description
|
||||
autoupdate - Upgrade OpenWrt by one-key
|
||||
autoupdate - One-key AutoUpdate
|
||||
endef
|
||||
|
||||
define Build/Compile
|
||||
|
@ -3,7 +3,7 @@
|
||||
# AutoUpdate for Openwrt
|
||||
# Dependences: wget-ssl/wget/uclient-fetch curl jq expr sysupgrade
|
||||
|
||||
Version=V6.9.7
|
||||
Version=V6.9.8
|
||||
|
||||
function TITLE() {
|
||||
clear && echo "Openwrt-AutoUpdate Script by Hyy2001 ${Version}"
|
||||
@ -22,6 +22,9 @@ function SHELL_HELP() {
|
||||
-f 跳过版本号校验,并强制刷写固件 ${Red}(危险)${White} *
|
||||
-F, --force-flash 强制刷写固件 ${Red}(危险)${White} *
|
||||
-P, --proxy 优先开启镜像加速下载固件 *
|
||||
${Next} A 自动选择
|
||||
${Next} F Cloudflare Workers
|
||||
${Next} G Ghproxy
|
||||
-D <Downloader> 使用指定的下载器 <wget-ssl | wget | curl | uclient-fetch> *
|
||||
--decompress 解压 img.gz 固件后再更新固件 *
|
||||
--skip-verify 跳过固件 SHA256 校验 ${Red}(危险)${White} *
|
||||
@ -653,15 +656,22 @@ function UPGRADE() {
|
||||
;;
|
||||
-P | --proxy)
|
||||
case $2 in
|
||||
A | F | G)
|
||||
Proxy_Type=$2
|
||||
A)
|
||||
Proxy_Type="All"
|
||||
Special_Commands="${Special_Commands} [镜像加速 Automatic]"
|
||||
shift
|
||||
;;
|
||||
*)
|
||||
Proxy_Type="All"
|
||||
F)
|
||||
Proxy_Type=$2
|
||||
Special_Commands="${Special_Commands} [CF Workers]"
|
||||
shift
|
||||
;;
|
||||
G)
|
||||
Proxy_Type=$2
|
||||
Special_Commands="${Special_Commands} [Ghproxy]"
|
||||
shift
|
||||
;;
|
||||
esac
|
||||
Special_Commands="${Special_Commands} [镜像加速 ${Proxy_Type}]"
|
||||
;;
|
||||
-D)
|
||||
DL_DEPENDS=($2)
|
||||
@ -785,14 +795,14 @@ $(echo -e "云端固件版本: ${CLOUD_FW_Version}${CHECKED_Type}")
|
||||
esac
|
||||
local URL
|
||||
case "${Proxy_Type}" in
|
||||
A | F | G)
|
||||
F | G)
|
||||
URL="$(Proxy_X ${CLOUD_FW_Url} ${Proxy_Type}@@5)"
|
||||
;;
|
||||
All)
|
||||
URL="$(Proxy_X ${CLOUD_FW_Url} G@@2 F@@1 A@@1 X@@1)"
|
||||
URL="$(Proxy_X ${CLOUD_FW_Url} G@@2 F@@2 X@@1)"
|
||||
;;
|
||||
*)
|
||||
URL="$(Proxy_X ${CLOUD_FW_Url} X@@3 G@@1 F@@1 A@@1)"
|
||||
URL="$(Proxy_X ${CLOUD_FW_Url} X@@3 G@@1 F@@1)"
|
||||
;;
|
||||
esac
|
||||
DOWNLOADER --file-name ${CLOUD_FW_Name} --no-url-name --dl ${DL_DEPENDS[@]} --url ${URL} --path ${Firmware_Path} --timeout 15 --type 固件
|
||||
@ -1102,17 +1112,14 @@ function Proxy_X() {
|
||||
|
||||
case "${Type}" in
|
||||
raw)
|
||||
A=https://raw.fgit.cf/$(echo ${URL##*com/})
|
||||
F=https://git.hyy2001.workers.dev/$(echo ${URL##*com/})
|
||||
G=https://mirror.ghproxy.com/${URL}
|
||||
;;
|
||||
release)
|
||||
A=https://hub.fgit.cf/$(echo ${URL##*com/})
|
||||
F=https://git.hyy2001.workers.dev/$(echo ${URL##*com/})
|
||||
G=https://mirror.ghproxy.com/${URL}
|
||||
;;
|
||||
codeload)
|
||||
A=https://hub.fgit.cf/$(echo ${URL##*com/})
|
||||
F=https://git.hyy2001.workers.dev/$(echo ${URL##*com/})
|
||||
G=https://mirror.ghproxy.com/${URL}
|
||||
;;
|
||||
@ -1120,9 +1127,6 @@ function Proxy_X() {
|
||||
while [[ $1 ]];do
|
||||
local URL_Cache=$1 URL_Final
|
||||
case $1 in
|
||||
A@@*)
|
||||
URL_Final="${URL_Cache/A/${A}}"
|
||||
;;
|
||||
F@@*)
|
||||
URL_Final="${URL_Cache/F/${F}}"
|
||||
;;
|
||||
|
@ -6,7 +6,7 @@ include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=dae
|
||||
PKG_VERSION:=0.5.1
|
||||
PKG_RELEASE:=43
|
||||
PKG_RELEASE:=44
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).zip
|
||||
PKG_SOURCE_URL:=https://github.com/daeuniverse/dae/releases/download/v$(PKG_VERSION)/dae-full-src.zip?
|
||||
|
@ -2,4 +2,6 @@
|
||||
config dae 'config'
|
||||
option enabled '0'
|
||||
option config_file '/etc/dae/config.dae'
|
||||
option log_maxbackups '1'
|
||||
option log_maxsize '1'
|
||||
|
||||
|
@ -6,6 +6,7 @@ START=99
|
||||
|
||||
CONF="dae"
|
||||
PROG="/usr/bin/dae"
|
||||
LOG_DIR="/var/log/dae"
|
||||
|
||||
start_service() {
|
||||
config_load "$CONF"
|
||||
@ -19,9 +20,17 @@ start_service() {
|
||||
|
||||
"$PROG" validate -c "$config_file" || return 1
|
||||
|
||||
local log_maxbackups log_maxsize
|
||||
config_get log_maxbackups "config" "log_maxbackups" "1"
|
||||
config_get log_maxsize "config" "log_maxsize" "1"
|
||||
|
||||
procd_open_instance "$CONF"
|
||||
procd_set_param command "$PROG"
|
||||
procd_append_param command run -c "$config_file"
|
||||
procd_set_param command "$PROG" run
|
||||
procd_append_param command --config "$config_file"
|
||||
procd_append_param command --disable-timestamp
|
||||
procd_append_param command --logfile "$LOG_DIR/dae.log"
|
||||
procd_append_param command --logfile-maxbackups "$log_maxbackups"
|
||||
procd_append_param command --logfile-maxsize "$log_maxsize"
|
||||
|
||||
procd_set_param limits core="unlimited"
|
||||
procd_set_param limits nofile="1000000 1000000"
|
||||
@ -32,6 +41,10 @@ start_service() {
|
||||
procd_close_instance
|
||||
}
|
||||
|
||||
stop_service() {
|
||||
rm -rf "$LOG_DIR"
|
||||
}
|
||||
|
||||
service_triggers() {
|
||||
procd_add_reload_trigger "$CONF"
|
||||
}
|
||||
|
@ -1,8 +1,8 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=dockerd
|
||||
PKG_VERSION:=24.0.5
|
||||
PKG_RELEASE:=17
|
||||
PKG_VERSION:=25.0.3
|
||||
PKG_RELEASE:=18
|
||||
PKG_LICENSE:=Apache-2.0
|
||||
PKG_LICENSE_FILES:=LICENSE
|
||||
|
||||
@ -11,7 +11,7 @@ PKG_GIT_URL:=github.com/moby/moby
|
||||
PKG_GIT_REF:=v$(PKG_VERSION)
|
||||
PKG_SOURCE_URL:=https://codeload.$(PKG_GIT_URL)/tar.gz/$(PKG_GIT_REF)?
|
||||
PKG_HASH:=skip
|
||||
PKG_GIT_SHORT_COMMIT:=a61e2b4 # SHA1 used within the docker executables
|
||||
PKG_GIT_SHORT_COMMIT:=f417435 # SHA1 used within the docker executables
|
||||
|
||||
PKG_MAINTAINER:=Gerard Ryan <G.M0N3Y.2503@gmail.com>
|
||||
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- a/hack/make.sh
|
||||
+++ b/hack/make.sh
|
||||
@@ -98,7 +98,7 @@ fi
|
||||
# functionality. We favour libdm_dlsym_deferred_remove over
|
||||
# libdm_no_deferred_remove in dynamic cases because the binary could be shipped
|
||||
# with a newer libdevmapper than the one it was built with.
|
||||
-if command -v gcc &> /dev/null && ! (echo -e '#include <libdevmapper.h>\nint main() { dm_task_deferred_remove(NULL); }' | gcc -xc - -o /dev/null $(${PKG_CONFIG} --libs devmapper 2> /dev/null) &> /dev/null); then
|
||||
+if command -v gcc &> /dev/null && ! (echo -e '#include <libdevmapper.h>\nint main() { dm_task_deferred_remove(NULL); }' | gcc -xc - -o /dev/null $(${PKG_CONFIG} --libs libdevmapper 2> /dev/null) &> /dev/null); then
|
||||
add_buildtag libdm dlsym_deferred_remove
|
||||
fi
|
||||
|
@ -10,8 +10,8 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=haproxy
|
||||
PKG_VERSION:=2.8.5
|
||||
PKG_RELEASE:=31
|
||||
PKG_VERSION:=2.8.6
|
||||
PKG_RELEASE:=32
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://www.haproxy.org/download/2.8/src
|
||||
|
@ -1,7 +1,7 @@
|
||||
#!/bin/sh
|
||||
|
||||
CLONEURL=https://git.haproxy.org/git/haproxy-2.8.git
|
||||
BASE_TAG=v2.8.5
|
||||
BASE_TAG=v2.8.6
|
||||
TMP_REPODIR=tmprepo
|
||||
PATCHESDIR=patches
|
||||
|
||||
|
@ -16,7 +16,7 @@ enable = s:option(Flag, "enable", translate("Enable"), translate("Automatically
|
||||
enable.default = 0
|
||||
enable.optional = false
|
||||
|
||||
proxy = s:option(Flag, "proxy", translate("Preference Mirror Speedup"), translate("Preference Mirror for speeding up downloads while upgrading (For Mainland)"))
|
||||
proxy = s:option(Flag, "proxy", translate("Preference Mirror Speedup"), translate("Preference Mirror for speeding up download"))
|
||||
proxy.default = 1
|
||||
proxy:depends("enable", "1")
|
||||
proxy.optional = false
|
||||
@ -24,8 +24,8 @@ proxy.optional = false
|
||||
proxy_type = s:option(ListValue, "proxy_type", translate("Mirror Station"))
|
||||
proxy_type.default = "A"
|
||||
proxy_type:value("A", translate("Automatic selection (Recommend)"))
|
||||
proxy_type:value("G", translate("GitHub Proxy - Ghproxy (Maybe faster)"))
|
||||
proxy_type:value("F", translate("FastGit UK"))
|
||||
proxy_type:value("G", translate("GitHub Proxy"))
|
||||
proxy_type:value("F", translate("CF Workers"))
|
||||
proxy_type:depends("proxy", "1")
|
||||
proxy_type.optional = false
|
||||
|
||||
|
@ -25,14 +25,14 @@ msgstr "镜像站"
|
||||
msgid "Automatic selection (Recommend)"
|
||||
msgstr "自动选择 (推荐)"
|
||||
|
||||
msgid "GitHub Proxy - Ghproxy (Maybe faster)"
|
||||
msgstr "GitHub Proxy - Ghproxy (也许更快)"
|
||||
msgid "GitHub Proxy"
|
||||
msgstr "GitHub Proxy - Ghproxy"
|
||||
|
||||
msgid "FastGit UK"
|
||||
msgstr "FastGit UK"
|
||||
msgid "CF Workers"
|
||||
msgstr "Cloudflare Workers"
|
||||
|
||||
msgid "Preference Mirror for speeding up downloads while upgrading (For Mainland)"
|
||||
msgstr "定时更新固件时优先启用镜像加速 (适用与被墙地区)"
|
||||
msgid "Preference Mirror for speeding up download"
|
||||
msgstr "优先使用镜像站加速下载"
|
||||
|
||||
msgid "Advanced Settings"
|
||||
msgstr "高级设置"
|
||||
@ -53,7 +53,7 @@ msgid "Upgrade without keeping config"
|
||||
msgstr "不保留配置"
|
||||
|
||||
msgid "Please don't select it unless you know what you're doing!"
|
||||
msgstr "请勿随意勾选除非你知道自己在做什么!"
|
||||
msgstr "请勿随意勾选,除非你知道自己在做什么!"
|
||||
|
||||
msgid "Recommend to set the AUTOUPDATE time to an uncommon time"
|
||||
msgstr "建议设置定时更新时间为设备不常用的时间"
|
||||
|
@ -25,14 +25,14 @@ msgstr "镜像站"
|
||||
msgid "Automatic selection (Recommend)"
|
||||
msgstr "自动选择 (推荐)"
|
||||
|
||||
msgid "GitHub Proxy - Ghproxy (Maybe faster)"
|
||||
msgstr "GitHub Proxy - Ghproxy (也许更快)"
|
||||
msgid "GitHub Proxy"
|
||||
msgstr "GitHub Proxy - Ghproxy"
|
||||
|
||||
msgid "FastGit UK"
|
||||
msgstr "FastGit UK"
|
||||
msgid "CF Workers"
|
||||
msgstr "Cloudflare Workers"
|
||||
|
||||
msgid "Preference Mirror for speeding up downloads while upgrading (For Mainland)"
|
||||
msgstr "定时更新固件时优先启用镜像加速 (适用与被墙地区)"
|
||||
msgid "Preference Mirror for speeding up download"
|
||||
msgstr "优先使用镜像站加速下载"
|
||||
|
||||
msgid "Advanced Settings"
|
||||
msgstr "高级设置"
|
||||
@ -53,7 +53,7 @@ msgid "Upgrade without keeping config"
|
||||
msgstr "不保留配置"
|
||||
|
||||
msgid "Please don't select it unless you know what you're doing!"
|
||||
msgstr "请勿随意勾选除非你知道自己在做什么!"
|
||||
msgstr "请勿随意勾选,除非你知道自己在做什么!"
|
||||
|
||||
msgid "Recommend to set the AUTOUPDATE time to an uncommon time"
|
||||
msgstr "建议设置定时更新时间为设备不常用的时间"
|
||||
@ -70,6 +70,9 @@ msgstr "用于检测固件版本更新以及下载固件的地址"
|
||||
msgid "Firmware Flag"
|
||||
msgstr "固件标签"
|
||||
|
||||
msgid "Log Path"
|
||||
msgstr "日志路径"
|
||||
|
||||
msgid "Do Upgrade"
|
||||
msgstr "执行更新"
|
||||
|
||||
|
@ -1,8 +1,8 @@
|
||||
msgid ""
|
||||
msgstr ""
|
||||
"Project-Id-Version: PACKAGE VERSION\n"
|
||||
"PO-Revision-Date: 2024-01-11 23:35+0000\n"
|
||||
"Last-Translator: gallegonovato <fran-carro@hotmail.es>\n"
|
||||
"PO-Revision-Date: 2024-02-05 02:27+0000\n"
|
||||
"Last-Translator: Franco Castillo <castillofrancodamian@gmail.com>\n"
|
||||
"Language-Team: Spanish <https://hosted.weblate.org/projects/openwrt/"
|
||||
"luciapplicationsopenwisp/es/>\n"
|
||||
"Language: es\n"
|
||||
@ -54,7 +54,7 @@ msgstr "Desactivado"
|
||||
|
||||
#: applications/luci-app-openwisp/htdocs/luci-static/resources/view/openwisp.js:27
|
||||
msgid "Enable"
|
||||
msgstr "Habilitar"
|
||||
msgstr "Activar"
|
||||
|
||||
#: applications/luci-app-openwisp/htdocs/luci-static/resources/view/openwisp.js:28
|
||||
msgid "Enable or disable the OpenWISP service."
|
||||
|
@ -65,13 +65,13 @@ o.default = "eth1"
|
||||
o:depends({ [option_name("protocol")] = "_iface" })
|
||||
|
||||
local nodes_table = {}
|
||||
local balancers_table = {}
|
||||
local iface_table = {}
|
||||
for k, e in ipairs(api.get_valid_nodes()) do
|
||||
if e.node_type == "normal" then
|
||||
nodes_table[#nodes_table + 1] = {
|
||||
id = e[".name"],
|
||||
remarks = e["remark"]
|
||||
remarks = e["remark"],
|
||||
type = e["type"]
|
||||
}
|
||||
end
|
||||
if e.protocol == "_iface" then
|
||||
@ -89,9 +89,6 @@ if #nodes_table > 0 then
|
||||
|
||||
o = s:option(Value, option_name("main_node"), string.format('<a style="color:red">%s</a>', translate("Preproxy Node")), translate("Set the node to be used as a pre-proxy. Each rule (including <code>Default</code>) has a separate switch that controls whether this rule uses the pre-proxy or not."))
|
||||
o:depends({ [option_name("protocol")] = "_shunt", [option_name("preproxy_enabled")] = true })
|
||||
for k, v in pairs(balancers_table) do
|
||||
o:value(v.id, v.remarks)
|
||||
end
|
||||
for k, v in pairs(iface_table) do
|
||||
o:value(v.id, v.remarks)
|
||||
end
|
||||
@ -110,9 +107,6 @@ uci:foreach(appname, "shunt_rules", function(e)
|
||||
o:depends({ [option_name("protocol")] = "_shunt" })
|
||||
|
||||
if #nodes_table > 0 then
|
||||
for k, v in pairs(balancers_table) do
|
||||
o:value(v.id, v.remarks)
|
||||
end
|
||||
for k, v in pairs(iface_table) do
|
||||
o:value(v.id, v.remarks)
|
||||
end
|
||||
@ -142,9 +136,6 @@ o:value("_direct", translate("Direct Connection"))
|
||||
o:value("_blackhole", translate("Blackhole"))
|
||||
|
||||
if #nodes_table > 0 then
|
||||
for k, v in pairs(balancers_table) do
|
||||
o:value(v.id, v.remarks)
|
||||
end
|
||||
for k, v in pairs(iface_table) do
|
||||
o:value(v.id, v.remarks)
|
||||
end
|
||||
@ -631,4 +622,18 @@ o:value("prefer_ipv6")
|
||||
o:value("ipv4_only")
|
||||
o:value("ipv6_only")
|
||||
|
||||
o = s:option(ListValue, option_name("to_node"), translate("Landing node"), translate("Only support a layer of proxy."))
|
||||
o.default = ""
|
||||
o:value("", translate("Close(Not use)"))
|
||||
for k, v in pairs(nodes_table) do
|
||||
if v.type == "sing-box" then
|
||||
o:value(v.id, v.remarks)
|
||||
end
|
||||
end
|
||||
for i, v in ipairs(s.fields[option_name("protocol")].keylist) do
|
||||
if not v:find("_") then
|
||||
o:depends({ [option_name("protocol")] = v })
|
||||
end
|
||||
end
|
||||
|
||||
api.luci_types(arg[1], m, s, type_name, option_prefix)
|
||||
|
@ -875,6 +875,53 @@ function gen_config(var)
|
||||
table.insert(inbounds, inbound)
|
||||
end
|
||||
|
||||
local function set_outbound_detour(node, outbound, outbounds_table, shunt_rule_name)
|
||||
if not node or not outbound or not outbounds_table then return nil end
|
||||
local default_outTag = outbound.tag
|
||||
|
||||
if node.shadowtls == "1" then
|
||||
local _node = {
|
||||
type = "sing-box",
|
||||
protocol = "shadowtls",
|
||||
shadowtls_version = node.shadowtls_version,
|
||||
password = (node.shadowtls_version == "2" or node.shadowtls_version == "3") and node.shadowtls_password or nil,
|
||||
address = node.address,
|
||||
port = node.port,
|
||||
tls = "1",
|
||||
tls_serverName = node.shadowtls_serverName,
|
||||
utls = node.shadowtls_utls,
|
||||
fingerprint = node.shadowtls_fingerprint
|
||||
}
|
||||
local shadowtls_outbound = gen_outbound(nil, _node, outbound.tag .. "_shadowtls")
|
||||
if shadowtls_outbound then
|
||||
table.insert(outbounds_table, shadowtls_outbound)
|
||||
outbound.detour = outbound.tag .. "_shadowtls"
|
||||
outbound.server = nil
|
||||
outbound.server_port = nil
|
||||
end
|
||||
end
|
||||
|
||||
if node.to_node then
|
||||
local to_node = uci:get_all(appname, node.to_node)
|
||||
if to_node then
|
||||
local to_outbound = gen_outbound(nil, to_node)
|
||||
if to_outbound then
|
||||
if shunt_rule_name then
|
||||
to_outbound.tag = outbound.tag
|
||||
outbound.tag = node[".name"]
|
||||
else
|
||||
to_outbound.tag = outbound.tag .. " -> " .. to_outbound.tag
|
||||
end
|
||||
|
||||
to_outbound.detour = outbound.tag
|
||||
table.insert(outbounds_table, to_outbound)
|
||||
default_outTag = to_outbound.tag
|
||||
end
|
||||
end
|
||||
end
|
||||
return default_outTag
|
||||
end
|
||||
|
||||
if node.protocol == "_shunt" then
|
||||
local rules = {}
|
||||
|
||||
@ -903,34 +950,14 @@ function gen_config(var)
|
||||
elseif preproxy_node and api.is_normal_node(preproxy_node) then
|
||||
local preproxy_outbound = gen_outbound(flag, preproxy_node, preproxy_tag)
|
||||
if preproxy_outbound then
|
||||
if preproxy_node.shadowtls == "1" then
|
||||
local _node = {
|
||||
type = "sing-box",
|
||||
protocol = "shadowtls",
|
||||
shadowtls_version = preproxy_node.shadowtls_version,
|
||||
password = (preproxy_node.shadowtls_version == "2" or preproxy_node.shadowtls_version == "3") and preproxy_node.shadowtls_password or nil,
|
||||
address = preproxy_node.address,
|
||||
port = preproxy_node.port,
|
||||
tls = "1",
|
||||
tls_serverName = preproxy_node.shadowtls_serverName,
|
||||
utls = preproxy_node.shadowtls_utls,
|
||||
fingerprint = preproxy_node.shadowtls_fingerprint
|
||||
}
|
||||
local shadowtls_outbound = gen_outbound(flag, _node, preproxy_tag .. "_shadowtls")
|
||||
if shadowtls_outbound then
|
||||
table.insert(outbounds, shadowtls_outbound)
|
||||
preproxy_outbound.detour = preproxy_outbound.tag .. "_shadowtls"
|
||||
preproxy_outbound.server = nil
|
||||
preproxy_outbound.server_port = nil
|
||||
end
|
||||
end
|
||||
set_outbound_detour(preproxy_node, preproxy_outbound, outbounds, preproxy_tag)
|
||||
table.insert(outbounds, preproxy_outbound)
|
||||
else
|
||||
preproxy_enabled = false
|
||||
end
|
||||
end
|
||||
|
||||
local function gen_shunt_node(rule_name, _node_id, as_proxy)
|
||||
local function gen_shunt_node(rule_name, _node_id)
|
||||
if not rule_name then return nil, nil end
|
||||
if not _node_id then _node_id = node[rule_name] or "nil" end
|
||||
local rule_outboundTag
|
||||
@ -1002,27 +1029,7 @@ function gen_config(var)
|
||||
end
|
||||
local _outbound = gen_outbound(flag, _node, rule_name, { proxy = proxy and 1 or 0, tag = proxy and preproxy_tag or nil })
|
||||
if _outbound then
|
||||
if _node.shadowtls == "1" then
|
||||
local shadowtls_node = {
|
||||
type = "sing-box",
|
||||
protocol = "shadowtls",
|
||||
shadowtls_version = _node.shadowtls_version,
|
||||
password = (_node.shadowtls_version == "2" or _node.shadowtls_version == "3") and _node.shadowtls_password or nil,
|
||||
address = _node.address,
|
||||
port = _node.port,
|
||||
tls = "1",
|
||||
tls_serverName = _node.shadowtls_serverName,
|
||||
utls = _node.shadowtls_utls,
|
||||
fingerprint = _node.shadowtls_fingerprint
|
||||
}
|
||||
local shadowtls_outbound = gen_outbound(flag, shadowtls_node, rule_name .. "_shadowtls", { proxy = proxy and 1 or 0, tag = proxy and preproxy_tag or nil })
|
||||
if shadowtls_outbound then
|
||||
table.insert(outbounds, shadowtls_outbound)
|
||||
_outbound.detour = _outbound.tag .. "_shadowtls"
|
||||
_outbound.server = nil
|
||||
_outbound.server_port = nil
|
||||
end
|
||||
end
|
||||
set_outbound_detour(_node, _outbound, outbounds, rule_name)
|
||||
table.insert(outbounds, _outbound)
|
||||
rule_outboundTag = rule_name
|
||||
end
|
||||
@ -1201,46 +1208,23 @@ function gen_config(var)
|
||||
for index, value in ipairs(rules) do
|
||||
table.insert(route.rules, rules[index])
|
||||
end
|
||||
else
|
||||
local outbound = nil
|
||||
if node.protocol == "_iface" then
|
||||
if node.iface then
|
||||
outbound = {
|
||||
type = "direct",
|
||||
tag = node_id,
|
||||
bind_interface = node.iface,
|
||||
routing_mark = 255,
|
||||
}
|
||||
sys.call("touch /tmp/etc/passwall/iface/" .. node.iface)
|
||||
end
|
||||
else
|
||||
outbound = gen_outbound(flag, node)
|
||||
if outbound then
|
||||
if node.shadowtls == "1" then
|
||||
local shadowtls_node = {
|
||||
type = "sing-box",
|
||||
protocol = "shadowtls",
|
||||
shadowtls_version = node.shadowtls_version,
|
||||
password = (node.shadowtls_version == "2" or node.shadowtls_version == "3") and node.shadowtls_password or nil,
|
||||
address = node.address,
|
||||
port = node.port,
|
||||
tls = "1",
|
||||
tls_serverName = node.shadowtls_serverName,
|
||||
utls = node.shadowtls_utls,
|
||||
fingerprint = node.shadowtls_fingerprint
|
||||
}
|
||||
local shadowtls_outbound = gen_outbound(flag, shadowtls_node, outbound.tag .. "_shadowtls")
|
||||
if shadowtls_outbound then
|
||||
table.insert(outbounds, shadowtls_outbound)
|
||||
outbound.detour = outbound.tag .. "_shadowtls"
|
||||
outbound.server = nil
|
||||
outbound.server_port = nil
|
||||
end
|
||||
end
|
||||
end
|
||||
end
|
||||
if outbound then
|
||||
elseif node.protocol == "_iface" then
|
||||
if node.iface then
|
||||
local outbound = {
|
||||
type = "direct",
|
||||
tag = node_id,
|
||||
bind_interface = node.iface,
|
||||
routing_mark = 255,
|
||||
}
|
||||
table.insert(outbounds, outbound)
|
||||
default_outTag = outbound.tag
|
||||
route.final = default_outTag
|
||||
sys.call("touch /tmp/etc/passwall/iface/" .. node.iface)
|
||||
end
|
||||
else
|
||||
local outbound = gen_outbound(flag, node)
|
||||
if outbound then
|
||||
default_outTag = set_outbound_detour(node, outbound, outbounds)
|
||||
table.insert(outbounds, outbound)
|
||||
route.final = default_outTag
|
||||
end
|
||||
|
@ -1569,3 +1569,9 @@ msgstr "分片间隔(ms)"
|
||||
|
||||
msgid "If is domain name, The requested domain name will be resolved to IP before connect."
|
||||
msgstr "如果是域名,域名将在请求发出之前解析为 IP。"
|
||||
|
||||
msgid "Landing node"
|
||||
msgstr "落地节点"
|
||||
|
||||
msgid "Only support a layer of proxy."
|
||||
msgstr "仅支持一层代理。"
|
||||
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
||||
PKG_NAME:=v2dat
|
||||
PKG_SOURCE_DATE:=2022-12-15
|
||||
PKG_SOURCE_VERSION:=47b8ee51fb528e11e1a83453b7e767a18d20d1f7
|
||||
PKG_RELEASE:=3
|
||||
PKG_RELEASE:=4
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_SOURCE_DATE).tar.gz
|
||||
PKG_SOURCE_URL:=https://codeload.github.com/urlesistiana/v2dat/tar.gz/$(PKG_SOURCE_VERSION)?
|
||||
@ -36,7 +36,7 @@ define Package/v2dat
|
||||
DEPENDS:=$(GO_ARCH_DEPENDS)
|
||||
endef
|
||||
|
||||
GO_PKG_TARGET_VARS:=$(filter-out CGO_ENABLED=%,$(GO_PKG_TARGET_VARS)) CGO_ENABLED=0
|
||||
GO_PKG_TARGET_VARS:=$(filter-out CGO_ENABLED=%,$(GO_PKG_TARGET_VARS)) CGO_ENABLED=1
|
||||
|
||||
define Package/v2dat/install
|
||||
$(call GoPackage/Package/Install/Bin,$(1))
|
||||
|
@ -1,8 +1,8 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=Xray-core
|
||||
PKG_VERSION:=1.8.7
|
||||
PKG_RELEASE:=77
|
||||
PKG_VERSION:=1.8.8
|
||||
PKG_RELEASE:=78
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://codeload.github.com/XTLS/Xray-core/tar.gz/v$(PKG_VERSION)?
|
||||
|
@ -5,8 +5,8 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=xray-plugin
|
||||
PKG_VERSION:=1.8.7
|
||||
PKG_RELEASE:=66
|
||||
PKG_VERSION:=1.8.8
|
||||
PKG_RELEASE:=67
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://codeload.github.com/teddysun/xray-plugin/tar.gz/v$(PKG_VERSION)?
|
||||
|
Loading…
Reference in New Issue
Block a user