mirror of
https://github.com/kiddin9/openwrt-packages.git
synced 2025-01-08 13:47:34 +08:00
🎁 Sync 2024-04-07 12:39:38
This commit is contained in:
parent
fbcd131944
commit
8f76a81367
@ -20,6 +20,13 @@ PKG_LICENSE:=MIT
|
||||
PKG_LICENSE_FILE:=LICENSE
|
||||
PKG_MAINTAINER:=sbwml <admin@cooluc.com>
|
||||
|
||||
ifeq ($(ARCH),arm)
|
||||
ARM_CPU_FEATURES:=$(word 2,$(subst +,$(space),$(call qstrip,$(CONFIG_CPU_TYPE))))
|
||||
ifeq ($(ARM_CPU_FEATURES),)
|
||||
ARCH:=armv6
|
||||
endif
|
||||
endif
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/$(PKG_NAME)
|
||||
|
@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=luci-app-dnscrypt-proxy2
|
||||
PKG_VERSION:=2.1.3
|
||||
PKG_RELEASE:=16
|
||||
PKG_RELEASE:=17
|
||||
|
||||
PKG_LICENSE:=GPLv3
|
||||
PKG_LICENSE_FILES:=LICENSE
|
||||
@ -37,6 +37,7 @@ define Package/$(PKG_NAME)
|
||||
TITLE:=DNSCrypt Proxy LuCI interface
|
||||
URL:=https://github.com/peter-tank/luci-app-dnscrypt-proxy2
|
||||
PKGARCH:=all
|
||||
DEPENDS:=+PACKAGE_$(PKG_NAME)_INCLUDE_minisign:minisign
|
||||
endef
|
||||
|
||||
define Package/$(PKG_NAME)/description
|
||||
|
@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=luci-app-openclash
|
||||
PKG_VERSION:=0.46.003
|
||||
PKG_RELEASE:=248
|
||||
PKG_RELEASE:=249
|
||||
PKG_MAINTAINER:=vernesong <https://github.com/vernesong/OpenClash>
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
|
||||
@ -35,7 +35,7 @@ define Package/$(PKG_NAME)
|
||||
TITLE:=LuCI support for clash
|
||||
PKGARCH:=all
|
||||
DEPENDS:=+dnsmasq-full +coreutils +coreutils-nohup +bash +curl +ca-bundle +ipset +ip-full \
|
||||
+libcap +libcap-bin +libcap-bin +ruby +ruby-yaml +kmod-tun +unzip +kmod-inet-diag +kmod-ipt-nat +iptables-mod-tproxy +iptables-mod-extra
|
||||
+libcap +libcap-bin +ruby +ruby-yaml +kmod-tun +unzip +kmod-inet-diag +kmod-ipt-nat +iptables-mod-tproxy +iptables-mod-extra
|
||||
MAINTAINER:=vernesong
|
||||
endef
|
||||
|
||||
|
@ -11,9 +11,9 @@ LUCI_DEPENDS:=@(x86_64||aarch64) +curl +opkg +luci-lib-ipkg +tar +coreutils +cor
|
||||
LUCI_EXTRA_DEPENDS:=luci-lib-taskd (>=1.0.17)
|
||||
LUCI_PKGARCH:=all
|
||||
|
||||
PKG_VERSION:=0.1.14-2
|
||||
PKG_VERSION:=0.1.14-3
|
||||
# PKG_RELEASE MUST be empty for luci.mk
|
||||
PKG_RELEASE:=67
|
||||
PKG_RELEASE:=68
|
||||
|
||||
ISTORE_UI_VERSION:=0.1.14
|
||||
ISTORE_UI_RELEASE:=2
|
||||
|
@ -58,11 +58,13 @@ update() {
|
||||
return 1
|
||||
fi
|
||||
|
||||
fcurl -o ${OPKG_CONF_DIR}/meta.conf "${FEEDS_SERVER}/all/meta.conf" && \
|
||||
fcurl -o ${OPKG_CONF_DIR}/all.conf "${FEEDS_SERVER}/all/isfeeds.conf" && \
|
||||
fcurl -o ${OPKG_CONF_DIR}/arch.conf "${FEEDS_SERVER}/${ARCH}/isfeeds.conf" || \
|
||||
echo "Fetch feed list for ${ARCH}"
|
||||
fcurl --no-progress-meter -o ${OPKG_CONF_DIR}/meta.conf "${FEEDS_SERVER}/all/meta.conf" && \
|
||||
fcurl --no-progress-meter -o ${OPKG_CONF_DIR}/all.conf "${FEEDS_SERVER}/all/isfeeds.conf" && \
|
||||
fcurl --no-progress-meter -o ${OPKG_CONF_DIR}/arch.conf "${FEEDS_SERVER}/${ARCH}/isfeeds.conf" || \
|
||||
return 1
|
||||
|
||||
echo "Update feeds index"
|
||||
opkg -f ${IS_ROOT}/etc/opkg_o.conf --offline-root ${IS_ROOT} update
|
||||
|
||||
return 0
|
||||
|
@ -7,7 +7,7 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
LUCI_TITLE:=LuCI Support for Transmission
|
||||
LUCI_DEPENDS:=+transmission-daemon +transmission-web-control
|
||||
LUCI_DEPENDS:=+transmission-daemon
|
||||
|
||||
include $(TOPDIR)/feeds/luci/luci.mk
|
||||
|
||||
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=miniupnpd-iptables
|
||||
PKG_VERSION:=3022-08-31
|
||||
PKG_RELEASE:=17
|
||||
PKG_RELEASE:=18
|
||||
|
||||
PKG_SOURCE_URL:=http://miniupnp.free.fr/files
|
||||
PKG_SOURCE:=miniupnpd-2.0.20180503.tar.gz
|
||||
|
13
miniupnpd-iptables/patches/106-spam-syslog-ignoring.patch
Normal file
13
miniupnpd-iptables/patches/106-spam-syslog-ignoring.patch
Normal file
@ -0,0 +1,13 @@
|
||||
--- a/minissdp.c 2017-04-21 19:24:23.000000000 +0800
|
||||
+++ b/minissdp.c 2021-06-22 07:01:24.000000000 +0800
|
||||
@@ -865,8 +865,8 @@
|
||||
lan_addr = get_lan_for_peer(sender);
|
||||
if(lan_addr == NULL)
|
||||
{
|
||||
- syslog(LOG_WARNING, "SSDP packet sender %s not from a LAN, ignoring",
|
||||
- sender_str);
|
||||
+ /* syslog(LOG_WARNING, "SSDP packet sender %s not from a LAN, ignoring",
|
||||
+ sender_str); */
|
||||
return;
|
||||
}
|
||||
|
@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
|
||||
|
||||
PKG_NAME:=my-default-settings
|
||||
PKG_VERSION:=1
|
||||
PKG_RELEASE:=229
|
||||
PKG_RELEASE:=231
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
|
@ -26,7 +26,7 @@ include $(TOPDIR)/feeds/packages/lang/python/python3-version.mk
|
||||
|
||||
PKG_NAME:=nanohatoled
|
||||
PKG_VERSION:=1.0.4
|
||||
PKG_RELEASE:=5
|
||||
PKG_RELEASE:=7
|
||||
PKG_DATE:=20200528
|
||||
|
||||
PKG_LICENSE:=MIT
|
||||
|
20
nanohatoled/files/nanohatoled
Executable file
20
nanohatoled/files/nanohatoled
Executable file
@ -0,0 +1,20 @@
|
||||
#!/bin/sh /etc/rc.common
|
||||
# Copyright (C) 2009-2010 OpenWrt.org
|
||||
|
||||
START=99
|
||||
STOP=15
|
||||
|
||||
NanoHatOLED="/usr/share/NanoHatOLED/NanoHatOLED"
|
||||
|
||||
start() {
|
||||
|
||||
# 启动 OLED
|
||||
$NanoHatOLED > /dev/null 2>&1 &
|
||||
|
||||
}
|
||||
|
||||
stop() {
|
||||
# 关闭 OLED
|
||||
kill -9 `ps w|grep -E "NanoHatOLED|bakebit_nanohat_oled"|grep -v "grep"|awk '{print $1}'` 2>/dev/null
|
||||
|
||||
}
|
@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=ngrokc
|
||||
PKG_VERSION:=1.55
|
||||
PKG_RELEASE:=19
|
||||
PKG_RELEASE:=20
|
||||
|
||||
PKG_SOURCE_PROTO:=git
|
||||
PKG_SOURCE_URL:=https://github.com/dosgo/ngrok-c.git
|
||||
@ -23,7 +23,7 @@ define Package/ngrokc
|
||||
SUBMENU:=Web Servers/Proxies
|
||||
TITLE:=Secure tunnels to localhost (C++ port)
|
||||
URL:=https://github.com/dosgo/ngrok-c
|
||||
DEPENDS:=+libc +libpthread +libopenssl +libstdcpp +zlib +zlib \
|
||||
DEPENDS:=+libc +libpthread +libopenssl +libstdcpp +zlib \
|
||||
+USE_GLIBC:libatomic
|
||||
endef
|
||||
|
||||
|
@ -8,7 +8,7 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=rtl8812au-ac
|
||||
PKG_RELEASE:=36
|
||||
PKG_RELEASE:=37
|
||||
|
||||
PKG_SOURCE_URL:=https://github.com/aircrack-ng/rtl8812au.git
|
||||
PKG_SOURCE_PROTO:=git
|
||||
|
@ -1,8 +1,11 @@
|
||||
--- a/os_dep/linux/ioctl_cfg80211.c
|
||||
+++ b/os_dep/linux/ioctl_cfg80211.c
|
||||
@@ -462,7 +462,7 @@ u8 rtw_cfg80211_ch_switch_notify(_adapter *adapter, u8 ch, u8 bw, u8 offset,
|
||||
@@ -460,9 +460,9 @@ u8 rtw_cfg80211_ch_switch_notify(_adapter *adapter, u8 ch, u8 bw, u8 offset,
|
||||
|
||||
#if (LINUX_VERSION_CODE >= KERNEL_VERSION(3, 19, 0))
|
||||
if (started) {
|
||||
#if (LINUX_VERSION_CODE >= KERNEL_VERSION(6, 3, 0))
|
||||
-#if (LINUX_VERSION_CODE >= KERNEL_VERSION(6, 3, 0))
|
||||
+#if (LINUX_VERSION_CODE >= KERNEL_VERSION(6, 1, 0))
|
||||
cfg80211_ch_switch_started_notify(adapter->pnetdev, &chdef, 0, 0, false, 0);
|
||||
-#elif (LINUX_VERSION_CODE >= KERNEL_VERSION(6, 1, 0))
|
||||
+#elif (LINUX_VERSION_CODE >= KERNEL_VERSION(5, 15, 0))
|
||||
|
Loading…
Reference in New Issue
Block a user