🔥 Sync 2024-09-20 20:34:48

This commit is contained in:
github-actions[bot] 2024-09-20 20:34:48 +08:00
parent e24d6e769c
commit f1b0f8fdce
7 changed files with 59 additions and 11 deletions

View File

@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
PKG_MAINTAINER:=Thaolga <https://github.com/Thaolga/luci-app-nekoclash>
PKG_NAME:=luci-app-nekoclash
PKG_VERSION:=1.3.4
PKG_RELEASE:=41
PKG_RELEASE:=42
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)

View File

@ -1019,7 +1019,7 @@ if ($_SERVER['REQUEST_METHOD'] === 'POST') {
<input type="hidden" name="fileType" value="<?php echo htmlspecialchars($_POST['fileType']); ?>">
<button type="submit" class="btn btn-primary mt-2" onclick="syncEditorContent()"><i class="fas fa-save"></i> 保存内容</button>
</form>
<button id="closeEditorButton" class="close-fullscreen" onclick="closeEditor()">X</button>
<div id="aceEditorError" class="error-popup d-none">
<span id="aceEditorErrorMessage"></span>
<button id="closeErrorPopup">关闭</button>
@ -1030,7 +1030,7 @@ if ($_SERVER['REQUEST_METHOD'] === 'POST') {
<div class="navigation">
<a href="javascript:history.back()" class="btn btn-success">返回上一级菜单</a>
<a href="/nekoclash/upload.php" class="btn btn-success">返回当前菜单</a>
<a href="/nekoclash/mon.php?page=upload" class="btn btn-success">返回当前菜单</a>
<a href="/nekoclash/configs.php" class="btn btn-success">返回配置菜单</a>
<a href="/nekoclash" class="btn btn-success">返回主菜单</a>
</div>
@ -1115,6 +1115,10 @@ if ($_SERVER['REQUEST_METHOD'] === 'POST') {
</script>
<script>
function closeEditor() {
window.location.href = window.location.href;
}
var aceEditor = ace.edit("aceEditorContainer");
aceEditor.setTheme("ace/theme/monokai");
aceEditor.session.setMode("ace/mode/yaml");
@ -1296,6 +1300,24 @@ if ($_SERVER['REQUEST_METHOD'] === 'POST') {
z-index: 9999;
}
.close-fullscreen {
position: fixed;
top: 10px;
right: 10px;
z-index: 10000;
background-color: red;
color: white;
border: none;
border-radius: 50%;
width: 40px;
height: 40px;
font-size: 24px;
display: flex;
align-items: center;
justify-content: center;
cursor: pointer;
}
#aceEditorError button {
margin-top: 10px;
padding: 5px 10px;

View File

@ -540,7 +540,7 @@ if (isset($_POST['update_index'])) {
<input type="hidden" name="fileType" value="<?php echo htmlspecialchars($_POST['fileType']); ?>">
<button type="submit" class="btn btn-primary mt-2" onclick="syncEditorContent()"><i class="fas fa-save"></i> 保存内容</button>
</form>
<button id="closeEditorButton" class="close-fullscreen" onclick="closeEditor()">X</button>
<div id="aceEditorError" class="error-popup d-none">
<span id="aceEditorErrorMessage"></span>
<button id="closeErrorPopup">关闭</button>
@ -551,7 +551,7 @@ if (isset($_POST['update_index'])) {
<div class="nav-buttons mt-4">
<a href="javascript:history.back()" class="btn btn-success">返回上一级菜单</a>
<a href="/nekoclash/upload_sb.php" class="btn btn-success">返回当前菜单</a>
<a href="/nekoclash/mon.php?page=upload_sb" class="btn btn-success">返回当前菜单</a>
<a href="/nekoclash" class="btn btn-success">返回主菜单</a>
</div>
<h1 style="margin-top: 20px; margin-bottom: 20px;">Sing-box 订阅</h1>
@ -622,6 +622,10 @@ if (isset($_POST['update_index'])) {
modal.find('#newFileName').val(oldFileName);
});
function closeEditor() {
window.location.href = window.location.href;
}
var aceEditor = ace.edit("aceEditorContainer");
aceEditor.setTheme("ace/theme/monokai");
aceEditor.session.setMode("ace/mode/json");
@ -805,6 +809,24 @@ if (isset($_POST['update_index'])) {
z-index: 9999;
}
.close-fullscreen {
position: fixed;
top: 10px;
right: 10px;
z-index: 10000;
background-color: red;
color: white;
border: none;
border-radius: 50%;
width: 40px;
height: 40px;
font-size: 24px;
display: flex;
align-items: center;
justify-content: center;
cursor: pointer;
}
#aceEditorError button {
margin-top: 10px;
padding: 5px 10px;

View File

@ -12,11 +12,11 @@ LUCI_DEPENDS:=+luci-nginx
define Package/luci-nginxer/postrm
#!/bin/sh
/etc/init.d/uhttpd enabled
/etc/init.d/uhttpd enable
/etc/init.d/uhttpd start
exit 0
endef
include $(TOPDIR)/feeds/luci/luci.mk
# call BuildPackage - OpenWrt buildroot signature
# call BuildPackage - OpenWrt buildroot signature

View File

@ -8,7 +8,11 @@ if [ "$nginxer" != 1 ]; then
uci set nginx._redirect2ssl.access_log='off; # logd openwrt'
uci set nginx.global.nginxer='1'
uci commit nginx
# fix firmware upload failed
sed -i 's/client_max_body_size 128M;/client_max_body_size 256M;/g' /etc/nginx/uci.conf.template
# /etc/init.d/uhttpd running || /etc/init.d/uhttpd disable
/etc/init.d/nginx reload
fi
exit 0
exit 0

View File

@ -1,8 +1,8 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=qBittorrent-Enhanced-Edition
PKG_VERSION:=4.6.5.10
PKG_RELEASE:=62
PKG_VERSION:=4.6.7.10
PKG_RELEASE:=63
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/c0re100/qBittorrent-Enhanced-Edition/tar.gz/release-$(PKG_VERSION)?

View File

@ -3,7 +3,7 @@
@@ -31,7 +31,7 @@
#define QBT_VERSION_MAJOR 4
#define QBT_VERSION_MINOR 6
#define QBT_VERSION_BUGFIX 5
#define QBT_VERSION_BUGFIX 7
-#define QBT_VERSION_BUILD 10
+#define QBT_VERSION_BUILD 0
#define QBT_VERSION_STATUS "" // Should be empty for stable releases!