mirror of
https://git.openwrt.org/feed/routing.git
synced 2025-01-08 11:47:51 +08:00
Fix Quagga vtysh build against readline 6.3
This commit is contained in:
parent
3c8e0c9670
commit
0820b44d82
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=quagga
|
||||
PKG_VERSION:=0.99.22.4
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
PKG_MD5SUM:=03ef24a448be47beba80efa2152f8a28
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
@ -46,7 +46,7 @@ endef
|
||||
|
||||
define Package/quagga
|
||||
$(call Package/quagga/Default)
|
||||
DEPENDS:=@BROKEN +librt
|
||||
DEPENDS:=+librt
|
||||
MENU:=1
|
||||
endef
|
||||
|
||||
|
@ -0,0 +1,15 @@
|
||||
--- a/vtysh/vtysh.c
|
||||
+++ b/vtysh/vtysh.c
|
||||
@@ -2211,9 +2211,9 @@
|
||||
vtysh_readline_init (void)
|
||||
{
|
||||
/* readline related settings. */
|
||||
- rl_bind_key ('?', (Function *) vtysh_rl_describe);
|
||||
+ rl_bind_key ('?', (rl_command_func_t *) vtysh_rl_describe);
|
||||
rl_completion_entry_function = vtysh_completion_entry_function;
|
||||
- rl_attempted_completion_function = (CPPFunction *)new_completion;
|
||||
+ rl_attempted_completion_function = (rl_completion_func_t *) new_completion;
|
||||
/* do not append space after completion. It will be appended
|
||||
* in new_completion() function explicitly. */
|
||||
rl_completion_append_character = '\0';
|
||||
|
Loading…
Reference in New Issue
Block a user