mirror of
https://git.openwrt.org/feed/routing.git
synced 2025-01-08 11:47:51 +08:00
batctl: upgrade package to latest release 2019.1
* coding style cleanups and refactoring * introduce support for batadv meshif, hardif and vlan configuration via netlink * replace multicast_mode with multicast_forceflood settings subcommand * add hop_penalty setting subcommand Signed-off-by: Sven Eckelmann <sven@narfation.org>
This commit is contained in:
parent
9e8aaf9911
commit
0a2547a111
@ -9,9 +9,9 @@ include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=batctl
|
||||
|
||||
PKG_VERSION:=2019.0
|
||||
PKG_RELEASE:=2
|
||||
PKG_HASH:=997721096ff396644e8d697ea7651e9d38243faf317bcea2661d4139ff58b531
|
||||
PKG_VERSION:=2019.1
|
||||
PKG_RELEASE:=0
|
||||
PKG_HASH:=e82d05f058d8b799d17ce6063e1bf5b83ef1fe42a0867b3e2e39545177469793
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://downloads.open-mesh.org/batman/releases/batman-adv-$(PKG_VERSION)
|
||||
@ -122,6 +122,7 @@ config-n := \
|
||||
log \
|
||||
loglevel \
|
||||
mcast_flags \
|
||||
multicast_forceflood \
|
||||
multicast_mode \
|
||||
nc_nodes \
|
||||
neighbors \
|
||||
@ -150,6 +151,7 @@ config-settings := \
|
||||
interface \
|
||||
isolation_mark \
|
||||
loglevel \
|
||||
multicast_forceflood \
|
||||
multicast_mode \
|
||||
network_coding \
|
||||
orig_interval \
|
||||
|
@ -1,59 +0,0 @@
|
||||
From: Sven Eckelmann <sven@narfation.org>
|
||||
Date: Fri, 22 Feb 2019 22:19:59 +0100
|
||||
Subject: batctl: Add hop_penalty command
|
||||
|
||||
Signed-off-by: Sven Eckelmann <sven@narfation.org>
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index 4d8b7095a1e307f0dde7660a718e4ad9c6b11102..55105cc754f546891ba2fcaf57dc8b3ac4c22f71 100755
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -63,6 +63,7 @@ $(eval $(call add_command,event,y))
|
||||
$(eval $(call add_command,fragmentation,y))
|
||||
$(eval $(call add_command,gateways,y))
|
||||
$(eval $(call add_command,gw_mode,y))
|
||||
+$(eval $(call add_command,hop_penalty,y))
|
||||
$(eval $(call add_command,interface,y))
|
||||
$(eval $(call add_command,isolation_mark,y))
|
||||
$(eval $(call add_command,log,y))
|
||||
diff --git a/hop_penalty.c b/hop_penalty.c
|
||||
new file mode 100644
|
||||
index 0000000000000000000000000000000000000000..6e6a06a661e2ffbb76793116fb214396523bbd8d
|
||||
--- /dev/null
|
||||
+++ b/hop_penalty.c
|
||||
@@ -0,0 +1,35 @@
|
||||
+// SPDX-License-Identifier: GPL-2.0
|
||||
+/* Copyright (C) 2009-2019 B.A.T.M.A.N. contributors:
|
||||
+ *
|
||||
+ * Marek Lindner <mareklindner@neomailbox.ch>
|
||||
+ *
|
||||
+ * This program is free software; you can redistribute it and/or
|
||||
+ * modify it under the terms of version 2 of the GNU General Public
|
||||
+ * License as published by the Free Software Foundation.
|
||||
+ *
|
||||
+ * This program is distributed in the hope that it will be useful, but
|
||||
+ * WITHOUT ANY WARRANTY; without even the implied warranty of
|
||||
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
||||
+ * General Public License for more details.
|
||||
+ *
|
||||
+ * You should have received a copy of the GNU General Public License
|
||||
+ * along with this program; if not, write to the Free Software
|
||||
+ * Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA
|
||||
+ * 02110-1301, USA
|
||||
+ *
|
||||
+ * License-Filename: LICENSES/preferred/GPL-2.0
|
||||
+ */
|
||||
+
|
||||
+#include <stddef.h>
|
||||
+
|
||||
+#include "main.h"
|
||||
+#include "sys.h"
|
||||
+
|
||||
+static struct settings_data batctl_settings_hop_penalty = {
|
||||
+ .sysfs_name = "hop_penalty",
|
||||
+ .params = NULL,
|
||||
+};
|
||||
+
|
||||
+COMMAND_NAMED(SUBCOMMAND, hop_penalty, "hp", handle_sys_setting,
|
||||
+ COMMAND_FLAG_MESH_IFACE, &batctl_settings_hop_penalty,
|
||||
+ "[penalty] \tdisplay or modify hop_penalty setting");
|
Loading…
Reference in New Issue
Block a user