mirror of
https://git.openwrt.org/feed/routing.git
synced 2025-01-07 03:06:53 +08:00
cjdns: bump v21.1 and patch find-python (#883)
* cjdns: bump source from v21 to v21.1 * cjdns: bump release with patch to prefer python2 * cjdns: refresh patches and remove patch musl Signed-off-by: William Fleurant <meshnet@protonmail.com>
This commit is contained in:
parent
09d5ceb923
commit
217330bb5e
@ -17,12 +17,12 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=cjdns
|
||||
PKG_VERSION:=v21
|
||||
PKG_VERSION:=v21.1
|
||||
PKG_RELEASE:=3
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://codeload.github.com/cjdelisle/cjdns/tar.gz/$(PKG_NAME)-$(PKG_VERSION)?
|
||||
PKG_HASH:=6dfb1fe18c9689324f36c8d33e660972aac5af4579fcaa9c4730179bc8d67c69
|
||||
PKG_HASH:=a6158ce7847159aa44e86f74ccc7b6ded6910a230ed8f3830db53cda5838f0b0
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_NAME)-$(PKG_VERSION)
|
||||
|
||||
PKG_MAINTAINER:=William Fleurant <meshnet@protonmail.com>
|
||||
|
@ -1,13 +1,13 @@
|
||||
--- a/node_build/builder.js
|
||||
+++ b/node_build/builder.js
|
||||
@@ -215,8 +215,8 @@ var execJs = function (js, builder, file
|
||||
js = qs.join("'");
|
||||
@@ -277,8 +277,8 @@ const execJs = function (js, ctx, file,
|
||||
js = '"use strict";' + qs.join("'");
|
||||
|
||||
var to = setTimeout(function () {
|
||||
const to = setTimeout(function () {
|
||||
- throw new Error("Inline JS did not return after 120 seconds [" + js + "]");
|
||||
- }, 120000);
|
||||
+ throw new Error("Inline JS did not return after 5 minutes [" + js + "]");
|
||||
+ }, 300000);
|
||||
|
||||
var REQUIRE = function (str) {
|
||||
if (typeof(str) !== 'string') {
|
||||
nThen(function (waitFor) {
|
||||
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- a/memory/Allocator.c
|
||||
+++ b/memory/Allocator.c
|
||||
@@ -57,7 +57,7 @@ static void unroll(struct Allocator_pvt*
|
||||
struct Allocator_Allocation_pvt* allocation = context->allocations;
|
||||
while (allocation && includeAllocations) {
|
||||
writeUnroller(&childUnroller);
|
||||
- fprintf(stderr, "%s:%ld [%lu] bytes at [0x%lx]\n",
|
||||
+ fprintf(stderr, "%s:%tu [%tu] bytes at [0x%lx]\n",
|
||||
allocation->fileName,
|
||||
allocation->lineNum,
|
||||
allocation->pub.size,
|
11
cjdns/patches/020-prefer-python2.patch
Normal file
11
cjdns/patches/020-prefer-python2.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- a/node_build/FindPython.js
|
||||
+++ b/node_build/FindPython.js
|
||||
@@ -23,7 +23,7 @@ var Fs = require('fs');
|
||||
// de-prioritize because the testing script accepts ANY python3 version
|
||||
// (as of this writing, we don't know what python3 versions actually work)
|
||||
// whereas we know that python2.7 is the only working python2 version.
|
||||
-var PYTHONS = ["python3.7", "python3", "python2.7", "python2", "python"];
|
||||
+var PYTHONS = ["python2", "python2.7", "python3.7", "python3.8", "python3.9", "python3"]
|
||||
|
||||
var SCRIPT = [
|
||||
'import sys',
|
Loading…
Reference in New Issue
Block a user