mirror of
https://git.openwrt.org/feed/routing.git
synced 2025-01-07 03:06:53 +08:00
prince: fix compilation with GCC 10
Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
8f9aa112b5
commit
587e2d8b9c
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=prince
|
||||
PKG_VERSION:=v0.4
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
# out of source build
|
||||
CMAKE_BINARY_SUBDIR:=build
|
||||
|
20
prince/patches/010-gcc10.patch
Normal file
20
prince/patches/010-gcc10.patch
Normal file
@ -0,0 +1,20 @@
|
||||
--- a/prince/include/common.h
|
||||
+++ b/prince/include/common.h
|
||||
@@ -35,12 +35,12 @@ typedef struct routing_plugin_ {
|
||||
|
||||
} routing_plugin;
|
||||
|
||||
-routing_plugin *(*new_plugin_p)(char *host, int port, int json_type,
|
||||
+static routing_plugin *(*new_plugin_p)(char *host, int port, int json_type,
|
||||
int timer_port);
|
||||
|
||||
-int (*get_initial_timers_p)(routing_plugin *o, struct timers *t);
|
||||
-int (*get_topology_p)(routing_plugin *o);
|
||||
-int (*push_timers_p)(routing_plugin *o, struct timers t);
|
||||
-void (*delete_plugin_p)(routing_plugin *o);
|
||||
+static int (*get_initial_timers_p)(routing_plugin *o, struct timers *t);
|
||||
+static int (*get_topology_p)(routing_plugin *o);
|
||||
+static int (*push_timers_p)(routing_plugin *o, struct timers t);
|
||||
+static void (*delete_plugin_p)(routing_plugin *o);
|
||||
|
||||
#endif /* SRC_COMMON_H_ */
|
Loading…
Reference in New Issue
Block a user