mirror of
https://git.openwrt.org/feed/routing.git
synced 2025-01-09 04:07:48 +08:00
batctl: upgrade package to latest release 2021.0
* Drop support for batman-adv's sysfs+debugfs * allow to select routing algorithm during creation of interface * bugs squashed: - fix query of meshif's ap_isolation status - ignore "interface already exists" error during "interface add" Signed-off-by: Sven Eckelmann <sven@narfation.org>
This commit is contained in:
parent
6c81fc2916
commit
8de6e21ec5
@ -3,12 +3,12 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=batctl
|
PKG_NAME:=batctl
|
||||||
PKG_VERSION:=2020.4
|
PKG_VERSION:=2021.0
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=https://downloads.open-mesh.org/batman/releases/batman-adv-$(PKG_VERSION)
|
PKG_SOURCE_URL:=https://downloads.open-mesh.org/batman/releases/batman-adv-$(PKG_VERSION)
|
||||||
PKG_HASH:=fc346005b3c19306ccf259329294d1d145a1294e04e9dbde2fb6c37697bb3917
|
PKG_HASH:=9cec8bf1952f885192749a9dc0318a54633b717aaf05c438d504efd83f5201e4
|
||||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
|
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
|
||||||
|
|
||||||
PKG_MAINTAINER:=Simon Wunderlich <sw@simonwunderlich.de>
|
PKG_MAINTAINER:=Simon Wunderlich <sw@simonwunderlich.de>
|
||||||
@ -112,7 +112,6 @@ config-n := \
|
|||||||
multicast_fanout \
|
multicast_fanout \
|
||||||
multicast_forceflood \
|
multicast_forceflood \
|
||||||
multicast_mode \
|
multicast_mode \
|
||||||
nc_nodes \
|
|
||||||
neighbors \
|
neighbors \
|
||||||
network_coding \
|
network_coding \
|
||||||
orig_interval \
|
orig_interval \
|
||||||
@ -155,7 +154,6 @@ config-tables := \
|
|||||||
dat_cache \
|
dat_cache \
|
||||||
gateways \
|
gateways \
|
||||||
mcast_flags \
|
mcast_flags \
|
||||||
nc_nodes \
|
|
||||||
neighbors \
|
neighbors \
|
||||||
originators \
|
originators \
|
||||||
statistics \
|
statistics \
|
||||||
|
@ -0,0 +1,25 @@
|
|||||||
|
From: Sven Eckelmann <sven@narfation.org>
|
||||||
|
Date: Thu, 28 Jan 2021 20:44:22 +0100
|
||||||
|
Subject: batctl: Fix build of routing_algo against musl
|
||||||
|
|
||||||
|
glibc is including the headers for the rtnetlink functionality. But musl
|
||||||
|
avoids this indirect include. The headers must therefore be included
|
||||||
|
explicitely.
|
||||||
|
|
||||||
|
Fixes: e0ccb9b575d9 ("batctl: Switch active routing algo list to netlink")
|
||||||
|
Signed-off-by: Sven Eckelmann <sven@narfation.org>
|
||||||
|
Origin: upstream, https://git.open-mesh.org/batctl.git/commit/b0044a6b2f8a762387d9b7408b1fe528f21c4ad7
|
||||||
|
|
||||||
|
diff --git a/routing_algo.c b/routing_algo.c
|
||||||
|
index 27458ffdd9b91decbecbe6ec5da8ffd14c863a35..b5e3ebb8c5a4743cd2c42634d79f8a4c6a8210db 100644
|
||||||
|
--- a/routing_algo.c
|
||||||
|
+++ b/routing_algo.c
|
||||||
|
@@ -9,6 +9,8 @@
|
||||||
|
#include <errno.h>
|
||||||
|
#include <fcntl.h>
|
||||||
|
#include <getopt.h>
|
||||||
|
+#include <linux/if_link.h>
|
||||||
|
+#include <linux/rtnetlink.h>
|
||||||
|
#include <netinet/if_ether.h>
|
||||||
|
#include <netlink/netlink.h>
|
||||||
|
#include <netlink/genl/genl.h>
|
Loading…
Reference in New Issue
Block a user