mirror of
https://git.openwrt.org/feed/routing.git
synced 2025-01-09 04:07:48 +08:00
bird2: update to version 2.0.8
- Removed patch as it is now included in upstream release - Removed --with-linux-headers option (Fixes: configure: WARNING: unrecognized options: --with-linux-headers) Changelog: https://bird.network.cz/pipermail/bird-users/2021-March/015281.html Signed-off-by: Josef Schlehofer <pepe.schlehofer@gmail.com>
This commit is contained in:
parent
e26b474520
commit
9d6ef13203
@ -7,12 +7,12 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=bird2
|
||||
PKG_VERSION:=2.0.7
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=2.0.8
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=bird-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=ftp://bird.network.cz/pub/bird
|
||||
PKG_HASH:=631d2b58aebdbd651aaa3c68c3756c02ebfe5b1e60d307771ea909eeaa5b1066
|
||||
PKG_HASH:=19d2de83ee25a307b9e5b9e58797dd68766d439bcee33e3ac617ed502370e7f6
|
||||
PKG_BUILD_DEPENDS:=ncurses readline
|
||||
PKG_MAINTAINER:=Toke Høiland-Jørgensen <toke@toke.dk>
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/bird-$(PKG_VERSION)
|
||||
@ -96,7 +96,7 @@ protocols, telling BIRD to show various information, telling it to show
|
||||
a routing table filtered by a filter, or asking BIRD to reconfigure.
|
||||
endef
|
||||
|
||||
CONFIGURE_ARGS += --with-linux-headers="$(LINUX_DIR)" --disable-libssh
|
||||
CONFIGURE_ARGS += --disable-libssh
|
||||
|
||||
define Package/bird2/conffiles
|
||||
/etc/bird.conf
|
||||
|
@ -1,40 +0,0 @@
|
||||
From 0ca3156f64a46c52c6d6fc913958f83970d3e57f Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Toke=20H=C3=B8iland-J=C3=B8rgensen?= <toke@toke.dk>
|
||||
Date: Mon, 30 Apr 2018 11:13:02 +0200
|
||||
Subject: [PATCH] babel: Set onlink flag for IPv4 routes with unreachable next
|
||||
hop
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
If the next hop of a route is not a reachable address, the route should be
|
||||
installed as onlink. This enables a configuration common in mesh networks
|
||||
where the mesh interface is assigned a /32 and babel handles the routing by
|
||||
installing onlink routes.
|
||||
|
||||
Signed-off-by: Toke Høiland-Jørgensen <toke@toke.dk>
|
||||
---
|
||||
proto/babel/babel.c | 7 +++++++
|
||||
1 file changed, 7 insertions(+)
|
||||
|
||||
diff --git a/proto/babel/babel.c b/proto/babel/babel.c
|
||||
index ce05191c..afd2eb19 100644
|
||||
--- a/proto/babel/babel.c
|
||||
+++ b/proto/babel/babel.c
|
||||
@@ -640,6 +640,13 @@ babel_announce_rte(struct babel_proto *p, struct babel_entry *e)
|
||||
.nh.iface = r->neigh->ifa->iface,
|
||||
};
|
||||
|
||||
+ /* If we cannot find a reachable neighbour, set the entry to be onlink. This
|
||||
+ * makes it possible to, e.g., assign /32 addresses on a mesh interface and
|
||||
+ * have routing work.
|
||||
+ */
|
||||
+ if (!neigh_find(&p->p, r->next_hop, r->neigh->ifa->iface, 0))
|
||||
+ a0.nh.flags = RNF_ONLINK;
|
||||
+
|
||||
rta *a = rta_lookup(&a0);
|
||||
rte *rte = rte_get_temp(a);
|
||||
rte->u.babel.seqno = r->seqno;
|
||||
--
|
||||
2.17.0
|
||||
|
Loading…
Reference in New Issue
Block a user