mirror of
https://git.openwrt.org/feed/routing.git
synced 2025-01-07 03:06:53 +08:00
babeld: update to 1.13.1
Announcement: https://alioth-lists.debian.net/pipermail/babel-users/2023-July/004125.html Remove upstreamed patch: - 100-local-make-local_kind-function-accessible.patch Refresh patch: - 600-add-ubus.patch Signed-off-by: Nick Hainke <vincent@systemli.org>
This commit is contained in:
parent
91e07907fa
commit
eb8978ebf7
@ -6,12 +6,12 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=babeld
|
||||
PKG_VERSION:=1.13
|
||||
PKG_VERSION:=1.13.1
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://www.irif.fr/~jch/software/files/
|
||||
PKG_HASH:=d085ccccfb06a11d7fa5b54c51d9c410f5f3b0a9389f584951336ff178f293b8
|
||||
PKG_HASH:=15f24d26da0ccfc073abcdef0309f281e4684f2aa71126f826572c4c845e8dd9
|
||||
|
||||
PKG_MAINTAINER:=Gabriel Kerneis <gabriel@kerneis.info>, \
|
||||
Baptiste Jonglez <openwrt-pkg@bitsofnetworks.org>, \
|
||||
|
@ -1,39 +0,0 @@
|
||||
From b29cb705c3b717a7d5c61719936464438b9a48f0 Mon Sep 17 00:00:00 2001
|
||||
From: Nick Hainke <vincent@systemli.org>
|
||||
Date: Fri, 15 Jan 2021 15:01:31 +0100
|
||||
Subject: [PATCH] local: make local_kind function accessible
|
||||
|
||||
The kind-definitions are contained in the header file:
|
||||
LOCAL_FLUSH 0
|
||||
LOCAL_ADD 1
|
||||
LOCAL_CHANGE 2
|
||||
|
||||
The function (local_kind) that converts them into strings again
|
||||
is private. New addons (for example openwrt ubus bindings) that make
|
||||
use of babeld should also use the same function to convert the kind
|
||||
to string format. This allows to ensure uniformity over all addons.
|
||||
|
||||
Signed-off-by: Nick Hainke <vincent@systemli.org>
|
||||
---
|
||||
local.c | 2 +-
|
||||
local.h | 1 +
|
||||
2 files changed, 2 insertions(+), 1 deletion(-)
|
||||
|
||||
--- a/local.c
|
||||
+++ b/local.c
|
||||
@@ -80,7 +80,7 @@ write_timeout(int fd, const void *buf, i
|
||||
}
|
||||
}
|
||||
|
||||
-static const char *
|
||||
+const char *
|
||||
local_kind(int kind)
|
||||
{
|
||||
switch(kind) {
|
||||
--- a/local.h
|
||||
+++ b/local.h
|
||||
@@ -55,3 +55,4 @@ int local_read(struct local_socket *s);
|
||||
int local_header(struct local_socket *s);
|
||||
struct local_socket *local_socket_create(int fd);
|
||||
void local_socket_destroy(int i);
|
||||
+const char *local_kind(int kind);
|
@ -57,7 +57,7 @@
|
||||
static struct filter *input_filters = NULL;
|
||||
static struct filter *output_filters = NULL;
|
||||
static struct filter *redistribute_filters = NULL;
|
||||
@@ -1017,7 +1019,8 @@ parse_option(int c, gnc_t gnc, void *clo
|
||||
@@ -1024,7 +1026,8 @@ parse_option(int c, gnc_t gnc, void *clo
|
||||
strcmp(token, "daemonise") == 0 ||
|
||||
strcmp(token, "skip-kernel-setup") == 0 ||
|
||||
strcmp(token, "ipv6-subtrees") == 0 ||
|
||||
@ -67,7 +67,7 @@
|
||||
int b;
|
||||
c = getbool(c, &b, gnc, closure);
|
||||
if(c < -1)
|
||||
@@ -1035,6 +1038,8 @@ parse_option(int c, gnc_t gnc, void *clo
|
||||
@@ -1042,6 +1045,8 @@ parse_option(int c, gnc_t gnc, void *clo
|
||||
has_ipv6_subtrees = b;
|
||||
else if(strcmp(token, "reflect-kernel-metric") == 0)
|
||||
reflect_kernel_metric = b;
|
||||
|
Loading…
Reference in New Issue
Block a user