mirror of
https://git.openwrt.org/feed/routing.git
synced 2025-01-09 04:07:48 +08:00
3e96c851a7
OpenWrt/packages removed AUTORELEASE treewide. Remove it also in the
routing feed.
This is just copied from [0] with modification to the sed cmd because it
was not working for the routing feed:
The following temporary change was made to the core:
diff --git a/rules.mk b/rules.mk
index 57d7995d4fa8..f16367de87a8 100644
--- a/rules.mk
+++ b/rules.mk
@@ -429,7 +429,7 @@ endef
abi_version_str = $(subst -,,$(subst _,,$(subst .,,$(1))))
COMMITCOUNT = $(if $(DUMP),0,$(call commitcount))
-AUTORELEASE = $(if $(DUMP),0,$(call commitcount,1))
+AUTORELEASE = $(if $(DUMP),0,$(shell sed -i "s/\$$(AUTORELEASE)/$(call commitcount,1)/" $(CURDIR)/Makefile))
all:
FORCE: ;
And this command used to fix affected packages:
for i in $(cd feeds/routing; git grep -l PKG_RELEASE:=.*AUTORELEASE | \
sed 's/\/Makefile$//';);
do
make package/$i/download
done
[0] - 0c10c224be
Signed-off-by: Nick Hainke <vincent@systemli.org>
51 lines
1.2 KiB
Makefile
51 lines
1.2 KiB
Makefile
# SPDX-License-Identifier: GPL-2.0-only
|
|
#
|
|
# Copyright (C) 2021 Nick Hainke <vincent@systemli.org>
|
|
#
|
|
|
|
include $(TOPDIR)/rules.mk
|
|
|
|
PKG_NAME:=naywatch
|
|
PKG_VERSION:=1
|
|
PKG_RELEASE:=7
|
|
|
|
PKG_MAINTAINER:=Nick Hainke <vincent@systemli.org>
|
|
PKG_LICENSE:=GPL-2.0-only
|
|
|
|
include $(INCLUDE_DIR)/package.mk
|
|
|
|
define Package/naywatch
|
|
SECTION:=utils
|
|
CATEGORY:=Utilities
|
|
TITLE:=Watchdog for IPv6 links
|
|
PKGARCH:=all
|
|
DEPENDS:=@IPV6 +owipcalc
|
|
endef
|
|
|
|
define Package/naywatch/description
|
|
Reboots or triggers watchdog if no link-local neighbor is available.
|
|
|
|
Important:
|
|
Be careful when you do a sysupgrade. Stop naywatch first, and make
|
|
sure procd took control again of the watchdog.
|
|
You can do this using 'ubus call system watchdog'. Status should be "running".
|
|
endef
|
|
|
|
define Package/naywatch/conffiles
|
|
/etc/config/naywatch
|
|
endef
|
|
|
|
define Build/Compile
|
|
endef
|
|
|
|
define Package/naywatch/install
|
|
$(INSTALL_DIR) $(1)/etc/init.d
|
|
$(INSTALL_BIN) ./files/naywatch.init $(1)/etc/init.d/naywatch
|
|
$(INSTALL_DIR) $(1)/usr/bin
|
|
$(INSTALL_BIN) ./files/naywatch.sh $(1)/usr/bin/naywatch
|
|
$(INSTALL_DIR) $(1)/etc/config
|
|
$(INSTALL_DATA) ./files/naywatch.config $(1)/etc/config/naywatch
|
|
endef
|
|
|
|
$(eval $(call BuildPackage,naywatch))
|