Go to file
Nick Hainke 3e96c851a7 treewide: remove AUTORELEASE
OpenWrt/packages removed AUTORELEASE treewide. Remove it also in the
routing feed.

This is just copied from [0] with modification to the sed cmd because it
was not working for the routing feed:

The following temporary change was made to the core:

diff --git a/rules.mk b/rules.mk
index 57d7995d4fa8..f16367de87a8 100644
--- a/rules.mk
+++ b/rules.mk
@@ -429,7 +429,7 @@ endef
 abi_version_str = $(subst -,,$(subst _,,$(subst .,,$(1))))

 COMMITCOUNT = $(if $(DUMP),0,$(call commitcount))
-AUTORELEASE = $(if $(DUMP),0,$(call commitcount,1))
+AUTORELEASE = $(if $(DUMP),0,$(shell sed -i "s/\$$(AUTORELEASE)/$(call commitcount,1)/" $(CURDIR)/Makefile))

 all:
 FORCE: ;

And this command used to fix affected packages:

for i in $(cd feeds/routing; git grep -l PKG_RELEASE:=.*AUTORELEASE | \
                              sed 's/\/Makefile$//';);
do
  make package/$i/download
done

[0] - 0c10c224be

Signed-off-by: Nick Hainke <vincent@systemli.org>
2023-04-27 17:14:16 +02:00
.github ci: update github actions to v3 2023-02-23 00:55:48 +01:00
ahcpd
alfred treewide: remove AUTORELEASE 2023-04-27 17:14:16 +02:00
babel-pinger
babeld babeld: remove AUTORELEASE 2023-02-10 08:39:41 +01:00
batctl treewide: remove AUTORELEASE 2023-04-27 17:14:16 +02:00
batman-adv treewide: remove AUTORELEASE 2023-04-27 17:14:16 +02:00
batmand batmand: Refresh patches with quilt 2022-02-19 09:29:33 +01:00
bird1
bird1-openwrt bird1: fix "Form token mismatch" errors in luci-app-bird1-ipv{4,6} 2023-03-06 21:13:32 +01:00
bird2 bird2: bump to version 2.0.12 2023-02-21 12:57:06 +01:00
bmx6 treewide: remove AUTORELEASE 2023-04-27 17:14:16 +02:00
bmx7 bmx7: bump PKG_RELEASE for libiwinfo ABI change 2023-01-22 20:12:42 +01:00
cjdns cjdns: Fix dangling pointer bug (#964) 2023-04-18 15:14:08 +02:00
hnetd
luci-app-bmx6
luci-app-cjdns cjdns: support the supernodes feature (#884) 2022-06-20 21:31:44 +02:00
luci-app-olsrd2 luci-app-olsrd2: New Package for OLSR2 configuration and status visualisation' 2023-01-23 14:25:30 +01:00
mcproxy treewide: remove AUTORELEASE 2023-04-27 17:14:16 +02:00
mesh11sd treewide: remove AUTORELEASE 2023-04-27 17:14:16 +02:00
minimalist-pcproxy treewide: remove AUTORELEASE 2023-04-27 17:14:16 +02:00
naywatch treewide: remove AUTORELEASE 2023-04-27 17:14:16 +02:00
ndppd
nodogsplash nodogsplash: fix SPDX License Identifier and reordering 2022-03-03 08:55:53 +01:00
ohybridproxy ohybridproxy: revert to default log level 2021-11-19 07:06:50 +01:00
olsrd treewide: remove AUTORELEASE 2023-04-27 17:14:16 +02:00
oonf-dlep-proxy oonf-dlep-proxy: change to git version from 2022-08-25 2023-01-23 14:25:02 +01:00
oonf-dlep-radio oonf-dlep-radio: change to git version from 2022-08-25 2023-01-23 14:24:40 +01:00
oonf-init-scripts
oonf-olsrd2 oonf-olsrd2: update to current develop branch - fixes routing#899 2023-03-11 11:57:07 +01:00
opennds opennds: Release v9.10.0 2023-01-24 21:11:33 +01:00
pimbd treewide: remove AUTORELEASE 2023-04-27 17:14:16 +02:00
prince treewide: remove AUTORELEASE 2023-04-27 17:14:16 +02:00
quagga quagga: reorder things in Makefile 2022-02-26 15:37:24 +01:00
vis treewide: remove AUTORELEASE 2023-04-27 17:14:16 +02:00
MAINTAINERS
README.md README: update content and use Markdown 2021-06-11 23:00:30 +02:00

OpenWrt Routing Feed

Description

This OpenWrt package feed contains community maintained routing packages.

Usage

This repository is intended to be layered on-top of an OpenWrt buildroot. If you do not have an OpenWrt buildroot installed, see the documentation at: OpenWrt Buildroot Installation on the OpenWrt support site.

This feed is enabled by default. To install all its package definitions, run:

./scripts/feeds update routing
./scripts/feeds install -a -p routing