mirror of
https://git.openwrt.org/feed/routing.git
synced 2025-01-07 03:06:53 +08:00
3e96c851a7
OpenWrt/packages removed AUTORELEASE treewide. Remove it also in the
routing feed.
This is just copied from [0] with modification to the sed cmd because it
was not working for the routing feed:
The following temporary change was made to the core:
diff --git a/rules.mk b/rules.mk
index 57d7995d4fa8..f16367de87a8 100644
--- a/rules.mk
+++ b/rules.mk
@@ -429,7 +429,7 @@ endef
abi_version_str = $(subst -,,$(subst _,,$(subst .,,$(1))))
COMMITCOUNT = $(if $(DUMP),0,$(call commitcount))
-AUTORELEASE = $(if $(DUMP),0,$(call commitcount,1))
+AUTORELEASE = $(if $(DUMP),0,$(shell sed -i "s/\$$(AUTORELEASE)/$(call commitcount,1)/" $(CURDIR)/Makefile))
all:
FORCE: ;
And this command used to fix affected packages:
for i in $(cd feeds/routing; git grep -l PKG_RELEASE:=.*AUTORELEASE | \
sed 's/\/Makefile$//';);
do
make package/$i/download
done
[0] -
|
||
---|---|---|
.github | ||
ahcpd | ||
alfred | ||
babel-pinger | ||
babeld | ||
batctl | ||
batman-adv | ||
batmand | ||
bird1 | ||
bird1-openwrt | ||
bird2 | ||
bmx6 | ||
bmx7 | ||
cjdns | ||
hnetd | ||
luci-app-bmx6 | ||
luci-app-cjdns | ||
luci-app-olsrd2 | ||
mcproxy | ||
mesh11sd | ||
minimalist-pcproxy | ||
naywatch | ||
ndppd | ||
nodogsplash | ||
ohybridproxy | ||
olsrd | ||
oonf-dlep-proxy | ||
oonf-dlep-radio | ||
oonf-init-scripts | ||
oonf-olsrd2 | ||
opennds | ||
pimbd | ||
prince | ||
quagga | ||
vis | ||
MAINTAINERS | ||
README.md |
OpenWrt Routing Feed
Description
This OpenWrt package feed contains community maintained routing packages.
Usage
This repository is intended to be layered on-top of an OpenWrt buildroot. If you do not have an OpenWrt buildroot installed, see the documentation at: OpenWrt Buildroot – Installation on the OpenWrt support site.
This feed is enabled by default. To install all its package definitions, run:
./scripts/feeds update routing
./scripts/feeds install -a -p routing