rtpproxy: add build fix

- add upstream build fix related to libsrtp version bump
- switch to $(AUTORELEASE)
- refresh patch

Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
This commit is contained in:
Sebastian Kemper 2021-11-28 18:18:13 +01:00
parent 7e8ee8ac26
commit 10b7fcd4d1
3 changed files with 24 additions and 3 deletions

View File

@ -14,7 +14,7 @@ PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/sippy/rtpproxy.git
PKG_SOURCE_DATE=2019-10-02
PKG_SOURCE_VERSION:=aa1f179e09097f467bc4726e3300014c1e35246f
PKG_RELEASE:=2
PKG_RELEASE:=$(AUTORELEASE)
PKG_MIRROR_HASH:=7acc5f5bf2d4be23e9a2fad0c4e7576f172191c9f1b37104aee4d05dbdcac8fd
PKG_BUILD_PARALLEL:=1

View File

@ -39,8 +39,6 @@ Date: Thu Oct 3 19:58:08 2019 +0200
Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
diff --git a/configure.ac b/configure.ac
index 6e680c63..fe3216b6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -140,22 +140,22 @@ then

View File

@ -0,0 +1,23 @@
From f6c1f9e5924246216a05c295f450989ad9c80104 Mon Sep 17 00:00:00 2001
From: Maksym Sobolyev <sobomax@sippysoft.com>
Date: Thu, 13 May 2021 11:42:29 -0700
Subject: [PATCH] Resolve build breakage after ekt member of the policy struct
has been deprecated by the libsrtp. We have not been using that member to do
anything meaningful anyhow and the struct is inied to \0, so it should have
no adverse effect.
---
extractaudio/eaud_crypto.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
--- a/extractaudio/eaud_crypto.c
+++ b/extractaudio/eaud_crypto.c
@@ -153,7 +153,7 @@ eaud_crypto_getopt_parse(char *optarg)
srtp_crypto_policy_set_rtp_default(&rval->policy.rtp);
srtp_crypto_policy_set_rtcp_default(&rval->policy.rtcp);
rval->policy.key = (uint8_t *)rval->key;
- rval->policy.ekt = NULL; rval->policy.next = NULL;
+ rval->policy.next = NULL;
rval->policy.window_size = 128;
rval->policy.allow_repeat_tx = 0;
rval->policy.rtp.auth_tag_len = suite->tag_size;