mirror of
https://git.openwrt.org/feed/telephony.git
synced 2025-01-09 04:09:47 +08:00
kamailio: bump to release 5.7.2
Bump kamailio to release 5.7.2 to make it easier to backport PCRE2 patches. Drop upstream patch related to time_t and python3 fixes. Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
This commit is contained in:
parent
ceb721c048
commit
231910de5f
@ -9,12 +9,12 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=kamailio
|
||||
PKG_VERSION:=5.6.2
|
||||
PKG_RELEASE:=5
|
||||
PKG_VERSION:=5.7.2
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE_URL:=https://www.kamailio.org/pub/kamailio/$(PKG_VERSION)/src
|
||||
PKG_SOURCE:=kamailio-$(PKG_VERSION)_src.tar.gz
|
||||
PKG_HASH:=ea3cd5d688c34208b92072c3844c8276b693e0ca2c688168ea0357978c76b32d
|
||||
PKG_HASH:=72c9a067da8d6fa920d3737d98cd7f66c321f80cbe1076e2d5a392b422503122
|
||||
PKG_BUILD_FLAGS:=no-mips16
|
||||
|
||||
PKG_LICENSE:=GPL-2.0+
|
||||
|
@ -1,8 +1,8 @@
|
||||
--- a/utils/kamctl/kamctlrc
|
||||
+++ b/utils/kamctl/kamctlrc
|
||||
@@ -162,3 +162,6 @@
|
||||
@@ -166,3 +166,6 @@
|
||||
## Extra start options - default is: not set
|
||||
## example: start Kamailio with 64MB share memory: STARTOPTIONS="-m 64"
|
||||
## example: start Kamailio with 64MB shared memory: STARTOPTIONS="-m 64"
|
||||
# STARTOPTIONS=
|
||||
+
|
||||
+# Disable colour printing in terminal
|
||||
|
@ -1,49 +0,0 @@
|
||||
From f32e1d9c96f6ba9df3c27178c689ccd27eabaafc Mon Sep 17 00:00:00 2001
|
||||
From: Sebastian Kemper <sebastian_ml@gmx.net>
|
||||
Date: Sun, 16 Oct 2022 16:51:41 +0200
|
||||
Subject: [PATCH] siputils: fix time_t warning and a typo
|
||||
|
||||
Fix the below warning one gets when compiling siputils for a 32 bit
|
||||
target against a time64 libc (musl).
|
||||
|
||||
Also fix a spelling mistake on the same line ("autdated" -> "outdated").
|
||||
|
||||
siputils.c: In function 'ki_hdr_date_check':
|
||||
../../core/parser/../dprint.h:321:73: warning: format '%ld' expects argument of type 'long int', but argument 11 has type 'time_t' {aka 'long long int'} [-Wformat=]
|
||||
321 | fprintf(stderr, "%2d(%d) %s: %.*s%s%s%s" fmt, \
|
||||
| ^~~~~~~~~~~~~~~~~~~~~~~~
|
||||
../../core/parser/../dprint.h:345:25: note: in expansion of macro 'LOG_FX'
|
||||
345 | LOG_FX(facility, level, lname, prefix, _FUNC_NAME_, fmt, ## args)
|
||||
| ^~~~~~
|
||||
../../core/parser/../dprint.h:351:25: note: in expansion of macro 'LOG_FL'
|
||||
351 | LOG_FL(facility, level, NULL, prefix, fmt, ## args)
|
||||
| ^~~~~~
|
||||
../../core/parser/../dprint.h:354:25: note: in expansion of macro 'LOG_FP'
|
||||
354 | LOG_FP(DEFAULT_FACILITY, (level), LOC_INFO, fmt, ## args)
|
||||
| ^~~~~~
|
||||
../../core/parser/../dprint.h:392:37: note: in expansion of macro 'LOG'
|
||||
392 | # define ERR(fmt, args...) LOG(L_ERR, fmt , ## args)
|
||||
| ^~~
|
||||
../../core/parser/../dprint.h:418:16: note: in expansion of macro 'ERR'
|
||||
418 | #define LM_ERR ERR
|
||||
| ^~~
|
||||
siputils.c:562:17: note: in expansion of macro 'LM_ERR'
|
||||
562 | LM_ERR("autdated date header value (%ld sec)\n", tnow - tmsg + tdiff);
|
||||
| ^~~~~~
|
||||
|
||||
Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
|
||||
---
|
||||
src/modules/siputils/siputils.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
--- a/src/modules/siputils/siputils.c
|
||||
+++ b/src/modules/siputils/siputils.c
|
||||
@@ -559,7 +559,7 @@ static int ki_hdr_date_check(sip_msg_t*
|
||||
}
|
||||
|
||||
if (tnow > tmsg + tdiff) {
|
||||
- LM_ERR("autdated date header value (%ld sec)\n", tnow - tmsg + tdiff);
|
||||
+ LM_ERR("outdated date header value (%" TIME_T_FMT " sec)\n", TIME_T_CAST(tnow - tmsg + tdiff));
|
||||
return -4;
|
||||
} else {
|
||||
LM_ERR("Date header value OK\n");
|
@ -1,60 +0,0 @@
|
||||
From b8bf86eb11a17c853450e5c7f81d2446cf719fbc Mon Sep 17 00:00:00 2001
|
||||
From: Daniel-Constantin Mierla <miconda@gmail.com>
|
||||
Date: Thu, 21 Jul 2022 20:15:29 +0200
|
||||
Subject: [PATCH] app_python3: use new Python 3.10+ API functions for tracking
|
||||
execution
|
||||
|
||||
- GH #3187
|
||||
---
|
||||
src/modules/app_python3/apy_kemi.c | 23 ++++++++++++++++++++++-
|
||||
1 file changed, 22 insertions(+), 1 deletion(-)
|
||||
|
||||
--- a/src/modules/app_python3/apy_kemi.c
|
||||
+++ b/src/modules/app_python3/apy_kemi.c
|
||||
@@ -1810,6 +1810,9 @@ PyObject *sr_apy_kemi_exec_func(PyObject
|
||||
PyObject *ret = NULL;
|
||||
PyThreadState *pstate = NULL;
|
||||
PyFrameObject *pframe = NULL;
|
||||
+#if PY_VERSION_HEX >= 0x03100000
|
||||
+ PyCodeObject *pcode = NULL;
|
||||
+#endif
|
||||
struct timeval tvb = {0}, tve = {0};
|
||||
struct timezone tz;
|
||||
unsigned int tdiff;
|
||||
@@ -1832,10 +1835,27 @@ PyObject *sr_apy_kemi_exec_func(PyObject
|
||||
+ (tve.tv_usec - tvb.tv_usec);
|
||||
if(tdiff >= cfg_get(core, core_cfg, latency_limit_action)) {
|
||||
pstate = PyThreadState_GET();
|
||||
- if (pstate != NULL && pstate->frame != NULL) {
|
||||
+ if (pstate != NULL) {
|
||||
+#if PY_VERSION_HEX >= 0x03100000
|
||||
+ pframe = PyThreadState_GetFrame(pstate);
|
||||
+ if(pframe != NULL) {
|
||||
+ pcode = PyFrame_GetCode(pframe);
|
||||
+ }
|
||||
+#else
|
||||
pframe = pstate->frame;
|
||||
+#endif
|
||||
}
|
||||
|
||||
+#if PY_VERSION_HEX >= 0x03100000
|
||||
+ LOG(cfg_get(core, core_cfg, latency_log),
|
||||
+ "alert - action KSR.%s%s%s(...)"
|
||||
+ " took too long [%u ms] (file:%s func:%s line:%d)\n",
|
||||
+ (ket->mname.len>0)?ket->mname.s:"",
|
||||
+ (ket->mname.len>0)?".":"", ket->fname.s, tdiff,
|
||||
+ (pcode)?PyBytes_AsString(pcode->co_filename):"",
|
||||
+ (pcode)?PyBytes_AsString(pcode->co_name):"",
|
||||
+ (pframe)?PyFrame_GetLineNumber(pframe):0);
|
||||
+#else
|
||||
LOG(cfg_get(core, core_cfg, latency_log),
|
||||
"alert - action KSR.%s%s%s(...)"
|
||||
" took too long [%u ms] (file:%s func:%s line:%d)\n",
|
||||
@@ -1844,6 +1864,7 @@ PyObject *sr_apy_kemi_exec_func(PyObject
|
||||
(pframe && pframe->f_code)?PyBytes_AsString(pframe->f_code->co_filename):"",
|
||||
(pframe && pframe->f_code)?PyBytes_AsString(pframe->f_code->co_name):"",
|
||||
(pframe && pframe->f_code)?PyCode_Addr2Line(pframe->f_code, pframe->f_lasti):0);
|
||||
+#endif
|
||||
}
|
||||
}
|
||||
|
@ -1,38 +0,0 @@
|
||||
From 8546fb87e3277b675bd47eba9435f739cf3bb69d Mon Sep 17 00:00:00 2001
|
||||
From: Daniel-Constantin Mierla <miconda@gmail.com>
|
||||
Date: Fri, 13 Jan 2023 12:33:20 +0100
|
||||
Subject: [PATCH] app_python3: proper check of PY_VERSION_HEX for python 3.11
|
||||
|
||||
---
|
||||
src/modules/app_python3/apy_kemi.c | 6 +++---
|
||||
1 file changed, 3 insertions(+), 3 deletions(-)
|
||||
|
||||
--- a/src/modules/app_python3/apy_kemi.c
|
||||
+++ b/src/modules/app_python3/apy_kemi.c
|
||||
@@ -1810,7 +1810,7 @@ PyObject *sr_apy_kemi_exec_func(PyObject
|
||||
PyObject *ret = NULL;
|
||||
PyThreadState *pstate = NULL;
|
||||
PyFrameObject *pframe = NULL;
|
||||
-#if PY_VERSION_HEX >= 0x03100000
|
||||
+#if PY_VERSION_HEX >= 0x030B0000
|
||||
PyCodeObject *pcode = NULL;
|
||||
#endif
|
||||
struct timeval tvb = {0}, tve = {0};
|
||||
@@ -1836,7 +1836,7 @@ PyObject *sr_apy_kemi_exec_func(PyObject
|
||||
if(tdiff >= cfg_get(core, core_cfg, latency_limit_action)) {
|
||||
pstate = PyThreadState_GET();
|
||||
if (pstate != NULL) {
|
||||
-#if PY_VERSION_HEX >= 0x03100000
|
||||
+#if PY_VERSION_HEX >= 0x030B0000
|
||||
pframe = PyThreadState_GetFrame(pstate);
|
||||
if(pframe != NULL) {
|
||||
pcode = PyFrame_GetCode(pframe);
|
||||
@@ -1846,7 +1846,7 @@ PyObject *sr_apy_kemi_exec_func(PyObject
|
||||
#endif
|
||||
}
|
||||
|
||||
-#if PY_VERSION_HEX >= 0x03100000
|
||||
+#if PY_VERSION_HEX >= 0x030B0000
|
||||
LOG(cfg_get(core, core_cfg, latency_log),
|
||||
"alert - action KSR.%s%s%s(...)"
|
||||
" took too long [%u ms] (file:%s func:%s line:%d)\n",
|
@ -1,23 +0,0 @@
|
||||
From fc75b4c3f8f9bdba320f74ddf942686c09316b56 Mon Sep 17 00:00:00 2001
|
||||
From: Daniel-Constantin Mierla <miconda@gmail.com>
|
||||
Date: Fri, 13 Jan 2023 12:41:12 +0100
|
||||
Subject: [PATCH] app_python3: use Py_SET_TYPE() from python 3.9
|
||||
|
||||
---
|
||||
src/modules/app_python3/python_msgobj.c | 4 ++++
|
||||
1 file changed, 4 insertions(+)
|
||||
|
||||
--- a/src/modules/app_python3/python_msgobj.c
|
||||
+++ b/src/modules/app_python3/python_msgobj.c
|
||||
@@ -507,7 +507,11 @@ static PyTypeObject MSGtype = {
|
||||
|
||||
int python_msgobj_init(void)
|
||||
{
|
||||
+#if PY_VERSION_HEX >= 0x03090000
|
||||
+ Py_SET_TYPE(&MSGtype, &PyType_Type);
|
||||
+#else
|
||||
Py_TYPE(&MSGtype) = &PyType_Type;
|
||||
+#endif
|
||||
if (PyType_Ready(&MSGtype) < 0)
|
||||
return -1;
|
||||
return 0;
|
Loading…
Reference in New Issue
Block a user