Merge pull request #876 from muzikr/baresip-fix-parallel-build

[22.03] baresip: fix init script and parallel build
This commit is contained in:
micmac1 2024-07-02 09:38:24 +02:00 committed by GitHub
commit 2a69b3a6f0
No known key found for this signature in database
GPG Key ID: B5690EEEBB952194
3 changed files with 25 additions and 2 deletions

View File

@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=baresip
PKG_VERSION:=1.1.0
PKG_RELEASE:=$(AUTORELEASE)
PKG_RELEASE:=6
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/baresip/baresip/tar.gz/v$(PKG_VERSION)?

View File

@ -21,7 +21,7 @@ start_service() {
if [ "$ENABLE_BARESIP" != yes ]; then
$LOGGER User configuration incomplete - not starting $DAEMON
$LOGGER Check ENABLE_BARESIP in $DEFAULT
exit 1
return 1
fi
procd_open_instance

View File

@ -0,0 +1,23 @@
From d7aeb9393876af3746dacdbacd70c4a5d6dfcf39 Mon Sep 17 00:00:00 2001
From: Christian Spielberger <c.spielberger@commend.com>
Date: Sun, 23 May 2021 10:01:04 +0200
Subject: [PATCH] ctrl_dbus: add dependency to baresipbus.h (#1447) (#1457)
---
modules/ctrl_dbus/module.mk | 5 ++++-
1 file changed, 4 insertions(+), 1 deletion(-)
--- a/modules/ctrl_dbus/module.mk
+++ b/modules/ctrl_dbus/module.mk
@@ -16,7 +16,10 @@ $(MOD)_CFLAGS += -Wno-unused-parameter -
$(MOD)_CCHECK_OPT = -e baresipbus.h -e baresipbus.c
-modules/ctrl_dbus/baresipbus.h modules/ctrl_dbus/baresipbus.c: \
+modules/$(MOD)/baresipbus.o : modules/$(MOD)/baresipbus.h
+modules/$(MOD)/ctrl_dbus.o : modules/$(MOD)/baresipbus.h
+
+modules/$(MOD)/baresipbus.h modules/$(MOD)/baresipbus.c: \
modules/ctrl_dbus/com.github.Baresip.xml
@cd $(dir $@) && ./gen.sh