bcg729: update to v1.1.1

The removed patch has been merged upstream.

Signed-off-by: Andre Heider <a.heider@gmail.com>
This commit is contained in:
Andre Heider 2021-03-22 15:27:36 +01:00
parent 41a4c15eee
commit 4e34b4b0a5
2 changed files with 8 additions and 37 deletions

View File

@ -8,18 +8,19 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=bcg729
PKG_VERSION:=1.0.4
PKG_RELEASE:=4
PKG_VERSION:=1.1.1
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://www.linphone.org/releases/sources/bcg729
PKG_HASH:=1a0fbf1ff91470037e83fa67976f940ebb601e4cc525859c754f4e7ffc24c307
PKG_SOURCE_URL_FILE:=$(PKG_VERSION).tar.gz
PKG_SOURCE:=$(PKG_NAME)-$(PKG_SOURCE_URL_FILE)
PKG_SOURCE_URL:=https://github.com/BelledonneCommunications/$(PKG_NAME)/archive
PKG_HASH:=68599a850535d1b182932b3f86558ac8a76d4b899a548183b062956c5fdc916d
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
CMAKE_INSTALL:=1
PKG_LICENSE:=GPL-2.0+
PKG_LICENSE_FILES:=COPYING
PKG_LICENSE:=GPL-3.0-or-later
PKG_LICENSE_FILES:=LICENSE.txt
PKG_MAINTAINER:=Alex Samorukov <samm@os2.kiev.ua>
include $(INCLUDE_DIR)/package.mk

View File

@ -1,30 +0,0 @@
commit a5907daf1b111e4ad7aab4f558f57e2af1e37e55
Author: Peter Wu <peter@lekensteyn.nl>
Date: Mon Feb 4 13:08:10 2019 +0100
CMake: install pkg-config files for parity with autotools
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a271876..e1496a7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -92,6 +92,19 @@ configure_file(Bcg729Config.cmake.in
@ONLY
)
+set(prefix "${CMAKE_INSTALL_PREFIX}")
+set(exec_prefix "\${prefix}")
+set(includedir "\${prefix}/include")
+set(libdir "\${exec_prefix}/${CMAKE_INSTALL_LIBDIR}")
+configure_file(libbcg729.pc.in
+ "${CMAKE_CURRENT_BINARY_DIR}/libbcg729.pc"
+ @ONLY
+)
+install(FILES
+ "${CMAKE_CURRENT_BINARY_DIR}/libbcg729.pc"
+ DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig
+)
+
set(CONFIG_PACKAGE_LOCATION "${CMAKE_INSTALL_DATADIR}/Bcg729/cmake")
install(EXPORT Bcg729Targets
FILE Bcg729Targets.cmake