mirror of
https://git.openwrt.org/feed/telephony.git
synced 2025-01-08 11:47:32 +08:00
freeswitch: add patch moving package to PCRE2
Add pending patch moving package to PCRE2 as PCRE is EOL and won't receive any updates anymore. These patch were run uder the freeswitch CI and were validated with their unit tests. Signed-off-by: Christian Marangi <ansuelsmth@gmail.com> [fix conflict, fix typo in commit message, remove @BROKEN dep, refresh patches] Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
This commit is contained in:
parent
7f4fa9e791
commit
75acd1cdc2
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=freeswitch
|
||||
PKG_VERSION:=1.10.12
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
PKG_MAINTAINER:=Sebastian Kemper <sebastian_ml@gmx.net>
|
||||
|
||||
PKG_SOURCE:=freeswitch-$(PKG_VERSION).-release.tar.xz
|
||||
@ -308,7 +308,6 @@ $(call Package/freeswitch/Default)
|
||||
MENU:=1
|
||||
USERID:=freeswitch=372:freeswitch=372
|
||||
DEPENDS:= \
|
||||
@BROKEN \
|
||||
$(ICONV_DEPENDS) \
|
||||
+libstdcpp \
|
||||
+!BUSYBOX_DEFAULT_SU:shadow-utils \
|
||||
@ -320,7 +319,7 @@ $(call Package/freeswitch/Default)
|
||||
+libcurl \
|
||||
+libedit \
|
||||
+libopenssl \
|
||||
+libpcre \
|
||||
+libpcre2 \
|
||||
+libpthread \
|
||||
+librt \
|
||||
+libspandsp3 \
|
||||
|
@ -0,0 +1,28 @@
|
||||
From 2a4c882464b792ac827c98b5d09e5a89b471a75a Mon Sep 17 00:00:00 2001
|
||||
From: Christian Marangi <ansuelsmth@gmail.com>
|
||||
Date: Fri, 3 Nov 2023 17:27:06 +0100
|
||||
Subject: [PATCH 1/3] [mod_verto] Fix memory leak by correctly freeing regex
|
||||
|
||||
For mod_verto regex was never freed and was actually leaking memory.
|
||||
Correctly free the compiled regex to fix the memory leak.
|
||||
|
||||
Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
|
||||
---
|
||||
src/mod/endpoints/mod_verto/mod_verto.c | 2 ++
|
||||
1 file changed, 2 insertions(+)
|
||||
|
||||
--- a/src/mod/endpoints/mod_verto/mod_verto.c
|
||||
+++ b/src/mod/endpoints/mod_verto/mod_verto.c
|
||||
@@ -1893,10 +1893,12 @@ authed:
|
||||
switch_log_printf(SWITCH_CHANNEL_LOG, SWITCH_LOG_DEBUG,
|
||||
"%d request [%s] matched expr [%s]\n", proceed, request->uri, expression);
|
||||
request->uri = rule->value;
|
||||
+ switch_regex_safe_free(re);
|
||||
break;
|
||||
}
|
||||
|
||||
rule = rule->next;
|
||||
+ switch_regex_safe_free(re);
|
||||
}
|
||||
}
|
||||
|
1806
net/freeswitch/patches/900-Core-Move-project-to-PCRE2.patch
Normal file
1806
net/freeswitch/patches/900-Core-Move-project-to-PCRE2.patch
Normal file
File diff suppressed because it is too large
Load Diff
Loading…
Reference in New Issue
Block a user