dahdi-tools: fix compilation with musl 1.2.x

Missing header.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
Rosen Penev 2021-07-08 17:11:03 -07:00
parent 621352af15
commit 972350e2ea
2 changed files with 11 additions and 1 deletions

View File

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=dahdi-tools
PKG_VERSION:=3.1.0
PKG_RELEASE:=2
PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://downloads.asterisk.org/pub/telephony/dahdi-tools/releases

View File

@ -0,0 +1,10 @@
--- a/xpp/hexfile.h
+++ b/xpp/hexfile.h
@@ -26,6 +26,7 @@
#include <stdarg.h>
#include <stdio.h>
#include <stdint.h>
+#include <sys/cdefs.h>
#include <sys/param.h>
#include <syslog.h>
#define PACKED __attribute__((packed))