mirror of
https://git.openwrt.org/feed/telephony.git
synced 2025-01-08 11:47:32 +08:00
Merge pull request #888 from dddaniel/master
baresip: Update to version 3.16.0 [v2]
This commit is contained in:
commit
a99df6e46f
@ -5,16 +5,15 @@
|
|||||||
# This is free software, licensed under the GNU General Public License v2.
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
# See /LICENSE for more information.
|
# See /LICENSE for more information.
|
||||||
#
|
#
|
||||||
|
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=re
|
PKG_NAME:=re
|
||||||
PKG_VERSION:=2.0.1
|
PKG_VERSION:=3.16.0
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=https://codeload.github.com/baresip/re/tar.gz/v$(PKG_VERSION)?
|
PKG_SOURCE_URL:=https://codeload.github.com/baresip/re/tar.gz/v$(PKG_VERSION)?
|
||||||
PKG_HASH:=43aa439b96aff75fe5768b9f9d49dea97042e42e7647df47b345465763e2f7ed
|
PKG_HASH:=11b3215064b6ef5a11b0f4645d6d4834f8ba899d5b65c66477f9c4afbd32e1ed
|
||||||
|
|
||||||
PKG_LICENSE:=BSD-3-Clause
|
PKG_LICENSE:=BSD-3-Clause
|
||||||
PKG_LICENSE_FILES:=docs/COPYING
|
PKG_LICENSE_FILES:=docs/COPYING
|
||||||
@ -24,6 +23,7 @@ PKG_BUILD_PARALLEL:=1
|
|||||||
PKG_INSTALL:=1
|
PKG_INSTALL:=1
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
include $(INCLUDE_DIR)/cmake.mk
|
||||||
|
|
||||||
define Package/libre
|
define Package/libre
|
||||||
SUBMENU:=Telephony
|
SUBMENU:=Telephony
|
||||||
@ -32,49 +32,17 @@ define Package/libre
|
|||||||
DEPENDS:=+libopenssl +zlib
|
DEPENDS:=+libopenssl +zlib
|
||||||
TITLE:=Generic library for real-time communications with async IO support
|
TITLE:=Generic library for real-time communications with async IO support
|
||||||
URL:=https://github.com/baresip/re
|
URL:=https://github.com/baresip/re
|
||||||
ABI_VERSION:=1
|
ABI_VERSION:=2
|
||||||
endef
|
endef
|
||||||
|
|
||||||
# re.mk is used for this and all related packages (rem, restund and baresip).
|
|
||||||
# It relies on SYSROOT and SYSROOT_ALT being set. SYSROOT is used for finding
|
|
||||||
# toolchain headers (like pthread.h). SYSROOT_ALT is used for finding headers
|
|
||||||
# from other packages, like openssl etc.
|
|
||||||
#
|
|
||||||
# CFLAGS are picked up from the environment, as well as CPPFLAGS (and LD etc.).
|
|
||||||
# But LDFLAGS aren't picked up, so they need to be handed over via
|
|
||||||
# EXTRA_LFLAGS.
|
|
||||||
#
|
|
||||||
# LD is changed to TARGET_CC to fix build failures on x86 32bit. Without this
|
|
||||||
# there's no linking to ssp, which results in undefined references.
|
|
||||||
|
|
||||||
# used by 001-extend-ninit-nclose-check.patch
|
|
||||||
TARGET_CFLAGS+=-DOPENWRT
|
|
||||||
|
|
||||||
ifneq ($(CONFIG_USE_GLIBC)$(CONFIG_USE_MUSL),)
|
|
||||||
TARGET_CFLAGS+=-D_GNU_SOURCE
|
|
||||||
endif
|
|
||||||
|
|
||||||
MAKE_FLAGS+= \
|
|
||||||
CROSS_COMPILE="$(TARGET_CROSS)" \
|
|
||||||
EXTRA_LFLAGS="$(TARGET_LDFLAGS)" \
|
|
||||||
LD="$(TARGET_CC)" \
|
|
||||||
OS=linux \
|
|
||||||
RELEASE=1 \
|
|
||||||
SYSROOT="$(shell $(FIND) $(TOOLCHAIN_DIR) -path '*/include/pthread.h' | sed -ne '1s|/include/pthread.h||p')" \
|
|
||||||
SYSROOT_ALT="$(STAGING_DIR)/usr"
|
|
||||||
|
|
||||||
define Build/InstallDev
|
define Build/InstallDev
|
||||||
$(INSTALL_DIR) $(1)/usr/share/re
|
$(INSTALL_DIR) $(1)/usr
|
||||||
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/re/re.mk $(1)/usr/share/re
|
$(CP) $(PKG_INSTALL_DIR)/usr/* $(1)/usr
|
||||||
$(INSTALL_DIR) $(1)/usr/include
|
|
||||||
$(CP) $(PKG_INSTALL_DIR)/usr/include/re $(1)/usr/include
|
|
||||||
$(INSTALL_DIR) $(1)/usr/lib
|
|
||||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libre.{a,so*} $(1)/usr/lib
|
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/libre/install
|
define Package/libre/install
|
||||||
$(INSTALL_DIR) $(1)/usr/lib
|
$(INSTALL_DIR) $(1)/usr/lib
|
||||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libre.so.$(ABI_VERSION)* $(1)/usr/lib
|
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libre.so.* $(1)/usr/lib
|
||||||
endef
|
endef
|
||||||
|
|
||||||
$(eval $(call BuildPackage,libre))
|
$(eval $(call BuildPackage,libre))
|
||||||
|
@ -1,20 +0,0 @@
|
|||||||
--- a/src/dns/res.c
|
|
||||||
+++ b/src/dns/res.c
|
|
||||||
@@ -26,7 +26,7 @@ int get_resolv_dns(char *domain, size_t
|
|
||||||
uint32_t i;
|
|
||||||
int ret, err;
|
|
||||||
|
|
||||||
-#ifdef OPENBSD
|
|
||||||
+#if defined(OPENBSD) || defined(OPENWRT)
|
|
||||||
ret = res_init();
|
|
||||||
state = _res;
|
|
||||||
#else
|
|
||||||
@@ -76,7 +76,7 @@ int get_resolv_dns(char *domain, size_t
|
|
||||||
*n = i;
|
|
||||||
|
|
||||||
out:
|
|
||||||
-#ifdef OPENBSD
|
|
||||||
+#if defined(OPENBSD) || defined(OPENWRT)
|
|
||||||
#else
|
|
||||||
res_nclose(&state);
|
|
||||||
#endif
|
|
@ -1,11 +0,0 @@
|
|||||||
--- a/include/re_types.h
|
|
||||||
+++ b/include/re_types.h
|
|
||||||
@@ -47,7 +47,7 @@ typedef unsigned long long int uint64
|
|
||||||
#endif /* __BIT_TYPES_DEFINED__ */
|
|
||||||
|
|
||||||
#endif /* __int8_t_defined */
|
|
||||||
-#ifndef __ssize_t_defined
|
|
||||||
+#if !defined(__ssize_t_defined) && !defined(__DEFINED_ssize_t)
|
|
||||||
typedef long ssize_t;
|
|
||||||
#define __ssize_t_defined
|
|
||||||
#endif
|
|
@ -1,10 +0,0 @@
|
|||||||
--- a/mk/re.mk
|
|
||||||
+++ b/mk/re.mk
|
|
||||||
@@ -47,7 +47,6 @@
|
|
||||||
|
|
||||||
ifneq ($(RELEASE),)
|
|
||||||
CFLAGS += -DRELEASE
|
|
||||||
-OPT_SPEED=1
|
|
||||||
endif
|
|
||||||
|
|
||||||
ifneq ($(TRACE_ERR),)
|
|
@ -1,14 +0,0 @@
|
|||||||
--- a/mk/re.mk
|
|
||||||
+++ b/mk/re.mk
|
|
||||||
@@ -412,11 +412,6 @@ endif
|
|
||||||
|
|
||||||
CFLAGS += -DARCH=\"$(ARCH)\"
|
|
||||||
|
|
||||||
-ifeq ($(ARCH),mipsel)
|
|
||||||
-CFLAGS += -march=mips32
|
|
||||||
-endif
|
|
||||||
-
|
|
||||||
-
|
|
||||||
##############################################################################
|
|
||||||
#
|
|
||||||
# External libraries section
|
|
@ -1,61 +0,0 @@
|
|||||||
#
|
|
||||||
# Copyright (C) 2010-2017 OpenWrt.org
|
|
||||||
# Copyright (C) 2010 Alfred E. Heggestad
|
|
||||||
#
|
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
|
||||||
# See /LICENSE for more information.
|
|
||||||
#
|
|
||||||
|
|
||||||
include $(TOPDIR)/rules.mk
|
|
||||||
|
|
||||||
PKG_NAME:=rem
|
|
||||||
PKG_VERSION:=1.0.0
|
|
||||||
PKG_RELEASE:=1
|
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
|
||||||
PKG_SOURCE_URL:=https://codeload.github.com/baresip/rem/tar.gz/v$(PKG_VERSION)?
|
|
||||||
PKG_HASH:=bcc91bb521fae183357fb422b00a3981477a22e99d3afe165c4ec50a6bbed9da
|
|
||||||
|
|
||||||
PKG_LICENSE:=BSD-3-Clause
|
|
||||||
PKG_LICENSE_FILES:=docs/COPYING
|
|
||||||
PKG_MAINTAINER:=Jiri Slachta <jiri@slachta.eu>
|
|
||||||
|
|
||||||
PKG_BUILD_PARALLEL:=1
|
|
||||||
PKG_INSTALL:=1
|
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
|
||||||
|
|
||||||
define Package/librem
|
|
||||||
SUBMENU:=Telephony
|
|
||||||
SECTION:=libs
|
|
||||||
CATEGORY:=Libraries
|
|
||||||
DEPENDS:=+libre
|
|
||||||
TITLE:=Audio and video processing media library
|
|
||||||
URL:=https://github.com/baresip/rem
|
|
||||||
endef
|
|
||||||
|
|
||||||
MAKE_FLAGS+= \
|
|
||||||
CROSS_COMPILE="$(TARGET_CROSS)" \
|
|
||||||
EXTRA_LFLAGS="$(TARGET_LDFLAGS)" \
|
|
||||||
LD="$(TARGET_CC)" \
|
|
||||||
LIBRE_MK="$(STAGING_DIR)/usr/share/re/re.mk" \
|
|
||||||
LIBRE_INC="$(STAGING_DIR)/usr/include/re" \
|
|
||||||
LIBRE_SO="$(STAGING_DIR)/usr/lib" \
|
|
||||||
OS=linux \
|
|
||||||
RELEASE=1 \
|
|
||||||
SYSROOT="$(shell $(FIND) $(TOOLCHAIN_DIR) -path '*/include/pthread.h' | sed -ne '1s|/include/pthread.h||p')" \
|
|
||||||
SYSROOT_ALT="$(STAGING_DIR)/usr"
|
|
||||||
|
|
||||||
define Build/InstallDev
|
|
||||||
$(INSTALL_DIR) $(1)/usr/include
|
|
||||||
$(CP) $(PKG_INSTALL_DIR)/usr/include/rem $(1)/usr/include
|
|
||||||
$(INSTALL_DIR) $(1)/usr/lib
|
|
||||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/librem.{a,so} $(1)/usr/lib
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/librem/install
|
|
||||||
$(INSTALL_DIR) $(1)/usr/lib
|
|
||||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/librem.so $(1)/usr/lib
|
|
||||||
endef
|
|
||||||
|
|
||||||
$(eval $(call BuildPackage,librem))
|
|
71
net/baresip-apps/Makefile
Normal file
71
net/baresip-apps/Makefile
Normal file
@ -0,0 +1,71 @@
|
|||||||
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
|
PKG_NAME:=baresip-apps
|
||||||
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
|
PKG_SOURCE_PROTO:=git
|
||||||
|
PKG_SOURCE_URL:=https://github.com/baresip/baresip-apps.git
|
||||||
|
PKG_SOURCE_VERSION:=0b25d61247f3e8d15071b09223e35f8806dacad8
|
||||||
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_SOURCE_VERSION).tar.gz
|
||||||
|
PKG_MIRROR_HASH:=35599fa7d081640a86a0ae91e1b46209fa1ddd41295332948ec29fa5a15c2b65
|
||||||
|
|
||||||
|
PKG_LICENSE:=BSD-3-Clause
|
||||||
|
PKG_LICENSE_FILES:=docs/COPYING
|
||||||
|
PKG_MAINTAINER:=Daniel Danzberger <dd@embedd.com>
|
||||||
|
|
||||||
|
PKG_BUILD_PARALLEL:=1
|
||||||
|
PKG_INSTALL:=1
|
||||||
|
|
||||||
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
include $(INCLUDE_DIR)/cmake.mk
|
||||||
|
|
||||||
|
define Package/baresip-app/Default
|
||||||
|
SECTION:=net
|
||||||
|
CATEGORY:=Network
|
||||||
|
SUBMENU:=Telephony
|
||||||
|
URL:=https://github.com/baresip/baresip-apps
|
||||||
|
endef
|
||||||
|
|
||||||
|
baresip-apps:= \
|
||||||
|
auloop \
|
||||||
|
autotest \
|
||||||
|
b2bua \
|
||||||
|
intercom \
|
||||||
|
kaoptions \
|
||||||
|
multicast \
|
||||||
|
parcall \
|
||||||
|
qualify \
|
||||||
|
vidloop
|
||||||
|
|
||||||
|
empty:=
|
||||||
|
space:= $(empty) $(empty)
|
||||||
|
|
||||||
|
MODULES:=$(foreach m,$(baresip-apps),$(if $(CONFIG_PACKAGE_baresip-app-$(m)),$(m)))
|
||||||
|
MODULES:=$(strip $(MODULES))
|
||||||
|
MODULES:=$(subst $(space),;,$(MODULES))
|
||||||
|
|
||||||
|
CMAKE_OPTIONS += -DMODULES="$(MODULES)"
|
||||||
|
|
||||||
|
define BuildPlugin
|
||||||
|
define Package/baresip-app-$(1)
|
||||||
|
$$(call Package/baresip-app/Default)
|
||||||
|
TITLE:=$(2)
|
||||||
|
DEPENDS:=+baresip $(patsubst +%,+PACKAGE_$(PKG_NAME)-app-$(1):%,$(3))
|
||||||
|
endef
|
||||||
|
define Package/baresip-app-$(1)/install
|
||||||
|
$(INSTALL_DIR) $$(1)/usr/lib/baresip/modules
|
||||||
|
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/baresip/modules/$(1).so \
|
||||||
|
$$(1)/usr/lib/baresip/modules
|
||||||
|
endef
|
||||||
|
$$(eval $$(call BuildPackage,baresip-app-$(1)))
|
||||||
|
endef
|
||||||
|
|
||||||
|
$(eval $(call BuildPlugin,auloop,Audio Looping,))
|
||||||
|
$(eval $(call BuildPlugin,autotest,Auto Test Module,))
|
||||||
|
$(eval $(call BuildPlugin,b2bua,Back-to-Back User-Agent,))
|
||||||
|
$(eval $(call BuildPlugin,intercom,Intercom Module,))
|
||||||
|
$(eval $(call BuildPlugin,kaoptions,Keepalive via SIP OPTIONS message,))
|
||||||
|
$(eval $(call BuildPlugin,multicast,Mulitcast Support,))
|
||||||
|
$(eval $(call BuildPlugin,parcall,Parallel call module,))
|
||||||
|
$(eval $(call BuildPlugin,qualify,Pinging of peer in CALL_STATE_INCOMING via SIP OPTIONS,))
|
||||||
|
$(eval $(call BuildPlugin,vidloop,Video Loop,))
|
@ -5,16 +5,15 @@
|
|||||||
# This is free software, licensed under the GNU General Public License v2.
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
# See /LICENSE for more information.
|
# See /LICENSE for more information.
|
||||||
#
|
#
|
||||||
|
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=baresip
|
PKG_NAME:=baresip
|
||||||
PKG_VERSION:=1.1.0
|
PKG_VERSION:=3.16.0
|
||||||
PKG_RELEASE:=6
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=https://codeload.github.com/baresip/baresip/tar.gz/v$(PKG_VERSION)?
|
PKG_SOURCE_URL:=https://codeload.github.com/baresip/baresip/tar.gz/v$(PKG_VERSION)?
|
||||||
PKG_HASH:=f9230b27c4a62f31223847bc485c51f3d960f8a09f36998dedb73358e1784b4e
|
PKG_HASH:=95338c4e4dd6931c94d425d69089b66d32c173e48cb992344e856ead7ba9393b
|
||||||
|
|
||||||
PKG_LICENSE:=BSD-3-Clause
|
PKG_LICENSE:=BSD-3-Clause
|
||||||
PKG_LICENSE_FILES:=docs/COPYING
|
PKG_LICENSE_FILES:=docs/COPYING
|
||||||
@ -24,45 +23,8 @@ PKG_BUILD_DEPENDS:=glib2/host
|
|||||||
PKG_BUILD_PARALLEL:=1
|
PKG_BUILD_PARALLEL:=1
|
||||||
PKG_INSTALL:=1
|
PKG_INSTALL:=1
|
||||||
|
|
||||||
baresip-mods:= \
|
|
||||||
aac \
|
|
||||||
alsa \
|
|
||||||
amr \
|
|
||||||
avcodec \
|
|
||||||
avfilter \
|
|
||||||
avformat \
|
|
||||||
cons \
|
|
||||||
ctrl-dbus \
|
|
||||||
evdev \
|
|
||||||
g711 \
|
|
||||||
g722 \
|
|
||||||
g726 \
|
|
||||||
gst \
|
|
||||||
gst-video \
|
|
||||||
httpreq \
|
|
||||||
l16 \
|
|
||||||
mqtt \
|
|
||||||
opus \
|
|
||||||
opus_multistream \
|
|
||||||
oss \
|
|
||||||
plc \
|
|
||||||
portaudio \
|
|
||||||
pulse \
|
|
||||||
snapshot \
|
|
||||||
sndfile \
|
|
||||||
speex-pp \
|
|
||||||
srtp \
|
|
||||||
stdio \
|
|
||||||
syslog \
|
|
||||||
v4l2 \
|
|
||||||
vp8 \
|
|
||||||
vp9
|
|
||||||
|
|
||||||
PKG_CONFIG_DEPENDS:= \
|
|
||||||
$(patsubst %,CONFIG_PACKAGE_baresip-mod-%,$(subst _,-,$(baresip-mods)))
|
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
include $(INCLUDE_DIR)/nls.mk
|
include $(INCLUDE_DIR)/cmake.mk
|
||||||
|
|
||||||
define Package/baresip/Default
|
define Package/baresip/Default
|
||||||
SECTION:=net
|
SECTION:=net
|
||||||
@ -74,7 +36,7 @@ endef
|
|||||||
define Package/baresip
|
define Package/baresip
|
||||||
$(call Package/baresip/Default)
|
$(call Package/baresip/Default)
|
||||||
TITLE:=Portable and modular SIP User-Agent with A/V support
|
TITLE:=Portable and modular SIP User-Agent with A/V support
|
||||||
DEPENDS:=+libre +librem
|
DEPENDS:=+libre
|
||||||
USERID:=$(PKG_NAME)=374:$(PKG_NAME)=374
|
USERID:=$(PKG_NAME)=374:$(PKG_NAME)=374
|
||||||
MENU:=1
|
MENU:=1
|
||||||
FILE_MODES:= \
|
FILE_MODES:= \
|
||||||
@ -84,76 +46,98 @@ $(call Package/baresip/Default)
|
|||||||
/etc/baresip/contacts:baresip:baresip:0640
|
/etc/baresip/contacts:baresip:baresip:0640
|
||||||
endef
|
endef
|
||||||
|
|
||||||
baresip-mod-aac := USE_AAC
|
baresip-mods:= \
|
||||||
baresip-mod-alsa := USE_ALSA
|
aac \
|
||||||
baresip-mod-amr := USE_AMR
|
alsa \
|
||||||
baresip-mod-avcodec := USE_AVCODEC
|
aubridge \
|
||||||
baresip-mod-avfilter := USE_AVFILTER
|
auconv \
|
||||||
baresip-mod-avformat := USE_AVFORMAT
|
aufile \
|
||||||
baresip-mod-cons := USE_CONS
|
auresamp \
|
||||||
baresip-mod-ctrl-dbus := HAVE_GLIB USE_DBUS
|
ausine \
|
||||||
baresip-mod-evdev := USE_EVDEV
|
avcodec \
|
||||||
baresip-mod-g711 := USE_G711
|
avfilter \
|
||||||
baresip-mod-g722 := USE_G722
|
avformat \
|
||||||
baresip-mod-g726 := USE_G726
|
cons \
|
||||||
baresip-mod-gst := USE_GST
|
ctrl_dbus \
|
||||||
baresip-mod-gst-video := USE_GST_VIDEO
|
ctrl_tcp \
|
||||||
baresip-mod-httpreq := USE_HTTPREQ
|
debug_cmd \
|
||||||
baresip-mod-l16 := USE_L16
|
dtls_srtp \
|
||||||
baresip-mod-mqtt := USE_MQTT
|
ebuacip \
|
||||||
baresip-mod-opus := USE_OPUS
|
echo \
|
||||||
baresip-mod-opus_multistream := USE_OPUS_MS
|
evdev \
|
||||||
baresip-mod-oss := USE_OSS
|
fakevideo \
|
||||||
baresip-mod-plc := USE_PLC
|
g711 \
|
||||||
baresip-mod-portaudio := USE_PORTAUDIO
|
g722 \
|
||||||
baresip-mod-pulse := USE_PULSE
|
g726 \
|
||||||
baresip-mod-snapshot := USE_SNAPSHOT
|
gst \
|
||||||
baresip-mod-sndfile := USE_SNDFILE
|
httpd \
|
||||||
baresip-mod-speex-pp := USE_SPEEX_PP
|
httpreq \
|
||||||
baresip-mod-srtp := USE_SRTP
|
in_band_dtmf \
|
||||||
baresip-mod-stdio := USE_STDIO
|
l16 \
|
||||||
baresip-mod-syslog := USE_SYSLOG
|
mixausrc \
|
||||||
baresip-mod-vp8 := USE_VPX
|
mixminus \
|
||||||
baresip-mod-vp9 := USE_VPX
|
mqtt \
|
||||||
baresip-mod-v4l2 := USE_V4L2
|
mwi \
|
||||||
|
natpmp \
|
||||||
|
netroam \
|
||||||
|
opus \
|
||||||
|
opus_multistream \
|
||||||
|
pcp \
|
||||||
|
plc \
|
||||||
|
portaudio \
|
||||||
|
presence \
|
||||||
|
pulse \
|
||||||
|
rtcpsummary \
|
||||||
|
selfview \
|
||||||
|
serreg \
|
||||||
|
snapshot \
|
||||||
|
sndfile \
|
||||||
|
srtp \
|
||||||
|
stdio \
|
||||||
|
swscale \
|
||||||
|
syslog \
|
||||||
|
uuid \
|
||||||
|
v4l2 \
|
||||||
|
vidbridge \
|
||||||
|
vidinfo \
|
||||||
|
vp8 \
|
||||||
|
vp9 \
|
||||||
|
vumeter
|
||||||
|
|
||||||
BARESIP_MOD_OPTIONS:= \
|
empty:=
|
||||||
MOD_AUTODETECT= \
|
space:= $(empty) $(empty)
|
||||||
$(foreach m,$(baresip-mods),$(foreach v,$(baresip-mod-$(m)),$(v)=$(if $(CONFIG_PACKAGE_baresip-mod-$(subst _,-,$(m))),1)))
|
|
||||||
|
|
||||||
MAKE_FLAGS+= \
|
MODULES:=stun;turn;menu;ice;contact;account
|
||||||
CROSS_COMPILE="$(TARGET_CROSS)" \
|
MODULES+=$(foreach m,$(baresip-mods),$(if $(CONFIG_PACKAGE_baresip-mod-$(m)),$(m)))
|
||||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
MODULES:=$(strip $(MODULES))
|
||||||
EXTRA_LFLAGS="$(TARGET_LDFLAGS)" \
|
MODULES:=$(subst $(space),;,$(MODULES))
|
||||||
LD="$(TARGET_CC)" \
|
|
||||||
LIBRE_MK="$(STAGING_DIR)/usr/share/re/re.mk" \
|
|
||||||
LIBRE_INC="$(STAGING_DIR)/usr/include/re" \
|
|
||||||
LIBRE_SO="$(STAGING_DIR)/usr/lib" \
|
|
||||||
LIBREM_PATH="$(STAGING_DIR)/usr" \
|
|
||||||
OS=linux \
|
|
||||||
RELEASE=1 \
|
|
||||||
SYSROOT="$(shell $(FIND) $(TOOLCHAIN_DIR) -path '*/include/pthread.h' | sed -ne '1s|/include/pthread.h||p')" \
|
|
||||||
SYSROOT_ALT="$(STAGING_DIR)/usr" \
|
|
||||||
$(BARESIP_MOD_OPTIONS)
|
|
||||||
|
|
||||||
TARGET_CFLAGS+=-D_GNU_SOURCE
|
CMAKE_OPTIONS += -DMODULES="$(MODULES)" \
|
||||||
|
-DGST_INCLUDE_DIRS="$(STAGING_DIR)/usr/include/gstreamer-1.0" \
|
||||||
|
-DGL_INCLUDE_DIRS="$(STAGING_DIR)/usr/include/glib-2.0"
|
||||||
|
|
||||||
|
define Build/InstallDev
|
||||||
|
$(INSTALL_DIR) $(1)/usr
|
||||||
|
$(CP) $(PKG_INSTALL_DIR)/usr/* $(1)/usr
|
||||||
|
endef
|
||||||
|
|
||||||
define Package/baresip/install
|
define Package/baresip/install
|
||||||
$(INSTALL_DIR) $(1)/usr/bin
|
$(INSTALL_DIR) $(1)/usr/bin \
|
||||||
|
$(1)/usr/lib/baresip/modules \
|
||||||
|
$(1)/usr/share/baresip \
|
||||||
|
$(1)/etc/baresip \
|
||||||
|
$(1)/etc/init.d \
|
||||||
|
$(1)/etc/default
|
||||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/baresip $(1)/usr/bin
|
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/baresip $(1)/usr/bin
|
||||||
$(INSTALL_DIR) $(1)/usr/lib/baresip/modules
|
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/libbaresip.so* $(1)/usr/lib
|
||||||
$(INSTALL_DATA) \
|
$(INSTALL_DATA) \
|
||||||
$(PKG_INSTALL_DIR)/usr/lib/baresip/modules/{account,auloop,contact,ice,menu,stun,turn}.so \
|
$(PKG_INSTALL_DIR)/usr/lib/baresip/modules/{account,contact,ice,menu,stun,turn}.so \
|
||||||
$(1)/usr/lib/baresip/modules
|
$(1)/usr/lib/baresip/modules
|
||||||
$(INSTALL_DIR) $(1)/usr/share/baresip
|
|
||||||
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/baresip/* $(1)/usr/share/baresip
|
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/baresip/* $(1)/usr/share/baresip
|
||||||
$(INSTALL_DIR) $(1)/etc/baresip
|
|
||||||
$(SED) '/^#/!s/^/#/' $(PKG_BUILD_DIR)/docs/examples/accounts
|
$(SED) '/^#/!s/^/#/' $(PKG_BUILD_DIR)/docs/examples/accounts
|
||||||
$(SED) '/^#module_path/s|^#||;s|/local||' $(PKG_BUILD_DIR)/docs/examples/config
|
$(SED) '/^#module_path/s|^#||;s|/local||' $(PKG_BUILD_DIR)/docs/examples/config
|
||||||
$(INSTALL_DATA) $(PKG_BUILD_DIR)/docs/examples/{accounts,config,contacts} $(1)/etc/baresip
|
$(INSTALL_DATA) $(PKG_BUILD_DIR)/docs/examples/{accounts,config,contacts} $(1)/etc/baresip
|
||||||
$(INSTALL_DIR) $(1)/etc/default
|
|
||||||
$(INSTALL_CONF) ./files/baresip.default $(1)/etc/default/baresip
|
$(INSTALL_CONF) ./files/baresip.default $(1)/etc/default/baresip
|
||||||
$(INSTALL_DIR) $(1)/etc/init.d
|
|
||||||
$(INSTALL_BIN) ./files/baresip.init $(1)/etc/init.d/baresip
|
$(INSTALL_BIN) ./files/baresip.init $(1)/etc/init.d/baresip
|
||||||
endef
|
endef
|
||||||
|
|
||||||
@ -162,92 +146,83 @@ define Package/baresip/conffiles
|
|||||||
/etc/baresip/config
|
/etc/baresip/config
|
||||||
/etc/baresip/contacts
|
/etc/baresip/contacts
|
||||||
/etc/default/baresip
|
/etc/default/baresip
|
||||||
/etc/init.d/baresip
|
|
||||||
endef
|
endef
|
||||||
|
|
||||||
##################
|
##################
|
||||||
# bareSIP modules
|
# bareSIP modules
|
||||||
# 1. Name
|
# 1. Name
|
||||||
# 2. Title
|
# 2. Title
|
||||||
# 3. Files
|
# 3. Dependencies
|
||||||
# 4. Dependencies
|
|
||||||
##################
|
##################
|
||||||
|
|
||||||
define BuildPlugin
|
define BuildPlugin
|
||||||
|
define Package/baresip-mod-$(1)
|
||||||
define Package/baresip-mod-$(subst _,-,$(1))
|
|
||||||
$$(call Package/baresip/Default)
|
$$(call Package/baresip/Default)
|
||||||
TITLE:=$(2)
|
TITLE:=$(2)
|
||||||
DEPENDS:=baresip $(patsubst +%,+PACKAGE_$(PKG_NAME)-mod-$(subst _,-,$(1)):%,$(4))
|
DEPENDS:=baresip $(patsubst +%,+PACKAGE_$(PKG_NAME)-mod-$(1):%,$(3))
|
||||||
endef
|
endef
|
||||||
|
define Package/baresip-mod-$(1)/install
|
||||||
define Package/baresip-mod-$(subst _,-,$(1))/install
|
$(INSTALL_DIR) $$(1)/usr/lib/baresip/modules
|
||||||
[ -z "$(3)" ] || $(INSTALL_DIR) $$(1)/usr/lib/baresip/modules
|
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/baresip/modules/$(1).so \
|
||||||
for f in $(3); do \
|
$$(1)/usr/lib/baresip/modules
|
||||||
$(INSTALL_DATA) \
|
|
||||||
$(PKG_INSTALL_DIR)/usr/lib/baresip/modules/$$$$$$$${f}.so \
|
|
||||||
$$(1)/usr/lib/baresip/modules; \
|
|
||||||
done
|
|
||||||
endef
|
endef
|
||||||
|
$$(eval $$(call BuildPackage,baresip-mod-$(1)))
|
||||||
$$(eval $$(call BuildPackage,baresip-mod-$(subst _,-,$(1))))
|
|
||||||
endef
|
endef
|
||||||
|
|
||||||
$(eval $(call BuildPackage,baresip))
|
$(eval $(call BuildPackage,baresip))
|
||||||
|
|
||||||
$(eval $(call BuildPlugin,aac,MPEG-4 AAC Audio Codec,aac,+fdk-aac))
|
$(eval $(call BuildPlugin,aac,MPEG-4 AAC Audio Codec,+fdk-aac))
|
||||||
$(eval $(call BuildPlugin,alsa,ALSA audio driver,alsa,+alsa-lib))
|
$(eval $(call BuildPlugin,alsa,ALSA audio driver,+alsa-lib))
|
||||||
$(eval $(call BuildPlugin,amr,Adaptive Multi-Rate [AMR] audio codec,amr,))
|
$(eval $(call BuildPlugin,aubridge,Audio bridge module,))
|
||||||
$(eval $(call BuildPlugin,aubridge,Audio bridge module,aubridge,))
|
$(eval $(call BuildPlugin,aufile,Audio module for using a WAV-file as audio input,))
|
||||||
$(eval $(call BuildPlugin,aufile,Audio module for using a WAV-file as audio input,aufile,))
|
$(eval $(call BuildPlugin,ausine,Sine Audio Source,))
|
||||||
$(eval $(call BuildPlugin,ausine,Sine Audio Source,ausine,))
|
$(eval $(call BuildPlugin,auconv,Audio format conversion,))
|
||||||
$(eval $(call BuildPlugin,avcodec,Video codec using FFmpeg,avcodec,+libffmpeg-full))
|
$(eval $(call BuildPlugin,auresamp,Audio resampler,))
|
||||||
$(eval $(call BuildPlugin,avformat,Video source using FFmpeg,avformat,baresip-mod-avcodec))
|
$(eval $(call BuildPlugin,avcodec,Video codec using FFmpeg,+libffmpeg-full))
|
||||||
$(eval $(call BuildPlugin,b2bua,Back-to-Back User-Agent module,b2bua,))
|
$(eval $(call BuildPlugin,avfilter,Video filter using FFmpeg,+libffmpeg-full))
|
||||||
$(eval $(call BuildPlugin,cons,UDP/TCP console UI driver,cons,))
|
$(eval $(call BuildPlugin,avformat,Video source using FFmpeg,+baresip-mod-avcodec))
|
||||||
$(eval $(call BuildPlugin,ctrl_dbus,DBus control interface,ctrl_dbus,+glib2))
|
$(eval $(call BuildPlugin,cons,UDP/TCP console UI driver,))
|
||||||
$(eval $(call BuildPlugin,ctrl_tcp,TCP control interface,ctrl_tcp,))
|
$(eval $(call BuildPlugin,ctrl_dbus,DBus control interface,+glib2))
|
||||||
$(eval $(call BuildPlugin,debug_cmd,Debug commands,debug_cmd,))
|
$(eval $(call BuildPlugin,ctrl_tcp,TCP control interface,))
|
||||||
$(eval $(call BuildPlugin,dtls_srtp,DTLS-SRTP end-to-end encryption,dtls_srtp,))
|
$(eval $(call BuildPlugin,debug_cmd,Debug commands,))
|
||||||
$(eval $(call BuildPlugin,ebuacip,EBU ACIP [Audio Contribution over IP] Profile,ebuacip,))
|
$(eval $(call BuildPlugin,dtls_srtp,DTLS-SRTP end-to-end encryption,))
|
||||||
$(eval $(call BuildPlugin,echo,Echo server module,echo,))
|
$(eval $(call BuildPlugin,ebuacip,EBU ACIP [Audio Contribution over IP] Profile,))
|
||||||
$(eval $(call BuildPlugin,evdev,Linux input driver,evdev,))
|
$(eval $(call BuildPlugin,echo,Echo server module,))
|
||||||
$(eval $(call BuildPlugin,fakevideo,Fake video input/output driver,fakevideo,))
|
$(eval $(call BuildPlugin,evdev,Linux input driver,))
|
||||||
$(eval $(call BuildPlugin,g711,G.711 audio codec,g711,))
|
$(eval $(call BuildPlugin,fakevideo,Fake video input/output driver,))
|
||||||
$(eval $(call BuildPlugin,g722,G.722 audio codec,g722,+libspandsp))
|
$(eval $(call BuildPlugin,g711,G.711 audio codec,))
|
||||||
$(eval $(call BuildPlugin,g726,G.726 audio codec,g726,+libspandsp))
|
$(eval $(call BuildPlugin,g722,G.722 audio codec,+libspandsp))
|
||||||
$(eval $(call BuildPlugin,gst,Gstreamer 1.0 playbin pipeline,gst,@AUDIO_SUPPORT +glib2 +libgstreamer1))
|
$(eval $(call BuildPlugin,g726,G.726 audio codec,+libspandsp))
|
||||||
$(eval $(call BuildPlugin,gst_video,Video codecs using Gstreamer 1.0,gst_video,@AUDIO_SUPPORT +glib2 +libgst1app +libgstreamer1))
|
$(eval $(call BuildPlugin,gst,Gstreamer 1.0 playbin pipeline,@AUDIO_SUPPORT +glib2 +libgstreamer1))
|
||||||
$(eval $(call BuildPlugin,httpd,HTTP webserver UI-module,httpd,))
|
$(eval $(call BuildPlugin,httpd,HTTP webserver UI-module,))
|
||||||
$(eval $(call BuildPlugin,httpreq,HTTP request module,httpreq,))
|
$(eval $(call BuildPlugin,httpreq,HTTP request module,))
|
||||||
$(eval $(call BuildPlugin,l16,16-bit linear codec,l16,))
|
$(eval $(call BuildPlugin,l16,16-bit linear codec,))
|
||||||
$(eval $(call BuildPlugin,mixausrc,Mixes another audio source into audio stream,mixausrc,))
|
$(eval $(call BuildPlugin,mixausrc,Mixes another audio source into audio stream,))
|
||||||
$(eval $(call BuildPlugin,mqtt,Message Queue Telemetry Transport [MQTT] client,mqtt,+libmosquitto))
|
$(eval $(call BuildPlugin,mixminus,Mixes N-1 audio streams for conferencing,))
|
||||||
$(eval $(call BuildPlugin,multicast,Multicast support,multicast,))
|
$(eval $(call BuildPlugin,mqtt,Message Queue Telemetry Transport [MQTT] client,+libmosquitto))
|
||||||
$(eval $(call BuildPlugin,mwi,Message Waiting Indication,mwi,))
|
$(eval $(call BuildPlugin,mwi,Message Waiting Indication,))
|
||||||
$(eval $(call BuildPlugin,natpmp,NAT Port Mapping Protocol module,natpmp,))
|
$(eval $(call BuildPlugin,natpmp,NAT Port Mapping Protocol module,))
|
||||||
$(eval $(call BuildPlugin,opus,OPUS Interactive audio codec,opus,+libopus))
|
$(eval $(call BuildPlugin,netroam,Network roaming module,))
|
||||||
$(eval $(call BuildPlugin,opus_multistream,Opus Multistream Audio Codec,opus_multistream,+libopus))
|
$(eval $(call BuildPlugin,opus,OPUS Interactive audio codec,+libopus))
|
||||||
$(eval $(call BuildPlugin,oss,OSS audio driver,oss,))
|
$(eval $(call BuildPlugin,opus_multistream,Opus Multistream Audio Codec,+libopus))
|
||||||
$(eval $(call BuildPlugin,plc,Packet Loss Concealment,plc,+libspandsp))
|
$(eval $(call BuildPlugin,plc,Packet Loss Concealment,+libspandsp))
|
||||||
$(eval $(call BuildPlugin,portaudio,Portaudio audio driver,portaudio,+portaudio))
|
$(eval $(call BuildPlugin,pcp,Port Control Protocol for Media NAT-traversal,))
|
||||||
$(eval $(call BuildPlugin,presence,Presence module,presence,))
|
$(eval $(call BuildPlugin,portaudio,Portaudio audio driver,+portaudio))
|
||||||
$(eval $(call BuildPlugin,pulse,Pulseaudio audio driver,pulse,PACKAGE_$(PKG_NAME)-mod-pulse:pulseaudio))
|
$(eval $(call BuildPlugin,presence,Presence module,))
|
||||||
$(eval $(call BuildPlugin,rtcpsummary,RTCP summary module,rtcpsummary,))
|
$(eval $(call BuildPlugin,pulse,Pulseaudio audio driver,PACKAGE_$(PKG_NAME)-mod-pulse:pulseaudio))
|
||||||
$(eval $(call BuildPlugin,selfview,Video selfview module,selfview,))
|
$(eval $(call BuildPlugin,rtcpsummary,RTCP summary module,))
|
||||||
$(eval $(call BuildPlugin,serreg,Serial registration mode,serreg,))
|
$(eval $(call BuildPlugin,selfview,Video selfview module,))
|
||||||
$(eval $(call BuildPlugin,snapshot,Snapshot video module,snapshot,+libpng))
|
$(eval $(call BuildPlugin,serreg,Serial registration mode,))
|
||||||
$(eval $(call BuildPlugin,sndfile,Audio dumper using libsndfile,sndfile,+libsndfile))
|
$(eval $(call BuildPlugin,snapshot,Snapshot video module,+libpng))
|
||||||
$(eval $(call BuildPlugin,speex_pp,Speex Pre-processor,speex_pp,+libspeexdsp))
|
$(eval $(call BuildPlugin,sndfile,Audio dumper using libsndfile,+libsndfile))
|
||||||
$(eval $(call BuildPlugin,srtp,Secure RTP module using libre,srtp,))
|
$(eval $(call BuildPlugin,srtp,Secure RTP module using libre,))
|
||||||
$(eval $(call BuildPlugin,stdio,Standard input/output UI driver,stdio,))
|
$(eval $(call BuildPlugin,stdio,Standard input/output UI driver,))
|
||||||
$(eval $(call BuildPlugin,syslog,Syslog module,syslog,))
|
$(eval $(call BuildPlugin,syslog,Syslog module,))
|
||||||
$(eval $(call BuildPlugin,uuid,UUID generator and loader,uuid,))
|
$(eval $(call BuildPlugin,swscale,Video filter for scaling by FFmpeg,+libffmpeg-full))
|
||||||
$(eval $(call BuildPlugin,v4l2,Video4Linux2 video source,v4l2,+libv4l))
|
$(eval $(call BuildPlugin,uuid,UUID generator and loader,))
|
||||||
$(eval $(call BuildPlugin,v4l2_codec,Video4Linux2 video codec module,v4l2_codec,))
|
$(eval $(call BuildPlugin,v4l2,Video4Linux2 video source,+libv4l))
|
||||||
$(eval $(call BuildPlugin,vidbridge,Video bridge module,vidbridge,))
|
$(eval $(call BuildPlugin,vidbridge,Video bridge module,))
|
||||||
$(eval $(call BuildPlugin,vidinfo,Video-info filter,vidinfo,))
|
$(eval $(call BuildPlugin,vidinfo,Video-info filter,))
|
||||||
$(eval $(call BuildPlugin,vidloop,Video-loop test module,vidloop,))
|
$(eval $(call BuildPlugin,vumeter,Display audio levels in console,))
|
||||||
$(eval $(call BuildPlugin,vumeter,Display audio levels in console,vumeter,))
|
$(eval $(call BuildPlugin,vp8,VP8 video codec,+libvpx))
|
||||||
$(eval $(call BuildPlugin,vp8,VP8 video codec,vp8,+libvpx))
|
$(eval $(call BuildPlugin,vp9,VP9 video codec,+libvpx))
|
||||||
$(eval $(call BuildPlugin,vp9,VP9 video codec,vp9,+libvpx))
|
|
||||||
|
@ -1,23 +0,0 @@
|
|||||||
From d7aeb9393876af3746dacdbacd70c4a5d6dfcf39 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Christian Spielberger <c.spielberger@commend.com>
|
|
||||||
Date: Sun, 23 May 2021 10:01:04 +0200
|
|
||||||
Subject: [PATCH] ctrl_dbus: add dependency to baresipbus.h (#1447) (#1457)
|
|
||||||
|
|
||||||
---
|
|
||||||
modules/ctrl_dbus/module.mk | 5 ++++-
|
|
||||||
1 file changed, 4 insertions(+), 1 deletion(-)
|
|
||||||
|
|
||||||
--- a/modules/ctrl_dbus/module.mk
|
|
||||||
+++ b/modules/ctrl_dbus/module.mk
|
|
||||||
@@ -16,7 +16,10 @@ $(MOD)_CFLAGS += -Wno-unused-parameter -
|
|
||||||
|
|
||||||
$(MOD)_CCHECK_OPT = -e baresipbus.h -e baresipbus.c
|
|
||||||
|
|
||||||
-modules/ctrl_dbus/baresipbus.h modules/ctrl_dbus/baresipbus.c: \
|
|
||||||
+modules/$(MOD)/baresipbus.o : modules/$(MOD)/baresipbus.h
|
|
||||||
+modules/$(MOD)/ctrl_dbus.o : modules/$(MOD)/baresipbus.h
|
|
||||||
+
|
|
||||||
+modules/$(MOD)/baresipbus.h modules/$(MOD)/baresipbus.c: \
|
|
||||||
modules/ctrl_dbus/com.github.Baresip.xml
|
|
||||||
@cd $(dir $@) && ./gen.sh
|
|
||||||
|
|
Loading…
Reference in New Issue
Block a user