mirror of
https://git.openwrt.org/feed/telephony.git
synced 2025-01-09 04:09:47 +08:00
Merge pull request #880 from micmac1/fs-1.10.12
freeswitch: bump to 1.10.12 (and mark as BROKEN)
This commit is contained in:
commit
d3f320558f
@ -9,12 +9,12 @@ include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=libks
|
||||
|
||||
PKG_VERSION:=2.0.2
|
||||
PKG_VERSION:=2.0.6
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=libks-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://codeload.github.com/signalwire/libks/tar.gz/v$(PKG_VERSION)?
|
||||
PKG_HASH:=af94f9fcdb2022b8f09187309ac2d372a5a4cc639af77cd4375f2d5c88b4fd63
|
||||
PKG_HASH:=0b78d07d7a4ebf6c58d898bde2873bc40941ed29ca237a3c9939860de4a0ba25
|
||||
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
CMAKE_INSTALL:=1
|
||||
|
@ -5,7 +5,7 @@
|
||||
#include(cmake/cotire.cmake)
|
||||
|
||||
+# Declare our project, libks2
|
||||
+project(LibKS2 VERSION 2.0.2 LANGUAGES C CXX)
|
||||
+project(LibKS2 VERSION 2.0.6 LANGUAGES C CXX)
|
||||
+message("LibKS2 Version ${PROJECT_VERSION_MAJOR}.${PROJECT_VERSION_MINOR}")
|
||||
+
|
||||
# Load our common utility api and setup the platfomrm and build
|
||||
@ -16,7 +16,7 @@
|
||||
endif()
|
||||
|
||||
-# Declare our project, libks2
|
||||
-project(LibKS2 VERSION 2.0.2 LANGUAGES C CXX)
|
||||
-project(LibKS2 VERSION 2.0.6 LANGUAGES C CXX)
|
||||
-message("LibKS2 Version ${PROJECT_VERSION_MAJOR}.${PROJECT_VERSION_MINOR}")
|
||||
-
|
||||
# Set package version
|
||||
|
@ -8,13 +8,13 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=freeswitch
|
||||
PKG_VERSION:=1.10.11
|
||||
PKG_VERSION:=1.10.12
|
||||
PKG_RELEASE:=1
|
||||
PKG_MAINTAINER:=Sebastian Kemper <sebastian_ml@gmx.net>
|
||||
|
||||
PKG_SOURCE:=freeswitch-$(PKG_VERSION).-release.tar.xz
|
||||
PKG_SOURCE_URL:=https://files.freeswitch.org/releases/freeswitch
|
||||
PKG_HASH:=7f9603a691220d9f47da42f3b19290b629b69dceb2eee56448f0a7cefcf9d1a1
|
||||
PKG_HASH:=e324e4ae063e692c42b93031157329bae339ea007e611d3535333deaed85aa47
|
||||
|
||||
PKG_CPE_ID:=cpe:/a:freeswitch:freeswitch
|
||||
|
||||
@ -127,7 +127,6 @@ FS_MOD_AVAILABLE:= \
|
||||
http_cache \
|
||||
isac \
|
||||
json_cdr \
|
||||
kazoo \
|
||||
lcr \
|
||||
ldap \
|
||||
local_stream \
|
||||
@ -309,6 +308,7 @@ $(call Package/freeswitch/Default)
|
||||
MENU:=1
|
||||
USERID:=freeswitch=372:freeswitch=372
|
||||
DEPENDS:= \
|
||||
@BROKEN \
|
||||
$(ICONV_DEPENDS) \
|
||||
+libstdcpp \
|
||||
+!BUSYBOX_DEFAULT_SU:shadow-utils \
|
||||
@ -592,7 +592,7 @@ CONFIGURE_ARGS+= \
|
||||
--with-python3=no
|
||||
endif
|
||||
|
||||
ifeq ($(CONFIG_PACKAGE_freeswitch-mod-erlang-event)$(CONFIG_PACKAGE_freeswitch-mod-kazoo),)
|
||||
ifeq ($(CONFIG_PACKAGE_freeswitch-mod-erlang-event),)
|
||||
CONFIGURE_ARGS+= \
|
||||
--with-erlang=no
|
||||
endif
|
||||
@ -921,7 +921,6 @@ $(eval $(call Package/freeswitch/Module,httapi,HT-TAPI,This module provides an A
|
||||
$(eval $(call Package/freeswitch/Module,http_cache,HTTP GET with caching,This module provides an API for making HTTP GET requests where the\nresult is cached.,))
|
||||
$(eval $(call Package/freeswitch/Module,isac,iSAC,iSAC codec support.,@arm||i386||mips||mips64||mips64el||mipsel||x86_64))
|
||||
$(eval $(call Package/freeswitch/Module,json_cdr,JSON CDR,JSON-based Call Detail Record handler.,))
|
||||
$(eval $(call Package/freeswitch/Module,kazoo,Kazoo,Kazoo module for FreeSWITCH.,+erlang))
|
||||
$(eval $(call Package/freeswitch/Module,lcr,LCR,This module adds a facility for least-cost routing.,))
|
||||
$(eval $(call Package/freeswitch/Module,ldap,LDAP,LDAP module for FreeSWITCH.,+libopenldap))
|
||||
$(eval $(call Package/freeswitch/Module,local_stream,Local stream,Connects multiple channels to a looped stream.,))
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -2300,7 +2300,12 @@ AC_SUBST(OUR_DISABLED_INSTALL_MODS)
|
||||
@@ -2299,7 +2299,12 @@ AC_SUBST(OUR_DISABLED_INSTALL_MODS)
|
||||
AC_SUBST(OUR_DISABLED_UNINSTALL_MODS)
|
||||
AC_SUBST(AM_MAKEFLAGS)
|
||||
|
||||
|
@ -73,7 +73,7 @@ The most portable fix for time_t handling is to always cast it to
|
||||
|
||||
--- a/src/mod/endpoints/mod_sofia/sofia_presence.c
|
||||
+++ b/src/mod/endpoints/mod_sofia/sofia_presence.c
|
||||
@@ -4198,7 +4198,8 @@ void sofia_presence_handle_sip_i_subscri
|
||||
@@ -4197,7 +4197,8 @@ void sofia_presence_handle_sip_i_subscri
|
||||
sql = switch_mprintf("insert into sip_dialogs (sip_from_user,sip_from_host,call_info,call_info_state,hostname,expires,rcd,profile_name) "
|
||||
"values ('%q','%q','%q','seized','%q',%"TIME_T_FMT",%ld,'%q')",
|
||||
to_user, to_host, switch_str_nil(p), mod_sofia_globals.hostname,
|
||||
|
Loading…
Reference in New Issue
Block a user