mirror of
https://git.openwrt.org/feed/telephony.git
synced 2025-01-09 04:09:47 +08:00
Merge pull request #783 from micmac1/fs-1.10.8
freeswitch: bump to 1.10.8
This commit is contained in:
commit
fa14037e8a
@ -9,12 +9,12 @@ include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=libks
|
||||
|
||||
PKG_VERSION:=1.7.0
|
||||
PKG_RELEASE:=1
|
||||
PKG_VERSION:=1.8.0
|
||||
PKG_RELEASE:=$(AUTORELEASE)
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://codeload.github.com/signalwire/libks/tar.gz/v$(PKG_VERSION)?
|
||||
PKG_HASH:=73c5751eadad4d3390d61b9765e9b860e0aba7336044ecf8b007dfc1818baa69
|
||||
PKG_HASH:=b42544a5544ac00ceeb0675a9e6a99c8e6ecc752452c7f38c6ffe32fbedb906d
|
||||
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
CMAKE_INSTALL:=1
|
||||
|
@ -5,7 +5,7 @@
|
||||
#include(cmake/cotire.cmake)
|
||||
|
||||
+# Declare our project, libks
|
||||
+project(LibKS VERSION 1.7.0 LANGUAGES C CXX)
|
||||
+project(LibKS VERSION 1.8.0 LANGUAGES C CXX)
|
||||
+message("LibKS Version ${PROJECT_VERSION_MAJOR}.${PROJECT_VERSION_MINOR}")
|
||||
+
|
||||
# Load our common utility api and setup the platfomrm and build
|
||||
@ -16,7 +16,7 @@
|
||||
endif()
|
||||
|
||||
-# Declare our project, libks
|
||||
-project(LibKS VERSION 1.7.0 LANGUAGES C CXX)
|
||||
-project(LibKS VERSION 1.8.0 LANGUAGES C CXX)
|
||||
-message("LibKS Version ${PROJECT_VERSION_MAJOR}.${PROJECT_VERSION_MINOR}")
|
||||
-
|
||||
# Set package version
|
||||
|
@ -8,13 +8,13 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=freeswitch
|
||||
PKG_VERSION:=1.10.7
|
||||
PKG_VERSION:=1.10.8
|
||||
PKG_RELEASE:=$(AUTORELEASE)
|
||||
PKG_MAINTAINER:=Sebastian Kemper <sebastian_ml@gmx.net>
|
||||
|
||||
PKG_SOURCE:=freeswitch-$(PKG_VERSION).-release.tar.xz
|
||||
PKG_SOURCE_URL:=https://files.freeswitch.org/releases/freeswitch
|
||||
PKG_HASH:=0919bddc2ea9cab2e4944314e71637bea9dd4f40d510722a74ea032104594c41
|
||||
PKG_HASH:=1176b26b2f463de2980e5be953f81ced94d23c784452bd41e086d3933a88be5f
|
||||
|
||||
PKG_CPE_ID:=cpe:/a:freeswitch:freeswitch
|
||||
|
||||
@ -98,7 +98,6 @@ FS_MOD_AVAILABLE:= \
|
||||
dialplan_asterisk \
|
||||
dialplan_directory \
|
||||
dialplan_xml \
|
||||
dingaling \
|
||||
directory \
|
||||
distributor \
|
||||
dptools \
|
||||
@ -198,7 +197,6 @@ FS_MOD_AVAILABLE:= \
|
||||
tone_stream \
|
||||
translate \
|
||||
tts_commandline \
|
||||
unimrcp \
|
||||
valet_parking \
|
||||
verto \
|
||||
video_filter \
|
||||
@ -728,21 +726,12 @@ ifneq ($(CONFIG_PACKAGE_freeswitch-mod-radius-cdr),)
|
||||
$(eval $(call Download/files,freeradius-client,$(FS_FREERADIUS_CLIENT_FILE),$(FS_LIBS_URL),$(FS_FREERADIUS_CLIENT_HASH)))
|
||||
endif
|
||||
|
||||
# Need to update LDFLAGS for libs/unimrcp, otherwise it will try to link to a
|
||||
# different apr/apr-util if found.
|
||||
# FS_ANCHOR: string in build/acmacros/apr.m4 that will be replaced
|
||||
FS_ANCHOR:=dnl Get build information from APR
|
||||
FS_APR_LIBS:=-L$(PKG_BUILD_DIR)/libs/apr -L$(PKG_BUILD_DIR)/libs/apr-util
|
||||
|
||||
define Build/Prepare
|
||||
$(call Build/Prepare/Default)
|
||||
|
||||
echo '#applications/mod_random' >> $(PKG_BUILD_DIR)/modules.conf
|
||||
echo '#codecs/mod_yuv' >> $(PKG_BUILD_DIR)/modules.conf
|
||||
echo '#event_handlers/mod_event_test' >> $(PKG_BUILD_DIR)/modules.conf
|
||||
|
||||
$(SED) 's|$(FS_ANCHOR)|APR_SETVAR(LDFLAGS,[$(FS_APR_LIBS) $(TARGET_LDFLAGS)])|' \
|
||||
$(PKG_BUILD_DIR)/libs/unimrcp/build/acmacros/apr.m4
|
||||
endef
|
||||
|
||||
define Build/Configure
|
||||
@ -764,21 +753,9 @@ ifneq ($(CONFIG_PACKAGE_freeswitch-mod-gsmopen),)
|
||||
$(call Package/freeswitch/enable/plugin,mod_spandsp)
|
||||
endif
|
||||
|
||||
# Hack for mod_rayo - it has a build-time dep on mod_dingaling
|
||||
ifneq ($(CONFIG_PACKAGE_freeswitch-mod-rayo),)
|
||||
$(call Package/freeswitch/enable/plugin,mod_dingaling)
|
||||
endif
|
||||
|
||||
# Hack for mod_ssml - it has a build-time dep on mod_rayo. And mod_rayo needs
|
||||
# mod_dingaling :)
|
||||
# Hack for mod_ssml - it has a build-time dep on mod_rayo.
|
||||
ifneq ($(CONFIG_PACKAGE_freeswitch-mod-ssml),)
|
||||
$(call Package/freeswitch/enable/plugin,mod_rayo)
|
||||
$(call Package/freeswitch/enable/plugin,mod_dingaling)
|
||||
endif
|
||||
|
||||
# Hack for mod_unimrcp - it has a build-time dep on mod_sofia
|
||||
ifneq ($(CONFIG_PACKAGE_freeswitch-mod-unimrcp),)
|
||||
$(call Package/freeswitch/enable/plugin,mod_sofia)
|
||||
endif
|
||||
|
||||
$(call Build/Configure/Default)
|
||||
@ -920,7 +897,6 @@ $(eval $(call Package/freeswitch/Module,db,DB,This module implements a simple db
|
||||
$(eval $(call Package/freeswitch/Module,dialplan_asterisk,Asterisk dialplan,Asterisk extensions.conf style dialplan parser.,))
|
||||
$(eval $(call Package/freeswitch/Module,dialplan_directory,Directory dialplan,Directory dialplan support.,))
|
||||
$(eval $(call Package/freeswitch/Module,dialplan_xml,XML dialplan,Standard FreeSWITCH XML dialplan support.,))
|
||||
$(eval $(call Package/freeswitch/Module,dingaling,Generic XMPP,Allows FreeSWITCH to be used as a client for XMPP Servers.,))
|
||||
$(eval $(call Package/freeswitch/Module,directory,Dial-by-name directory,This module implements a dial-by-name directory IVR.,))
|
||||
$(eval $(call Package/freeswitch/Module,distributor,Load distributor,This module implements a mechanism for performing load balancing.,))
|
||||
$(eval $(call Package/freeswitch/Module,dptools,Dialplan tools,This module implements basic dialplan tools.,))
|
||||
@ -1020,7 +996,6 @@ $(eval $(call Package/freeswitch/Module,theora,Theora passthrough,Theora video c
|
||||
$(eval $(call Package/freeswitch/Module,tone_stream,Tone stream,Tone generation stream.,))
|
||||
$(eval $(call Package/freeswitch/Module,translate,Number translation,This module implements number translation.,))
|
||||
$(eval $(call Package/freeswitch/Module,tts_commandline,TTS command-line,Run a command-line and play the output file.,))
|
||||
$(eval $(call Package/freeswitch/Module,unimrcp,UniMRCP,Allows communication with Media Resource Control Protocol servers.,))
|
||||
$(eval $(call Package/freeswitch/Module,valet_parking,Valet parking,This module implements the valet call parking strategy.,))
|
||||
$(eval $(call Package/freeswitch/Module,verto,Verto,Verto signaling protocol.,+libks))
|
||||
$(eval $(call Package/freeswitch/Module,video_filter,Video filter chromakey,This module provides a media bug for chromakey functionality.,))
|
||||
|
@ -40,7 +40,7 @@
|
||||
AC_PATH_PROG([PKG_CONFIG], [pkg-config], [no])
|
||||
|
||||
case $host in
|
||||
@@ -1660,13 +1636,7 @@ AC_CHECK_PROG(PERL,perl,[ac_cv_have_perl
|
||||
@@ -1672,13 +1648,7 @@ AC_CHECK_PROG(PERL,perl,[ac_cv_have_perl
|
||||
# -a "x$ac_cv_have_EXTERN_h" != "xno"
|
||||
|
||||
if test "x$ac_cv_have_perl" != "xno"; then
|
||||
|
@ -1,31 +0,0 @@
|
||||
--- a/src/include/switch_core_media.h
|
||||
+++ b/src/include/switch_core_media.h
|
||||
@@ -203,7 +203,7 @@ SWITCH_DECLARE(switch_status_t) switch_c
|
||||
SWITCH_DECLARE(void) switch_media_handle_set_media_flag(switch_media_handle_t *smh, switch_core_media_flag_t flag);
|
||||
SWITCH_DECLARE(void) switch_media_handle_clear_media_flag(switch_media_handle_t *smh, switch_core_media_flag_t flag);
|
||||
SWITCH_DECLARE(int32_t) switch_media_handle_test_media_flag(switch_media_handle_t *smh, switch_core_media_flag_t flag);
|
||||
-SWITCH_DECLARE(void) switch_media_handle_set_media_flags(switch_media_handle_t *smh, switch_core_media_flag_t flags[]);
|
||||
+SWITCH_DECLARE(void) switch_media_handle_set_media_flags(switch_media_handle_t *smh, switch_core_media_flag_t flags[SCMF_MAX]);
|
||||
SWITCH_DECLARE(void) switch_core_session_check_outgoing_crypto(switch_core_session_t *session);
|
||||
SWITCH_DECLARE(const char *) switch_core_session_local_crypto_key(switch_core_session_t *session, switch_media_type_t type);
|
||||
SWITCH_DECLARE(int) switch_core_session_check_incoming_crypto(switch_core_session_t *session,
|
||||
--- a/src/include/switch_rtp.h
|
||||
+++ b/src/include/switch_rtp.h
|
||||
@@ -234,7 +234,7 @@ SWITCH_DECLARE(switch_status_t) switch_r
|
||||
switch_payload_t payload,
|
||||
uint32_t samples_per_interval,
|
||||
uint32_t ms_per_packet,
|
||||
- switch_rtp_flag_t flags[], char *timer_name, const char **err, switch_memory_pool_t *pool);
|
||||
+ switch_rtp_flag_t flags[SWITCH_RTP_FLAG_INVALID], char *timer_name, const char **err, switch_memory_pool_t *pool);
|
||||
|
||||
|
||||
/*!
|
||||
@@ -260,7 +260,7 @@ SWITCH_DECLARE(switch_rtp_t *) switch_rt
|
||||
switch_payload_t payload,
|
||||
uint32_t samples_per_interval,
|
||||
uint32_t ms_per_packet,
|
||||
- switch_rtp_flag_t flags[], char *timer_name, const char **err, switch_memory_pool_t *pool, switch_port_t bundle_internal_ports, switch_port_t bundle_external_port);
|
||||
+ switch_rtp_flag_t flags[SWITCH_RTP_FLAG_INVALID], char *timer_name, const char **err, switch_memory_pool_t *pool, switch_port_t bundle_internal_ports, switch_port_t bundle_external_port);
|
||||
|
||||
|
||||
/*!
|
@ -1,33 +1,3 @@
|
||||
--- a/libs/apr-util/build/apr_common.m4
|
||||
+++ b/libs/apr-util/build/apr_common.m4
|
||||
@@ -514,8 +514,9 @@ dnl string.
|
||||
dnl
|
||||
dnl
|
||||
AC_DEFUN([APR_CHECK_STRERROR_R_RC],[
|
||||
-AC_MSG_CHECKING(for type of return code from strerror_r)
|
||||
-AC_TRY_RUN([
|
||||
+AC_CACHE_CHECK([whether return code from strerror_r has type int],
|
||||
+[ac_cv_strerror_r_rc_int],
|
||||
+[AC_TRY_RUN([
|
||||
#include <errno.h>
|
||||
#include <string.h>
|
||||
#include <stdio.h>
|
||||
@@ -534,14 +535,10 @@ int main(void)
|
||||
}], [
|
||||
ac_cv_strerror_r_rc_int=yes ], [
|
||||
ac_cv_strerror_r_rc_int=no ], [
|
||||
- ac_cv_strerror_r_rc_int=no ] )
|
||||
+ ac_cv_strerror_r_rc_int=no ] ) ] )
|
||||
if test "x$ac_cv_strerror_r_rc_int" = xyes; then
|
||||
AC_DEFINE(STRERROR_R_RC_INT, 1, [Define if strerror returns int])
|
||||
- msg="int"
|
||||
-else
|
||||
- msg="pointer"
|
||||
fi
|
||||
-AC_MSG_RESULT([$msg])
|
||||
] )
|
||||
|
||||
dnl
|
||||
--- a/libs/apr/build/apr_common.m4
|
||||
+++ b/libs/apr/build/apr_common.m4
|
||||
@@ -514,8 +514,9 @@ dnl string.
|
||||
@ -57,34 +27,4 @@
|
||||
-AC_MSG_RESULT([$msg])
|
||||
] )
|
||||
|
||||
dnl
|
||||
--- a/libs/unimrcp/build/acmacros/apr_common.m4
|
||||
+++ b/libs/unimrcp/build/acmacros/apr_common.m4
|
||||
@@ -526,8 +526,9 @@ dnl string.
|
||||
dnl
|
||||
dnl
|
||||
AC_DEFUN([APR_CHECK_STRERROR_R_RC], [
|
||||
-AC_MSG_CHECKING(for type of return code from strerror_r)
|
||||
-AC_TRY_RUN([
|
||||
+AC_CACHE_CHECK([whether return code from strerror_r has type int],
|
||||
+[ac_cv_strerror_r_rc_int],
|
||||
+[AC_TRY_RUN([
|
||||
#include <errno.h>
|
||||
#include <string.h>
|
||||
#include <stdio.h>
|
||||
@@ -543,14 +544,10 @@ main()
|
||||
}], [
|
||||
ac_cv_strerror_r_rc_int=yes ], [
|
||||
ac_cv_strerror_r_rc_int=no ], [
|
||||
- ac_cv_strerror_r_rc_int=no ] )
|
||||
+ ac_cv_strerror_r_rc_int=no ] ) ] )
|
||||
if test "x$ac_cv_strerror_r_rc_int" = xyes; then
|
||||
AC_DEFINE(STRERROR_R_RC_INT, 1, [Define if strerror returns int])
|
||||
- msg="int"
|
||||
-else
|
||||
- msg="pointer"
|
||||
fi
|
||||
-AC_MSG_RESULT([$msg])
|
||||
] )
|
||||
|
||||
dnl
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -2263,7 +2263,12 @@ AC_SUBST(OUR_DISABLED_INSTALL_MODS)
|
||||
@@ -2289,7 +2289,12 @@ AC_SUBST(OUR_DISABLED_INSTALL_MODS)
|
||||
AC_SUBST(OUR_DISABLED_UNINSTALL_MODS)
|
||||
AC_SUBST(AM_MAKEFLAGS)
|
||||
|
||||
@ -14,22 +14,6 @@
|
||||
|
||||
# --prefix='$prefix' --exec_prefix='$exec_prefix' --libdir='$libdir' --libexecdir='$libexecdir' --bindir='$bindir' --sbindir='$sbindir' \
|
||||
# --localstatedir='$localstatedir' --datadir='$datadir'"
|
||||
--- a/libs/apr-util/configure.ac
|
||||
+++ b/libs/apr-util/configure.ac
|
||||
@@ -20,9 +20,10 @@ dnl Generate ./config.nice for reproduci
|
||||
dnl
|
||||
APR_CONFIG_NICE(config.nice)
|
||||
|
||||
-CFLAGS="$CFLAGS $CONFIGURE_CFLAGS"
|
||||
-CXXFLAGS="$CXXFLAGS $CONFIGURE_CXXFLAGS"
|
||||
-LDFLAGS="$LDFLAGS $CONFIGURE_LDFLAGS"
|
||||
+APR_ADDTO(CFLAGS, [$CONFIGURE_CFLAGS])
|
||||
+APR_ADDTO(CPPFLAGS, [$CONFIGURE_CPPFLAGS])
|
||||
+APR_ADDTO(CXXFLAGS, [$CONFIGURE_CXXFLAGS])
|
||||
+APR_ADDTO(LDFLAGS, [$CONFIGURE_LDFLAGS])
|
||||
|
||||
dnl # Some initial steps for configuration. We setup the default directory
|
||||
dnl # and which files are to be configured.
|
||||
--- a/libs/apr/configure.ac
|
||||
+++ b/libs/apr/configure.ac
|
||||
@@ -20,9 +20,10 @@ sinclude(build/apr_hints.m4)
|
||||
@ -44,7 +28,7 @@
|
||||
+APR_ADDTO(CXXFLAGS, [$CONFIGURE_CXXFLAGS])
|
||||
+APR_ADDTO(LDFLAGS, [$CONFIGURE_LDFLAGS])
|
||||
|
||||
dnl Hard-coded inclusion at the tail end of apr_private.h:
|
||||
dnl Hard-coded inclusion at the tail end of fspr_private.h:
|
||||
AH_BOTTOM([
|
||||
--- a/libs/iksemel/configure.ac
|
||||
+++ b/libs/iksemel/configure.ac
|
||||
@ -64,24 +48,6 @@
|
||||
|
||||
AC_CANONICAL_HOST
|
||||
|
||||
--- a/libs/libdingaling/configure.ac
|
||||
+++ b/libs/libdingaling/configure.ac
|
||||
@@ -8,9 +8,12 @@ AM_INIT_AUTOMAKE
|
||||
AC_CONFIG_SRCDIR([src])
|
||||
AC_CONFIG_HEADERS([src/config.h])
|
||||
|
||||
-CFLAGS="$CFLAGS $CONFIGURE_CFLAGS"
|
||||
-CXXFLAGS="$CXXFLAGS $CONFIGURE_CXXFLAGS"
|
||||
-LDFLAGS="$LDFLAGS $CONFIGURE_LDFLAGS"
|
||||
+m4_include(../apr/build/apr_common.m4)
|
||||
+
|
||||
+APR_ADDTO(CFLAGS, [$CONFIGURE_CFLAGS])
|
||||
+APR_ADDTO(CPPFLAGS, [$CONFIGURE_CPPFLAGS])
|
||||
+APR_ADDTO(CXXFLAGS, [$CONFIGURE_CXXFLAGS])
|
||||
+APR_ADDTO(LDFLAGS, [$CONFIGURE_LDFLAGS])
|
||||
|
||||
#Set default language
|
||||
AC_LANG_C
|
||||
--- a/libs/srtp/configure.ac
|
||||
+++ b/libs/srtp/configure.ac
|
||||
@@ -3,9 +3,12 @@ AC_INIT(srtp, 2.4.0, mcgrew@cisco.com)
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -585,8 +585,15 @@ libs/libedit/src/.libs/libedit.a:
|
||||
@@ -573,8 +573,15 @@ libs/libedit/src/.libs/libedit.a:
|
||||
libs/libzrtp/libzrtp.a:
|
||||
cd libs/libzrtp && $(MAKE)
|
||||
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- a/src/mod/endpoints/mod_verto/Makefile.am
|
||||
+++ b/src/mod/endpoints/mod_verto/Makefile.am
|
||||
@@ -12,8 +12,8 @@ if HAVE_PERL
|
||||
@@ -13,8 +13,8 @@ if HAVE_PERL
|
||||
#perldir = $(PERL_SITEDIR)
|
||||
noinst_LTLIBRARIES = MCAST.la
|
||||
MCAST_la_SOURCES = mcast/mcast_wrap.cpp mcast/perlxsi.c mcast/mcast.c mcast/mcast_cpp.cpp
|
||||
|
@ -1,28 +1,3 @@
|
||||
--- a/libs/apr-util/build/apr_common.m4
|
||||
+++ b/libs/apr-util/build/apr_common.m4
|
||||
@@ -493,13 +493,15 @@ AC_DEFUN([APR_TRY_COMPILE_NO_WARNING],
|
||||
if test "$ac_cv_prog_gcc" = "yes"; then
|
||||
CFLAGS="$CFLAGS -Werror"
|
||||
fi
|
||||
- AC_COMPILE_IFELSE([AC_LANG_SOURCE([
|
||||
- [#include "confdefs.h"
|
||||
- ]
|
||||
- [[$1]]
|
||||
- [int main(int argc, const char *const *argv) {]
|
||||
- [[$2]]
|
||||
- [ return 0; }]])],
|
||||
+ AC_COMPILE_IFELSE(
|
||||
+ [AC_LANG_SOURCE(
|
||||
+ [#include "confdefs.h"
|
||||
+ ]
|
||||
+ [[$1]]
|
||||
+ [int main(int argc, const char *const *argv) {]
|
||||
+ [[$2]]
|
||||
+ [ return 0; }]
|
||||
+ )],
|
||||
[$3], [$4])
|
||||
CFLAGS=$apr_save_CFLAGS
|
||||
])
|
||||
--- a/libs/apr/build/apr_common.m4
|
||||
+++ b/libs/apr/build/apr_common.m4
|
||||
@@ -493,13 +493,15 @@ AC_DEFUN([APR_TRY_COMPILE_NO_WARNING],
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- a/src/switch_rtp.c
|
||||
+++ b/src/switch_rtp.c
|
||||
@@ -2155,7 +2155,7 @@ static void switch_send_rtcp_event(switc
|
||||
switch_event_add_header_string(event, SWITCH_STACK_BOTTOM, header, value);
|
||||
snprintf(header, sizeof(header), "Source-Lost");
|
||||
#if SWITCH_BYTE_ORDER == __BIG_ENDIAN
|
||||
- tmpLost = report->lost; /* signed 24bit will extended signess to int32_t automatically */
|
||||
+ tmpLost = rtcp_report_block->lost; /* signed 24bit will extended signess to int32_t automatically */
|
||||
#else
|
||||
tmpLost = ntohl(rtcp_report_block->lost)>>8;
|
||||
tmpLost = tmpLost | ((tmpLost & 0x00800000) ? 0xff000000 : 0x00000000); /* ...and signess compensation */
|
@ -1,20 +0,0 @@
|
||||
--- a/src/mod/formats/mod_opusfile/mod_opusfile.c
|
||||
+++ b/src/mod/formats/mod_opusfile/mod_opusfile.c
|
||||
@@ -930,7 +930,7 @@ static int decode_stream_cb(void *dconte
|
||||
if (globals.debug) {
|
||||
switch_log_printf(SWITCH_CHANNEL_LOG, SWITCH_LOG_DEBUG, "[OGG/OPUS Stream Decode] decode CB called: context: %p data: %p packet_len: %d\n",
|
||||
(void *)context, data, nbytes);
|
||||
- switch_log_printf(SWITCH_CHANNEL_LOG, SWITCH_LOG_DEBUG, "[OGG/OPUS Stream Decode] decode_stream_cb(): switch_thread_self(): %lx\n", switch_thread_self());
|
||||
+ switch_log_printf(SWITCH_CHANNEL_LOG, SWITCH_LOG_DEBUG, "[OGG/OPUS Stream Decode] decode_stream_cb(): switch_thread_self(): %lx\n", (unsigned long)(intptr_t)switch_thread_self());
|
||||
}
|
||||
|
||||
switch_mutex_lock(context->ogg_mutex);
|
||||
@@ -973,7 +973,7 @@ static void *SWITCH_THREAD_FUNC read_str
|
||||
int buffered_ogg_bytes;
|
||||
|
||||
if (globals.debug) {
|
||||
- switch_log_printf(SWITCH_CHANNEL_LOG, SWITCH_LOG_DEBUG, "[OGG/OPUS Stream Decode] read_stream_thread(): switch_thread_self(): 0x%lx\n", switch_thread_self());
|
||||
+ switch_log_printf(SWITCH_CHANNEL_LOG, SWITCH_LOG_DEBUG, "[OGG/OPUS Stream Decode] read_stream_thread(): switch_thread_self(): 0x%lx\n", (unsigned long)(intptr_t)switch_thread_self());
|
||||
}
|
||||
switch_thread_rwlock_rdlock(context->rwlock);
|
||||
switch_mutex_lock(context->ogg_mutex);
|
@ -1,23 +0,0 @@
|
||||
From 9f26a15220b8b8b09c4debe41fe395d25d4cfeec Mon Sep 17 00:00:00 2001
|
||||
From: shaunjstokes <shaun@sysconfig.cloud>
|
||||
Date: Tue, 26 Oct 2021 18:25:14 +0200
|
||||
Subject: [PATCH] [mod_pgsql] Add support for postgresql 14
|
||||
|
||||
---
|
||||
src/mod/databases/mod_pgsql/mod_pgsql.c | 5 +++++
|
||||
1 file changed, 5 insertions(+)
|
||||
|
||||
--- a/src/mod/databases/mod_pgsql/mod_pgsql.c
|
||||
+++ b/src/mod/databases/mod_pgsql/mod_pgsql.c
|
||||
@@ -774,6 +774,11 @@ switch_status_t pgsql_next_result_timed(
|
||||
case PGRES_COPY_IN:
|
||||
case PGRES_COMMAND_OK:
|
||||
break;
|
||||
+#if POSTGRESQL_MAJOR_VERSION >= 14
|
||||
+ case PGRES_PIPELINE_ABORTED:
|
||||
+ case PGRES_PIPELINE_SYNC:
|
||||
+ break;
|
||||
+#endif
|
||||
case PGRES_EMPTY_QUERY:
|
||||
switch_log_printf(SWITCH_CHANNEL_LOG, SWITCH_LOG_DEBUG, "Query (%s) returned PGRES_EMPTY_QUERY\n", handle->sql);
|
||||
case PGRES_BAD_RESPONSE:
|
@ -1,6 +1,6 @@
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -1853,36 +1853,24 @@ then
|
||||
@@ -1865,36 +1865,24 @@ then
|
||||
fi
|
||||
AC_MSG_RESULT([$PYTHON3_VER])
|
||||
|
||||
|
@ -1,118 +0,0 @@
|
||||
commit a2ce46c6fde38d6ac54a8a2ee1a5b391e2ed2071
|
||||
Author: Sebastian Kemper <sebastian_ml@gmx.net>
|
||||
Date: Mon Nov 1 09:59:09 2021 +0100
|
||||
|
||||
[core] fix "--disable-libyuv"
|
||||
|
||||
Recent changes made it impossible to compile freeswitch without libyuv
|
||||
support.
|
||||
|
||||
src/switch_core_video.c: In function 'switch_img_read_from_file':
|
||||
src/switch_core_video.c:3139:4: error: implicit declaration of function 'RAWToI420' [-Werror=implicit-function-declaration]
|
||||
RAWToI420(data, width * 3,
|
||||
^
|
||||
src/switch_core_video.c:3148:4: error: implicit declaration of function 'ABGRToARGB' [-Werror=implicit-function-declaration]
|
||||
ABGRToARGB(data, width * 4, img->planes[SWITCH_PLANE_PACKED], img->stride[SWITCH_PLANE_PACKED], width, height);
|
||||
^
|
||||
|
||||
Fix this my adding/moving the checks for "SWITCH_HAVE_YUV".
|
||||
|
||||
Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
|
||||
|
||||
--- a/src/switch_core_video.c
|
||||
+++ b/src/switch_core_video.c
|
||||
@@ -3116,6 +3116,7 @@ SWITCH_DECLARE(switch_status_t) switch_i
|
||||
|
||||
SWITCH_DECLARE(switch_image_t *) switch_img_read_from_file(const char* file_name, switch_img_fmt_t img_fmt)
|
||||
{
|
||||
+#ifdef SWITCH_HAVE_YUV
|
||||
int width = 0, height = 0, channels = 0;
|
||||
int comp = STBI_rgb;
|
||||
unsigned char *data = NULL;
|
||||
@@ -3155,12 +3156,16 @@ SWITCH_DECLARE(switch_image_t *) switch_
|
||||
} else if (data) {
|
||||
stbi_image_free(data);
|
||||
}
|
||||
+#endif
|
||||
|
||||
return NULL;
|
||||
}
|
||||
|
||||
SWITCH_DECLARE(switch_status_t) switch_img_write_to_file(switch_image_t *img, const char* file_name, int quality)
|
||||
{
|
||||
+#ifndef SWITCH_HAVE_YUV
|
||||
+ return SWITCH_STATUS_FALSE;
|
||||
+#else
|
||||
int comp = STBI_rgb;
|
||||
unsigned char *data = NULL;
|
||||
const char *ext = strrchr(file_name, '.');
|
||||
@@ -3217,6 +3222,7 @@ SWITCH_DECLARE(switch_status_t) switch_i
|
||||
free(data);
|
||||
|
||||
return ret ? SWITCH_STATUS_SUCCESS : SWITCH_STATUS_FALSE;
|
||||
+#endif
|
||||
}
|
||||
|
||||
typedef struct data_url_context_s {
|
||||
@@ -3224,14 +3230,19 @@ typedef struct data_url_context_s {
|
||||
char **urlP;
|
||||
} data_url_context_t;
|
||||
|
||||
+#ifdef SWITCH_HAVE_YUV
|
||||
static void data_url_write_func(void *context, void *data, int size)
|
||||
{
|
||||
switch_buffer_t *buffer = (switch_buffer_t *)context;
|
||||
switch_buffer_write(buffer, data, size);
|
||||
}
|
||||
+#endif
|
||||
|
||||
SWITCH_DECLARE(switch_status_t) switch_img_data_url(switch_image_t *img, char **urlP, const char *type, int quality)
|
||||
{
|
||||
+#ifndef SWITCH_HAVE_YUV
|
||||
+ return SWITCH_STATUS_FALSE;
|
||||
+#else
|
||||
int comp = STBI_rgb;
|
||||
unsigned char *data = NULL;
|
||||
int stride_in_bytes = 0;
|
||||
@@ -3300,6 +3311,7 @@ SWITCH_DECLARE(switch_status_t) switch_i
|
||||
switch_buffer_destroy(&buffer);
|
||||
|
||||
return ret ? SWITCH_STATUS_SUCCESS : SWITCH_STATUS_FALSE;
|
||||
+#endif /* SWITCH_HAVE_YUV */
|
||||
}
|
||||
|
||||
|
||||
--- a/tests/unit/switch_core_video.c
|
||||
+++ b/tests/unit/switch_core_video.c
|
||||
@@ -48,6 +48,7 @@ FST_CORE_BEGIN("./conf")
|
||||
}
|
||||
FST_TEARDOWN_END()
|
||||
|
||||
+#ifdef SWITCH_HAVE_YUV
|
||||
FST_TEST_BEGIN(data_url_test)
|
||||
{
|
||||
char *data_url = NULL;
|
||||
@@ -88,6 +89,7 @@ FST_CORE_BEGIN("./conf")
|
||||
unlink(argb_filename);
|
||||
}
|
||||
FST_TEST_END()
|
||||
+#endif /* SWITCH_HAVE_YUV */
|
||||
|
||||
FST_TEST_BEGIN(img_patch)
|
||||
{
|
||||
@@ -239,6 +241,7 @@ FST_CORE_BEGIN("./conf")
|
||||
}
|
||||
FST_TEST_END()
|
||||
|
||||
+#ifdef SWITCH_HAVE_YUV
|
||||
FST_TEST_BEGIN(stb_data_url)
|
||||
{
|
||||
switch_image_t *img = switch_img_alloc(NULL, SWITCH_IMG_FMT_I420, 120, 60, 1);
|
||||
@@ -321,6 +324,7 @@ FST_CORE_BEGIN("./conf")
|
||||
unlink(jpg_write_filename);
|
||||
}
|
||||
FST_TEST_END()
|
||||
+#endif /* SWITCH_HAVE_YUV */
|
||||
}
|
||||
FST_SUITE_END()
|
||||
}
|
@ -62,7 +62,7 @@ The most portable fix for time_t handling is to always cast it to
|
||||
#else
|
||||
--- a/src/mod/applications/mod_httapi/mod_httapi.c
|
||||
+++ b/src/mod/applications/mod_httapi/mod_httapi.c
|
||||
@@ -2745,7 +2745,7 @@ static switch_status_t write_meta_file(h
|
||||
@@ -2744,7 +2744,7 @@ static switch_status_t write_meta_file(h
|
||||
|
||||
switch_snprintf(write_data, sizeof(write_data),
|
||||
"%" TIME_T_FMT ":%s",
|
||||
|
@ -12,7 +12,7 @@ Reported-by: Sebastian Kemper <sebastian_ml@gmx.net>
|
||||
|
||||
--- a/src/switch_core_sqldb.c
|
||||
+++ b/src/switch_core_sqldb.c
|
||||
@@ -3551,7 +3551,7 @@ SWITCH_DECLARE(switch_status_t) switch_c
|
||||
@@ -3549,7 +3549,7 @@ SWITCH_DECLARE(switch_status_t) switch_c
|
||||
if (force) {
|
||||
sql = switch_mprintf("delete from registrations where hostname='%q'", switch_core_get_switchname());
|
||||
} else {
|
||||
|
Loading…
Reference in New Issue
Block a user