tvheadend: moved to github

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>


git-svn-id: svn://svn.openwrt.org/openwrt/packages@46331 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
hauke 2015-07-13 19:50:05 +00:00
parent e897dab63f
commit 07eefeb4c9
5 changed files with 0 additions and 127 deletions

View File

@ -1,21 +0,0 @@
config TVHEADEND_CWC_SUPPORT
bool "NewCamD support"
default n
config TVHEADEND_V4L_SUPPORT
bool "Video4Linux v2 support"
default n
config TVHEADEND_LINUXDVB_SUPPORT
bool "Linux DVB support"
default n
config TVHEADEND_DVBSCAN_SUPPORT
bool "Fetch DVB-scan data"
depends on TVHEADEND_LINUXDVB_SUPPORT
default TVHEADEND_LINUXDVB_SUPPORT
config TVHEADEND_AVAHI_SUPPORT
bool "Avahi client support"
select PACKAGE_libavahi-client
default n

View File

@ -1,79 +0,0 @@
#
# Copyright (C) 2012 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk
PKG_NAME:=tvheadend
PKG_VERSION:=3.4patch1
PKG_RELEASE:=0.1
PKG_SOURCE:=$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/tvheadend/tvheadend/archive/
PKG_MD5SUM:=86d1be0ad6e02bd2aecd3d529a026797
PKG_USE_MIPS16:=0
include $(INCLUDE_DIR)/package.mk
define Package/tvheadend
SECTION:=multimedia
CATEGORY:=Multimedia
TITLE:=Tvheadend is a TV streaming server for Linux
DEPENDS:=+libcurl +libopenssl +librt +zlib +TVHEADEND_AVAHI_SUPPORT:libavahi-client
URL:=https://tvheadend.org/
endef
define Package/tvheadend/description
Tvheadend is a TV streaming server for Linux supporting DVB, ATSC, IPTV,
and Analog video (V4L) as input sources.
Can be used as a backend to Showtime, XBMC and various other clients.
endef
define Package/tvheadend/config
menu "Configuration"
depends on PACKAGE_tvheadend
source "$(SOURCE)/Config.in"
endmenu
endef
ifeq ($(CONFIG_TVHEADEND_CWC_SUPPORT),)
CONFIGURE_ARGS += --disable-cwc
endif
ifeq ($(CONFIG_TVHEADEND_V4L_SUPPORT),)
CONFIGURE_ARGS += --disable-v4l
endif
ifeq ($(CONFIG_TVHEADEND_LINUXDVB_SUPPORT),)
CONFIGURE_ARGS += --disable-linuxdvb
endif
ifeq ($(CONFIG_TVHEADEND_DVBSCAN_SUPPORT),)
CONFIGURE_ARGS += --disable-dvbscan
endif
ifeq ($(CONFIG_TVHEADEND_AVAHI_SUPPORT),)
CONFIGURE_ARGS += --disable-avahi
else
CONFIGURE_ARGS += --enable-avahi
endif
CONFIGURE_ARGS += \
--release \
--enable-bundle
define Package/tvheadend/install
$(INSTALL_DIR) $(1)/etc/tvheadend
$(INSTALL_DIR) $(1)/etc/init.d
$(INSTALL_BIN) ./files/tvheadend.init $(1)/etc/init.d/tvheadend
$(INSTALL_DIR) $(1)/lib/upgrade/keep.d
$(INSTALL_DATA) ./files/tvheadend.upgrade $(1)/lib/upgrade/keep.d/tvheadend
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/build.linux/tvheadend $(1)/usr/bin/
endef
$(eval $(call BuildPackage,tvheadend))

View File

@ -1,15 +0,0 @@
#!/bin/sh /etc/rc.common
# Copyright (C) 2012 OpenWrt.org
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
START=80
start() {
service_start /usr/bin/tvheadend -f -c /etc/tvheadend
}
stop() {
service_stop /usr/bin/tvheadend
}

View File

@ -1 +0,0 @@
/etc/tvheadend

View File

@ -1,11 +0,0 @@
--- a/Makefile
+++ b/Makefile
@@ -282,7 +282,7 @@ include support/${OSENV}.mk
# Bundle files
$(BUILDDIR)/bundle.o: $(BUILDDIR)/bundle.c
@mkdir -p $(dir $@)
- $(CC) -I${CURDIR}/src -c -o $@ $<
+ $(CC) $(CFLAGS) -I${CURDIR}/src -c -o $@ $<
$(BUILDDIR)/bundle.c:
@mkdir -p $(dir $@)