[patch-team] A python package for generating eeml documents. In particular can be used to send sensor data to pachube (https://pachube.com/) - Signed-off-by: Roberto Riggio <roberto.riggio@create-net.org>

git-svn-id: svn://svn.openwrt.org/openwrt/packages@29426 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
dingo 2011-12-04 20:42:46 +00:00
parent 9824569a5f
commit 676e3d7d84
2 changed files with 64 additions and 0 deletions

52
lang/python-eeml/Makefile Normal file
View File

@ -0,0 +1,52 @@
#
# Copyright (C) 2008-2011 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk
PKG_NAME:=python-eeml
PKG_VERSION:=20111202
PKG_RELEASE:=1
PKG_REV:=9f0173e56a0b2a0ae7d3a2c76eb5428381912ac6
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=git://github.com/petervizi/python-eeml.git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE_VERSION:=$(PKG_REV)
PKG_SOURCE_PROTO:=git
PKG_BUILD_DEPENDS:=python
include $(INCLUDE_DIR)/package.mk
$(call include_mk, python-package.mk)
define Package/python-eeml
SUBMENU:=Python
SECTION:=lang
CATEGORY:=Languages
TITLE:=python-eeml
URL:=http://petervizi.github.com/python-eeml/
DEPENDS:=+python +distribute
endef
define Package/python-eeml/description
A python package for generating eeml documents.
endef
define Build/Compile
$(call Build/Compile/PyMod,., \
install --prefix="/usr" --root="$(PKG_INSTALL_DIR)", \
)
endef
define Package/python-eeml/install
$(INSTALL_DIR) $(1)$(PYTHON_PKG_DIR)
$(CP) \
$(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)/* \
$(1)$(PYTHON_PKG_DIR)/
endef
$(eval $(call BuildPackage,python-eeml))

View File

@ -0,0 +1,12 @@
--- a/setup.py
+++ b/setup.py
@@ -1,5 +1,6 @@
-from setuptools import setup
-from setuptools import find_packages
+#!/usr/bin/env python
+
+from distutils.core import setup
setup(name="Python EEML",
version="0.1",