mirror of
http://git.openwrt.org/packages.git
synced 2025-01-09 04:19:54 +08:00
[packages] add sslsniff (thanks to David Cooper)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@14642 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
188c291179
commit
75f24c7cac
52
net/sslsniff/Makefile
Normal file
52
net/sslsniff/Makefile
Normal file
@ -0,0 +1,52 @@
|
||||
#
|
||||
# Copyright (C) 2009 David Cooper <dave@kupesoft.com>
|
||||
# Copyright (C) 2009 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
# $Id$
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=sslsniff
|
||||
PKG_VERSION:=0.5
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
|
||||
PKG_SOURCE_URL:=http://www.thoughtcrime.org/software/sslsniff
|
||||
PKG_MD5SUM:=24653e2c4f1ca94328520667eb756369
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/sslsniff
|
||||
SECTION:=net
|
||||
CATEGORY:=Network
|
||||
TITLE:=SSL man-in-the-middle attack
|
||||
URL:=http://www.thoughtcrime.org/software/sslsniff/index.html
|
||||
DEPENDS:=+libopenssl
|
||||
endef
|
||||
|
||||
define Package/sslsniff/description
|
||||
sslsniff is designed to MITM all SSL connections on a LAN,
|
||||
and dynamically generates certs for the domains that are
|
||||
being accessed on the fly. The new certificates are constructed
|
||||
in a certificate chain that is signed by any certificate that
|
||||
you provide.
|
||||
endef
|
||||
|
||||
# Take this opportunity to remove the pre-packaged x86 binary
|
||||
define Build/Prepare
|
||||
$(call Build/Prepare/Default)
|
||||
$(RM) $(PKG_BUILD_DIR)/sslsniff
|
||||
endef
|
||||
|
||||
MAKE_FLAGS += CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS) $(TARGET_LDFLAGS)"
|
||||
|
||||
define Package/sslsniff/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/sslsniff $(1)/usr/bin/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,sslsniff))
|
||||
|
24
net/sslsniff/patches/01-cross-compile.patch
Normal file
24
net/sslsniff/patches/01-cross-compile.patch
Normal file
@ -0,0 +1,24 @@
|
||||
diff -ruN sslsniff-0.5.orig/Makefile sslsniff-0.5/Makefile
|
||||
--- sslsniff-0.5.orig/Makefile 2009-02-16 12:00:36.000000000 -0500
|
||||
+++ sslsniff-0.5/Makefile 2009-02-23 11:14:22.000000000 -0500
|
||||
@@ -1,4 +1,7 @@
|
||||
+CC := gcc
|
||||
+CFLAGS := -g -Wall
|
||||
+
|
||||
all:
|
||||
- gcc -g -Wall -o sslsniff cache.c sslsniff.c network.c mx509.c mssl.c log.c -lcrypto -lssl
|
||||
+ $(CC) $(CFLAGS) -o sslsniff cache.c sslsniff.c network.c mx509.c mssl.c log.c -lcrypto -lssl
|
||||
clean:
|
||||
rm sslsniff
|
||||
\ No newline at end of file
|
||||
diff -ruN sslsniff-0.5.orig/network.c sslsniff-0.5/network.c
|
||||
--- sslsniff-0.5.orig/network.c 2009-02-16 12:00:36.000000000 -0500
|
||||
+++ sslsniff-0.5/network.c 2009-02-23 10:45:37.000000000 -0500
|
||||
@@ -27,6 +27,7 @@
|
||||
* SUCH DAMAGE.
|
||||
*/
|
||||
|
||||
+#include <limits.h>
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
#include <unistd.h>
|
Loading…
Reference in New Issue
Block a user