mirror of
http://git.openwrt.org/packages.git
synced 2025-01-07 03:17:29 +08:00
mutt: moved to github
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> git-svn-id: svn://svn.openwrt.org/openwrt/packages@48566 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
e4ab2f1809
commit
77aa47e523
@ -1,48 +0,0 @@
|
||||
#
|
||||
# Copyright (C) 2006-2010 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=mutt
|
||||
PKG_VERSION:=1.5.21
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE_URL:=@SF/mutt
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_MD5SUM:=a29db8f1d51e2f10c070bf88e8a553fd
|
||||
|
||||
PKG_INSTALL:=1
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/mutt
|
||||
SECTION:=mail
|
||||
CATEGORY:=Mail
|
||||
DEPENDS:=+libopenssl +libncursesw
|
||||
TITLE:=Console mail client
|
||||
URL:=http://www.mutt.org/
|
||||
endef
|
||||
|
||||
define Package/mutt/description
|
||||
Mutt is a small but very powerful text-based mail client for Unix
|
||||
operating systems.
|
||||
endef
|
||||
|
||||
CONFIGURE_ARGS += \
|
||||
--includedir=$(PKG_BUILD_DIR)/. \
|
||||
--oldincludedir=$(PKG_BUILD_DIR)/. \
|
||||
--enable-pop \
|
||||
--enable-imap \
|
||||
--with-ssl \
|
||||
--without-idn
|
||||
|
||||
define Package/mutt/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/mutt $(1)/usr/bin/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,mutt))
|
@ -1,11 +0,0 @@
|
||||
--- a/Makefile.in
|
||||
+++ b/Makefile.in
|
||||
@@ -342,7 +342,7 @@ top_srcdir = @top_srcdir@
|
||||
AUTOMAKE_OPTIONS = 1.6 foreign
|
||||
@BUILD_IMAP_TRUE@IMAP_SUBDIR = imap
|
||||
@BUILD_IMAP_TRUE@IMAP_INCLUDES = -I$(top_srcdir)/imap
|
||||
-SUBDIRS = m4 po intl doc contrib $(IMAP_SUBDIR)
|
||||
+SUBDIRS = m4 intl contrib $(IMAP_SUBDIR)
|
||||
bin_SCRIPTS = muttbug flea @SMIMEAUX_TARGET@
|
||||
@BUILD_HCACHE_TRUE@HCVERSION = hcversion.h
|
||||
BUILT_SOURCES = keymap_defs.h patchlist.c reldate.h $(HCVERSION)
|
Loading…
Reference in New Issue
Block a user