mirror of
http://git.openwrt.org/packages.git
synced 2025-01-09 04:19:54 +08:00
tcsh: move to github
Signed-off-by: Nuno Goncalves <nunojpg@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/packages@42562 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
a927f9d39e
commit
84293b87ee
@ -1,53 +0,0 @@
|
||||
#
|
||||
# Copyright (C) 2011 Nuno Goncalves <nunojpg@gmail.com>
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=tcsh
|
||||
PKG_VERSION:=6.17.00
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=ftp://ftp.astron.com/pub/tcsh/
|
||||
PKG_MD5SUM:=c47de903e3d52f6824c8dd0c91eeb477
|
||||
|
||||
PKG_MAINTAINER:=Nuno Goncalves <nunojpg@gmail.com>
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/tcsh
|
||||
SECTION:=utils
|
||||
CATEGORY:=Utilities
|
||||
TITLE:=Enhanced Berkeley UNIX C shell
|
||||
DEPENDS:=+libncurses
|
||||
URL:=http://www.tcsh.org/
|
||||
endef
|
||||
|
||||
define Package/tcsh/description
|
||||
Tcsh is an enhanced, but completely compatible
|
||||
version of the Berkeley UNIX C shell (csh). It
|
||||
is a command language interpreter usable both
|
||||
as an interactive login shell and a shell
|
||||
script command processor. It includes a
|
||||
command-line editor, programmable word
|
||||
completion, spelling correction, a history
|
||||
mechanism, job control and a C-like syntax.
|
||||
endef
|
||||
|
||||
define Package/tcsh/postinst
|
||||
#!/bin/sh
|
||||
grep tcsh $${IPKG_INSTROOT}/etc/shells || \
|
||||
echo "/bin/tcsh" >> $${IPKG_INSTROOT}/etc/shells
|
||||
echo "/bin/csh" >> $${IPKG_INSTROOT}/etc/shells
|
||||
endef
|
||||
|
||||
define Package/tcsh/install
|
||||
$(INSTALL_DIR) $(1)/bin
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/tcsh $(1)/bin/
|
||||
ln -sf tcsh $(1)/bin/csh
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,tcsh))
|
@ -1,11 +0,0 @@
|
||||
--- a/Makefile.in
|
||||
+++ b/Makefile.in
|
||||
@@ -365,7 +365,7 @@
|
||||
|
||||
gethost: gethost.c sh.err.h tc.const.h sh.h
|
||||
rm -f gethost
|
||||
- ${CC} -o gethost ${LDFLAGS} ${CFLAGS} ${CPPFLAGS} ${DFLAGS} $(srcdir)/gethost.c ${LIBES} ${EXTRALIBS}
|
||||
+ gcc -o gethost -g -O2 -I. -I. -D_PATH_TCSHELL='"/usr/local/bin/tcsh"' $(srcdir)/gethost.c ${LIBES} ${EXTRALIBS}
|
||||
|
||||
tc.defs.c: gethost host.defs
|
||||
@rm -f $@.tmp
|
@ -1,9 +0,0 @@
|
||||
--- a/config/linux
|
||||
+++ b/config/linux
|
||||
@@ -106,6 +106,4 @@
|
||||
#endif
|
||||
#define ECHO_STYLE BOTH_ECHO
|
||||
|
||||
-#define NLS_CATALOGS
|
||||
-
|
||||
#endif /* _h_config */
|
Loading…
Reference in New Issue
Block a user